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Cakewalk Next® Introduction
Welcome to Cakewalk Next®!

Cakewalk Next® is a cross-platform digital audio workstation (DAW) that offers cloud-based project sync and interchange.

Take an idea from the BandLab mobile app, then continue working on it on your desktop. Or export your desktop projects to your 
BandLab library and take advantage of all the benefits the BandLab platform offers, including:

Continue working on your songs from anywhere using the free BandLab app for iOS and Android

Check the mix in your car by connecting via Bluetooth to your car stereo

Use Google Chromecast to stream songs to your HDTV or home audio hi-fi system

Collaborate with other musicians privately or publicly on BandLab

To launch Cakewalk Next®, do one of the following:

Double-click the Next shortcut on your desktop 

Windows: Find Next in the Start Menu under Next

Mac: Select the Launchpad icon on the Dock, then click the Cakewalk Next® app icon

To quickly learn the basics of using Next, see “Quick Tutorials” on page 271.
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See:

“UI overview” on page 9

“Enabling input and output devices” on page 24

“Creating and saving projects” on page 24

“Inserting tracks” on page 28

“Using track templates” on page 32

“Scrolling and zooming” on page 37

“Installing Cakewalk Next®” on page 38

“Activating Cakewalk Next®” on page 40

“Support” on page 42

See also:

“Playback” on page 43

“Recording” on page 49

“Virtual MIDI Controller” on page 69

“Loop Browser” on page 71

“Inspectors” on page 87

“Editing” on page 127

“Mixing” on page 187

“Effects” on page 193

“Automation” on page 211

“Exporting” on page 241

“Preferences” on page 247

“Menu commands” on page 259

“Keyboard shortcuts” on page 265
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UI overview
Figure 1. Cakewalk Next® UI.

A. Menu B. Insert track C. Tracks and buses D. Arranger inspector E. Main toolbar F. Clips pane G. Inspectors (track/clip/lyrics) H. Loop 
Browser

Menu. The menu contains various commands for using Next. For details, see “Menu commands” on page 259.

Main toolbar. The main toolbar provides convenient access to frequently used controls, including project information, tempo, 
metronome, transport, and monitor level. For details, see “Main Toolbar / Transport” on page 10.

Track, bus, and folder channel strips. The Track pane shows a channel strip for each track, bus, and track folder. For details, 
see “Track/Bus/Track Folder controls” on page 13 and “Track folders” on page 17.

Clips pane. The Clips pane shows the clips in your project on a timeline that helps you visualize how your project is organized. 
For details, see “Clips pane” on page 15 and “Editing clips” on page 134.

Time ruler. Shows the project timeline in measures and beats, absolute time, or samples. For details, see “Time ruler” on page 
16.

Click to set the playback position.

Double-click to start playback.

Drag to make a time selection.

Right-click to change the display format.

 Inspectors. Inspector provide easy access to relevant settings and content.

Loop Browser. The Loop Browser lets you access and import a professionally curated selection of premium audio packs, 
loops, and one-shots right from within Next. Just drag & drop directly into tracks. For details, see “Loop Browser” on page 71.

Track Inspector. The Track Inspector lets you add effects and configure input echo, input, output, and sends for the 
selected track/bus/folder (see “Track Inspector” on page 89).

Clip Inspector. The Clip Inspector lets you edit instrument tracks with a Piano Roll interface (see “Clip inspector / Piano Roll 
view” on page 94).

Arranger Inspector. The Arranger Inspector shows all the arranger sections defined in the project’s timeline, and allows 
you to create unlimited different arrangements of the current project. Each arrangement can contain any combination of 
sections, in any order. For details, see “Arranger” on page 101 and “Arranger Inspector” on page 106.

Lyrics Inspector. The Lyrics Inspector can toggle between showing the Lyrics Editor (and Lyrics Scratch Pad) and Lyrics 
Prompter. For details, see “Lyrics” on page 221 and “Lyrics Inspector” on page 225.
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Main Toolbar / Transport

Figure 2. Main toolbar.

A. Project Information B. Export audio or publish to BandLab C. Metronome D. Tempo E. Loop playback F. Jump Back G. Play/Pause H. Jump 
Forward I. Record J. Now time K. Monitor Mute L. Main level and meter M. Show Loop Browser

The main toolbar contains the following controls:

Project Information. Shows the project thumbnail image, title, author, and album. Click to open the Project Information Editor 
(see “Project Information” on page 26).

Share . Export audio or publish to BandLab. For details, see “Exporting” on page 241.

Metronome  /  /  / . Enable/disable the metronome. Click the drop-down menu  to configure metronome 
settings and use tap tempo. For details, see “Using the metronome” on page 62.

Tempo. The current tempo at the Now time. Double-click to change the current tempo. To use tap tempo, open the Metronome 
Options menu.

Transport. The toolbar contains common transport controls:

Toggle Loop Playback  / . Enable/disable playback looping (see “Looping” on page 44).

Jump Back . Rewind the playback position and seek to loop positions and the playback marker en route to the project 
start.

Play/Pause  / . Start/pause playback.

Jump Forward . Jump forward and seek to loop positions en route to the project end.

Record  / . Start/stop recording on any armed tracks (see “Recording” on page 49). Click the drop-down menu  
to configure recording settings.

• When punch recording is enabled, the Record button looks like  /  (see “Punch recording” on page 57).

Now Time. Shows the current playback position. To change the time format, select one of the following menu options:

View > Display Musical Time. Measure:Beat:Tick

View > Display Absolute Time. Minute:Second:Millisecond

View > Display Sample Time. Sample

Monitor Mute  / . Mute the main output.

Monitor Level and meter. The overall volume level for all tracks in the project, ranging from -INF (silent) to +6 dB (maximum 
volume). Double-click to reset. The main meter sum pairs of output channels into a single stereo meter.

Show Loop Browser . Show/hide the Loop Browser (see “Loop Browser” on page 71).

Notifications . Show/hide notifications. The button shows a red circle  if there are any notifications.

See also:

“Menu commands” on page 259
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Track pane

The Track pane contains the following items:

 Insert track . Open a menu that lets you select a track type to insert:

Mic/Line In . Record your voice or any sound using a microphone. Click the icon to create a blank track. Use the 
submenu to select any available track template. 

 Instrument . Play and record a virtual instrument using a MIDI device or your computer keyboard. 

Sampler . Use MIDI to play back loops, one-shots, audio clips or local audio files. 

Pad Controller . Use MIDI to trigger up to 16 sampler or instrument pads. 

 Instrument Rack . Use MIDI to trigger up to 16 layered instruments simultaneously within a single track.

Bus . Create a bus that can be used to process many tracks. 

Track Folder . A track folder may contain other tracks, buses, and folders. Useful for project organization and mixing. 

Show/Hide Automation Lanes . Show/hide automation lanes in track strips. Select the visible automation parameter from 

each track’s Automation menu. To arm automation for recording, click the Show/Hide Automation Lanes button  drop-

down menu  and select Capture automation changes during playback/record. A red circle  indicates that automation 
recording is enabled, and all automatable controls show a small red circle. For details, see “Automation” on page 211.

Global MSR  / . The global MSR toggle buttons indicate if any tracks are muted, soloed, armed for recording, or have 
monitoring enabled. The four toggle buttons allow you to toggle the on-state for the Mute/Solo/Arm/Monitor parameters.

Toggling off a global MSR button results in toggling off this state for all tracks

Toggling on a global MSR button results in restoring the on cached state for any such tracks

A global MSR button is disabled if there are no associated cache states to restore

To toggle off the Mute, Solo, Arm, or Monitor state and clear the associated cache, hold down the CTRL (Windows) / CMD 
(Mac) key and click the corresponding global MSR button

Track View Options . The Track View Options menu contains the following:

Arranger. Show/hide the Arranger track, which allows you to create arbitrary song sections anywhere on the project 
timeline, then later string them together for seamless playback. For details, see “Arranger” on page 101.

Lyrics. Show/hide the Lyrics track, which allows you to edit the time ranges of lyric events. For details, see “Lyrics” on page 
221.

Tempo. Show/hide the Tempo track, which provides a graphic overview of the project tempo and allows you to create and 
edit tempo changes within a project. For details, see “Tempo” on page 63.

Show meter values. Show dB values on track meters.

Fit Vertically. Resize tracks vertically to fill the Track pane.

Zoom to fit. Zoom the selection horizontally.

Track height presets. Quickly resize all tracks vertically.

Expand track folders. Expand all track folders.

Collapse track folders. Collapse all track folders.

Meter (time signature) . Specify the project’s time signature (the number of beats per measure and the note value of 
each beat). For details, see “Setting the project meter (time signature)” on page 47.
UI overview



Ripple Edit . Ripple editing allows you to adjust the position of a clip in the Track view, and automatically adjust the start 
position of all subsequent clips to compensate for the change. For details, see “Ripple editing” on page 139). You can choose to 

ripple edit just the selection, or all tracks. Click the Enable/Disable Ripple Editing button  drop-down menu  to specify the 
ripple mode:

Ripple Edit Selection . Only selected tracks, or tracks included via range selection within the clips pane are affected.

Ripple Edit All . Any edit on any track affects all tracks, including Arranger and Lyric track data.

Snap to Grid . The snap grid makes it easy to align clips and note events, select time ranges, set the loop region, and 
control automation envelope drawing. When drawing, moving, and resizing objects, the objects will snap to the nearest point on 
the snap grid. For details, see “Using the Snap Grid” on page 147).

Track, bus, and folder channel strip(s). Each track, bus, and track folder is represented by its own channel strip. For details, 
see “Track/Bus/Track Folder controls” on page 13 and “Track folders” on page 17.

Resizing the Track pane

To resize the Track pane horizontally, drag the splitter bar that divides the Track pane and Clips pane.
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Track/Bus/Track Folder controls

Each track/bus/folder contains the following controls.

A. Icon B. Name C. Mute D. Solo E. Record Arm F. Track Monitor G. Color H. Meter I. Volume J. Pan

Color. Track colors make it easy to distinguish tracks. Inserted tracks cycle through 6 hard-coded colors. Right-click the color 
bar to change the track color.

 Icon. Default track icons are used to distinguish between different track types:

  = Audio track

  = Instrument track

  = Sampler track

  = Pad Controller track

  = Instrument Rack track

  = Folder track

  = Bus

Name. The Name control lets you assign a descriptive name to each track. Double-click to edit.

Mute  / . Mute the track so it is silenced during playback.

Solo  / . Solo the track. Only soloed tracks are audible during playback if at least one track is soloed.

 Audio track:

Instrument track:

Sampler track: Pad Controller track:

A B C

H I

G

Bus:Folder track:

J

D E F
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Record Arm  /  / . Not available on buses and track folders. For details, see “Arming tracks for recording” on page 54.

By default, the focused track is auto armed, as indicated by a red hollow circle . This is useful for single track recording. 
For details, see “Auto arm track for recording” on page 54.

A solid circle  indicates a manually armed track, which useful for multitrack recording.

Track Monitor  / . Enable/disable input monitoring, which allows you to hear plugin audio effects applied to the live 
signal.

Level meter. Displays the playback level. Right-click to toggle between pre and post fader and pre/post FX):

 Input. The signal is taken from before the channel volume fader and before effects.

Pre Fader. The signal is taken from before the channel volume fader and after effects.

Post Fader.  The signal is taken from after the channel volume fader.

To show meter values, click the Track View Options menu button  and select Show meter values.

Volume. The current volume level for the track, ranging from -INF (silent) to +6 dB (maximum volume). Double-click to reset.

Pan. The stereo distribution of the output, ranging from -50 (hard left) to +50 (hard right). Double-click to reset.

See:

“Inserting tracks” on page 28

“Grouping tracks with track folders” on page 35

“Importing audio” on page 61

“Editing tracks & track folders” on page 128

“Editing” on page 127

See also:

“Track Inspector” on page 89

“Clip inspector / Piano Roll view” on page 94
14 Cakewalk Next® Introduction
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Clips pane

The Clips pane contains the following elements.

A. Now Time marker B. Time ruler C. Clip D. Composite folder clip E. Scroll bars

Now Time marker. Shows the current playback position. To change the time format, select one of the following menu options:

View > Display Musical Time. Measure:Beat:Tick

View > Display Absolute Time. Minute:Second:Millisecond

View > Display Sample Time. Sample

Time ruler. Shows the project timeline in measures and beats. Click to change the playback position.

Audio/MIDI clips. Each recorded or imported audio/MIDI file appears as a separate clip. For details, see “Editing clips” on page 
134.

Composite folder clips. Each parent track folder shows a composite clip of its child clips.

Scroll bars. Use the horizontal and vertical scroll bars to navigate the project. You can also use the mouse wheel to scroll 
horizontally.
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Time ruler

Figure 3. Time Ruler.

A. Time selection B. Playback start position C. Loop (and punch record) range

The Time ruler appears in the Clips pane and Clip Inspector’s Piano Roll. It has several functions, including:

Showing the playback position. During playback the vertical Now Time marker shows the current playback position.

Changing the Now time. Click to set the playback position.

Starting playback. Double-click to start playback.

Making a time selection. Point the mouse pointer at the bottom 1/3 until the mouse pointer looks like , then drag left/right 
to make a time selection. The Time ruler follows the Snap to Grid settings, if enabled.

Zooming horizontally. Point the mouse pointer in the middle 1/3 until the mouse pointer looks like , then drag up/down to 
zoom horizontally.

Setting the loop region. Drag in the top 1/3 to set the loop region. Right-click to toggle loop on/off.

Setting the punch record region. Drag in the top 1/3 to set the punch region. When punch recording is enabled, the blue loop 
markers turn red to indicate the punch region.

To change the time ruler format, select one of the following menu options:

View > Display Musical Time. Measure:Beat:Tick

View > Display Absolute Time. Minute:Second:Millisecond

View > Display Sample Time. Sample

See:

“Setting the playback position” on page 44

“Setting the loop region” on page 45

“Zooming” on page 37

“Making a time selection” on page 127
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Track folders

A track folder is a special track type that can contain multiple audio, bus, and instrument tracks, as well as other track folders. A track 
folder functions as a submix, or bus, for its child tracks. There is no limit to the number of tracks a track folder can contain, but when 
exporting to BandLab, each top-level track folder exports as a single audio file.

Each track folder contains the following controls.

A. Expand/collapse folder B. Icon C. Name D. Mute E. Solo F. Color G. Meter H. Volume I. Pan

Color. Colors make it easy to distinguish track folders. Right-click the track header and select Track Color to change the track 
folder color. You can also change the track color in the Track Inspector.

Expand/Collapse. Click the arrow button (  / ) to expand/collapse the folder.

 Icon. The track folder icon is used to distinguish between audio tracks, buses, instrument tracks, and folders. 

Name. The Name control lets you assign a descriptive name to each track folder. Double-click to edit.

Mute  / . Mute the track folder so it is silenced during playback.

Solo  / . Solo the track folder. Only soloed tracks/buses/folders are audible during playback if at least one track/bus/
folder is soloed.

Volume. The overall volume level for all tracks in the folder, ranging from -INF (silent) to +6 dB (maximum volume). Double-click 
to reset.

Pan. The stereo distribution of the output, ranging from -50 (hard left) to +50 (hard right). Double-click to reset.
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Level meter. The meter displays the cumulative playback level for all tracks/buses in the folder. Right-click to select the meter 
mode:

 Input. The signal is taken from before the channel volume fader and before effects.

Pre Fader. The signal is taken from before the channel volume fader and after effects.

Post Fader.  The signal is taken from after the channel volume fader.

A. Composite folder clip B. Audio clips

A track folder shows a composite clip of any clips that are contained in the folder. A track folder can contain multiple tracks and 
subfolders. You can nest track folders up to 5 levels deep, and each folder can contain an unlimited number of tracks. Track 
indentation and color bars make it easy to see the relationship between folders and tracks.

When a track folder is expanded, its child track, bus, and folder channel strips are indented to show the hierarchy. Each parent track 
folder shows a composite clip of its child track(s)/bus(es)/folder(s). In the following example, the “Guitars” and “Drums” track folders 
are top-level folders, and therefore only count as two tracks.

For details, see “Grouping tracks with track folders” on page 35.

Note: Each top-level track folder only counts as a single track, regardless of how many child tracks and subfolders it contains. 
During export, each top-level track folder is mixed down to a single file/track.
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 Folder collapsed:  Folder expanded:
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Track numbers

To show/hide track numbers, select Edit > Preferences and click Display, then select Track Number Display.

Track folders can affect how track numbers are shown. Track numbers can be either indexed or sequential. When sequential, each 
folder and track increases the counter. When indexed, tracks are numbered relative to their parent track folder. To specify the track 
number display mode, select Edit > Preferences and click Display, then select Track Numbering Mode.

See:

“Inserting tracks” on page 28

“Grouping tracks with track folders” on page 35

“Editing tracks & track folders” on page 128

Note: When exporting to BandLab, you can publish a maximum of 12 non-empty tracks or top-level track folders. If your project 
contains more than 12 tracks, the export button becomes disabled. Simply arrange your tracks into folders in order to reduce 
the overall file count and ensure the project will export in full. For details, see “Publishing to BandLab” on page 79.

 

Indexed track numbers: Sequential track numbers:
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Quick Start screen
Figure 4. The Quick Start screen.

A. Browse B. Installed app version C. App updates D. Create E. Local Projects F. Online Projects G. Demo Projects H. Product Updates
I. Show at start J. Search K. Content

You can perform the following tasks from the Quick Start screen:

Open a recent project.

Open an existing project.

Start a new project.

Create a new project from a template.

Open demo projects.

Update the app and download optional content.

Showing the Quick Start screen

By default, the Quick Start screen appears automatically when you open Next. To change the startup behavior, go to Edit > 
Preferences > Project and disable the Show Quick Start Screen at Launch option.
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Quick Start screen overview

The Quick Start screen contains the following tabs:

Create. Select a project template to get started. For details, see “Project templates” on page 151.

Local Projects. Choose a recent song you've worked on. For details, see “Opening a recent project” on page 21 and “Opening 
an existing project” on page 21.

Online Projects. Import a project from your online BandLab library. For details, see “BandLab library import/export” on page 77.

Demo Projects. Preview, download, and open demo projects. For details, see “Downloading demo projects” on page 23.

Product Updates. Update the app and install optional content. For details, see “Checking for product updates” on page 23.

To open a project or template, simply click on a list item.

Starting a new project from a template

1. Use the File > New Project command to open the Quick Start screen’s Create page.

2. Click the template that you want to open.

Opening a recent project

1. Use the File > Open Project command to open the Quick Start screen’s Local Projects page.

2. Click the project that you want to open.

Removing a project from the recent projects list

To remove a project from the Recent projects list on the Local Projects page, right-click the project and select Remove recent item 
<project name>.

Opening an existing project

1. Use the File > Open Project command to open the Quick Start screen’s Local Projects page.

2. Do one of the following:

Click the Recent/All toggle to show all local projects, then click the desired project.

Click the Browse button  to open the Open Project dialog box, navigate to the project file you want to open, then click 
Open.

Tip: You can save a preview file that allows you to preview a project from the Quick Start screen’s Recent page by clicking the preview 
button on the project image. For details, see “Creating a project preview file” on page 24.

Note: The default browse folder is \Cakewalk\Next\Projects, but you can specify other favorite folders. To add any user 

folders and select which to browse, click the Browse button  drop-down arrow and select Add browse folder. The Browse 
button tooltip shows the selected folder path.
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Pinning a project or template

You can pin templates on the Create page and projects on the Local Projects page so they appear at the top of the list.

To pin or unpin an item, point to the project or template and click the pin icon .

Any pinned projects are shown first in the list, regardless of the project’s modified date.

A. Pinned B. Unpinned

Opening a project in Safe Mode

A poorly behaved 3rd party plugin can cause data corruption and prevent a project from loading successfully.

Cakewalk Next® has a special diagnostic mode called Safe Mode that allows you to skip loading individual plugins when opening a 
project.

You activate Safe Mode by holding down the SHIFT key while launching the app or opening a project.

When loading the app in Safe Mode, Next does not load the last project, even if Open Most Recent Project at Launch is 
enabled in the Preferences dialog box.

When loading a project in Safe Mode, Next prompts to load or skip each plugin that is used in the project.

If you are unable to load a project that uses 3rd party plugins, hold down the SHIFT key while loading the project. Cakewalk Next® 
will prompt to load each individual plugin. Skip one plugin at a time until you identify and isolate any offending plugins. Remove the 
offending plugin(s) in the project, then resave the project.

 

A

B
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Downloading demo projects

To download demo projects:

1. Use the File > Open Project command to open the Quick Start screen.

2. Select the Demo Projects page.

3. Click the Download button  for the demo project that you want to download. Downloaded demo projects are indicated by a 

check mark .

A. Icon (click to preview project) B. Project and author name C. Genre D. Date published E. Project file size F. Download G. Downloaded 
indicator

Checking for product updates

To check for product updates:

1. Select Help > Check for Updates to open the Quick Start screen’s Product Updates page.

2. Click the Download button  to download any updates or optional content.

A B C D E F G
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Enabling input and output devices

When you start Next for the first time, it checks your computer to find all the audio and MIDI devices you have installed. If you have 
multiple devices, you need to tell Next exactly which devices you want it to use.

To configure your audio and MIDI hardware devices, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open 
the Preferences dialog box.

Configuring the audio driver mode

To select an audio driver mode, select the Audio page, then click the Audio Driver drop-down menu.

Enabling audio devices

To configure your audio hardware device, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the 
Preferences dialog box, then select the Audio page.

Enabling MIDI input device

To select your default MIDI input device, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the 
Preferences dialog box, then select the MIDI page.

See also:

“Preferences” on page 247

Creating and saving projects

Creating a new project

To create a new project, do one of the following:

Select File > New Project.

Press CTRL+N (Windows) / CMD+N (Mac).

You can also open or import a project from your BandLab library. For details, see “Importing from BandLab” on page 82.

Saving a project

To save the current project, do one of the following:

Select File > Save Project.

Press CTRL+S (Windows) / CMD+S (Mac).

You can also publish the current project to your BandLab library. For details, see “Publishing to BandLab” on page 79.

Creating a project preview file

You can preview projects from the Quick Start screen’s Recent page if you have exported a designated preview file. The preview file 
may be any supported audio file type (.wav, .mp3, etc), and can be the entire project or a specific time range.

To create a project preview file:

1. If you only want the preview to contain a specific time range, select the desired time range.

2. Do one of the following to open the Export Audio dialog box:

Select File > Export Audio

Click the Share button  and select Export Audio

Press CTRL+E (Windows) / CMD+E (Mac) 

3. Under Source, select Master.

4. Under Range, select Entire project to export the entire project, or select Time selection to only export the selected time range.

5. Under Format, specify the desired settings.
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6. Select Include Project Preview.

7. Click Export.

The preview file is exported to the project’s \Audio folder.

To preview a recent project:

1. Use the File > Open Project command to open the Quick Start screen’s Recent page.

2. Click the preview button on a project’s image. A preview button only appears if the project has a designated preview file.

See also:

“Exporting audio” on page 242

 

 

25Cakewalk Next® Introduction

Creating and saving projects



Project Information

Figure 5. Main toolbar.

The Project Info editor allows you to view and edit project information. Project information is stored within the project and can be 
used with BandLab publishing, ID3 tagging, and general project information.

To show the Project Info editor, do one of the following:

Select View > Show Project Info Editor

Click the Project Info section in the main toolbar

Press CTRL+SHIFT+I or ALT+P (Windows) / CMD+SHIFT+I (Mac).

The Project Info editor contains the following fields:

Project Art. The project art is shown in the main toolbar and Quick Start screen, and also used when publishing a project to 

BandLab. To change the project art, hover over the art image and click the Edit button .

Project Title. The song title, which can be different than the saved project file name.

Author. The song’s author.

Album. Album name, if any.

Genre. Specify the music genre.

Description. Include any important information about the song.
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Project File. The name of the saved project file. Click the Browse button  to open the project folder.

Sample Rate. Specify the project’s fixed sample rate. Audio is recorded at the project sample rate, and imported audio is 
converted to the project sample rate if there is a mismatch. The default project sample is Auto, which adapts to the audio device 
sample rate. It is strongly recommended that you use the same sample rate for the project and audio device. Using different 
sample rates will cause real-time audio resampling, which may consume extra CPU. See also “Specifying the recording format” 
on page 50.
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Inserting tracks

To insert a new track, click the Insert Track button  and select the desired track type:

Mic/Line In . Record your voice or any sound using a microphone. Click the icon to create a blank track. Use the submenu 
to select any available track template.

 Instrument . Play and record a virtual instrument using a MIDI device or your computer keyboard.

Sampler . Use MIDI to play back loops, one-shots, audio clips or local audio files.

Pad Controller . Use MIDI to trigger up to 16 sampler or instrument pads.

 Instrument Rack . Use MIDI to trigger up to 16 layered instruments simultaneously within a single track.

Bus . Create a bus that can be used to process many tracks.

Track Folder . A track folder may contain other tracks, buses, and folders. Useful for project organization and mixing.
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Inserting audio tracks

To insert an audio track, do one of the following:

Click the Insert Track button , then select Mic/Line In .

Select Insert > Insert Audio Track.

Press CTRL+T (Windows) / CMD+T (Mac).

Double-click the empty area below the last track strip (will insert either an audio track or an instrument track, deepening on which 
was last inserted).

Inserting instrument tracks

To insert an instrument track:

1. Do one of the following:

Click the Insert Track button , then select Instrument .

Select Insert > Insert Instrument Track.

Press CTRL+SHIFT+T (Windows) / CMD+SHIFT+T (Mac).

2. In the Add Instrument to Track dialog box, select the desired instrument

3. Click Add.

1. Click Insert Track button and select Instrument 2. Select instrument 3. Click Add

 

1 2

3
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Replacing an instrument

To replace an instrument with a different instrument:

1. Right-click the instrument’s module header in the Track Inspector and select Replace.

2. Select the desired instrument, then click Add.

See also:

“Instruments” on page 153

Inserting Sampler tracks

To insert a Sampler track, do one of the following:

Click the Insert Track button , then select Sampler .

Select Insert > Insert Sampler Track.

Press CTRL+SHIFT+X (Windows) / CMD+SHIFT+X (Mac).

See also:

“XSampler” on page 156

Inserting Pad Controller tracks

To insert a Pad Controller track, do one of the following:

Click the Insert Track button , then select Pad Controller .

Select Insert > Insert Pad Controller Track.

Press CTRL+SHIFT+P (Windows) / CMD+SHIFT+P (Mac).

See also:

“Pad Controller” on page 171
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Inserting Instrument Rack tracks

To insert an Instrument Rack track, do one of the following:

Click the Insert Track button , then select Instrument Rack .

Select Insert > Insert Instrument Rack Track.

Press CTRL+SHIFT+R (Windows) / CMD+SHIFT+R (Mac).

Select Cakewalk > Instrument Rack in the Plugin Browser.

See also:

“Instrument Rack” on page 177

Inserting track folders

To insert a track folder track, do one of the following:

Click the Insert Track button , then select Track Folder .

Select Insert > Insert Track Folder.

Press CTRL+SHIFT+G (Windows) / CMD+SHIFT+G (Mac).

See also:

“Track folders” on page 17

“Grouping tracks with track folders” on page 35
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Using track templates

A track template contains a description of track properties, including name, parameter settings and plugin configuration.

Track templates minimize setup time. You can create an unlimited number of track templates for quickly recalling your most often 
used track settings including the following:

Track type (Audio or Instrument)

Track name

Track color

Track icon

Volume and pan

Mute and Solo state

Effects and their settings

A track folder (see “Track folders” on page 17) can also be saved as a template, which is useful instantly inserting instrument 
ensembles or a multichannel drum recording configuration.

Saving a track template

To create a track template:

1. Right-click the track that you want to save as a template and select Export as Track Template.

2. Enter a name, creator, and any tags for the template, then click OK.
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Inserting a track from a template
To insert a new track from a track template:

1. Click the Insert menu and select Insert Track Template.

2. On the pop-up menu, select the desired track template (templates are organized by their tag assignments), then click Add.

or:

Click the Insert Track button  and point to Mic/Line In , then select the desired template on the pop-up menu.

Managing user track templates

To delete or rename a user track template, select Insert > Insert Track Template > Manage My Track Templates, then rename or 
delete the desired user track template(s), then either restart the app or select Insert > Insert Track Template > Refresh Track 
Templates.

Inserting buses

Buses are useful for mixing together different audio tracks (in stereo) and applying effects to the mix. You can mix the tracks at 
different volume levels by adjusting each track’s send level. Buses output to either other buses or to the main out.

To insert a bus, do one of the following:

Click the Insert Track button , then select Bus .

Select Insert > Insert Bus.

Press CTRL+ALT+T (Windows) / CMD+OPTION+T (Mac).

Tip: A track folder can also be saved as a template, which is useful instantly inserting instrument ensembles or a multichannel drum 
recording configuration.
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Adding aux sends

Sends allow you to send audio data from tracks to buses.

To insert a send on a track:

1. Select the source track.

2. Open the Track Inspector.

3. Under Sends, click the Add Send button .

4. On the pop-up menu, select an existing bus or select Create New Bus to create a new bus.

See also:

“Aux sends” on page 189
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Grouping tracks with track folders

You can add and remove audio tracks from track folders at any time. A common use is to group tracks by instrument type and to 
ensure a project does not exceed a total of 16 tracks or top-level track folders if you intend to publish to your BandLab library (see 
“Publishing to BandLab” on page 79).

Inserting a new track folder

To insert a new track folder, do one of the following:

Click the Insert Track button , then select Track Folder .

Select Insert > Insert Track Folder.

Press CTRL+SHIFT+G (Windows) / CMD+SHIFT+G (Mac).

Placing tracks into a new track folder
To place tracks into a new track folder, select the tracks you want to group, then select Edit > Move to Track Folder or press 
CTRL+G (Windows) / CMD+G (Mac).

Placing tracks into an existing track folder

To place tracks into an existing track folder, select the tracks you want to move to a folder, then drag any of the selected tracks into 
the folder.

Removing tracks from a track folder

To remove tracks from a track folder, drag the tracks out of the folder.

Removing all tracks from a track folder

To remove all tracks from a track folder, select the track folder and go to Edit > Remove From Folder, or press CTRL+U (Windows) 
/ CMD+U (Mac).

Note: If you delete a track folder, it will also delete everything inside the folder. Deleting a track folder will not ungroup its child 
tracks/buses/subfolders.
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Expanding/collapsing a track folder

To expand/collapse a track folder, click the arrow button (  / ) to the left of the track icon.

To expand/collapse all track folders, do one of the following:

Click the Track View Options  button and select Expand track folders or Collapse track folders

Select View > Expand Track Folders or View > Collapse Track Folders

See also:

“Resizing tracks” on page 130

 

 

 Folder collapsed:  Folder expanded:
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Scrolling and zooming

Scrolling

To scroll horizontally, drag the horizontal scroll bar, or use the mouse wheel.

To scroll vertically, drag the vertical scroll bar, or hold down the SHIFT key while using the mouse wheel.

Zooming

Zooming horizontally

To zoom in/out horizontally, do one of the following:

Go to View > Zoom In or View > Zoom Out.

Press ALT+LEFT/RIGHT (Windows) / CMD+LEFT/RIGHT (Mac).

Point the mouse pointer at the top half until the mouse pointer looks like , then drag up/down.

To zoom to the selection, press the F key, or click the View Options button  and select Zoom to fit.

Zooming vertically

You can zoom vertically in the Clips pane and the Clip Inspector’s Piano Roll editor, whichever has focus. If the Clips pane has focus, 
zooming affects the selected track(s).

To zoom vertically, press CTRL+UP/DOWN (Windows) / CMD+UP/DOWN (Mac).

You can also resize individual tracks (see “Resizing tracks” on page 130).
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Installing Cakewalk Next®

Visit www.cakewalk.com/next to download Cakewalk Next®.

Cakewalk Product Center

Cakewalk Product Center allows you to download and install Cakewalk products from one central location. Simply sign in with your 
BandLab ID and password and begin installing your connected products. Stay up to date with the latest features and fixes.

On app launch, Cakewalk Product Center checks for any updates and shows all available apps and updates that you are entitled to. 

Download and install Cakewalk Product Center

Download Cakewalk Product Center for Windows

Download Cakewalk Product Center for macOS

Updating Cakewalk Product Center

Cakewalk Product Center automatically checks for its own updates on launch, and will prompt to download and install if an update is 
available.

UI

Figure 6. Cakewalk Product Center.

Note: Cakewalk product Center requires an internet connection and user sign-in to check for updates.
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The Cakewalk Product Center UI consists of the following sections:

Top: Shows the current app version.

Sidebar: The left sidebar is where you select which Cakewalk app to install/update. A dot appears to the right of the product 
name if an update is available.

Enable the Show Add-ons toggle to show optional content.

Click Sign Out or Sign In to sign out/in of your BandLab account.

Click Offline Activation to activate a Cakewalk product that is installed on an offline computer. See Offline activation for details.

Product/Update list: Shows the latest available update(s) for the app that is selected in the sidebar.

Progress view: Shows progress of the currently downloading/installing item. This section is hidden when no item is downloading/
installing.

Using Cakewalk Product Center

Installing or updating an app

1. In the sidebar, select the app that you want to install/update.

2. In the product list, click Install or Update.

Installing or updating add-ons

1. In the sidebar, select the parent app, then enable the Show Add-ons toggle.

2. In the product list, click Install or Update for the add-on that you want to download and install. Download progress is shown and 
can be canceled.

Offline activation

1. On the offline computer, generate an offline activation request file in Next (Help > Activation > Export Activation Request).

2. Copy the Activation request.crq file to removable media, such as a USB flash drive, that you can transfer to another 
computer that is connected to the internet.

3. On the online computer, launch Cakewalk Product Center, then click Offline Activation.

4. Select the Activation request.crq file.

5. The app will process the request and return a Activation response.dat file if successful.

6. Copy the Activation response.dat file to removable media that you can transfer back to your offline computer.

7. On the offline computer, open Next and go to Help > Activation > Import Activation Response.

8. Select the Activation response.dat file and click Open.

If the response file is valid, the app is activated.

See:

“Activating Cakewalk Next®” on page 40
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Activating Cakewalk Next®

What is activation?

Cakewalk Next® is provided to users free of cost by BandLab. The software is linked to your BandLab account by a process called 
activation. The first time you install Next it is automatically activated. From time to time, re-activation may be necessary. The 
reactivation window is typically once every 6 months and requires you to be logged in to your BandLab account.

Why is activation required?

Activation ensures that you are running genuine Next software obtained from our servers and that you have a current version of Next 
that is actively supported by us. Running an updated version ensures a better user experience by getting the latest features and 
fixes to the software. Additionally, back end changes to the BandLab cloud may periodically require the software to be updated to 
remain compatible.

Do I always need to be online to BandLab for Cakewalk Next® to work?

No. You only need to be online in order to update the software to the latest version or when activating it. Under normal 
circumstances, activation will require no manual user intervention going forward, beyond the initial sign-in. An Internet connection is 
required for performing activation as described above but not required for general Next usage.

How to activate Cakewalk Next®

When starting Next for the first time, you will be presented with the BandLab Sign In dialog box.

Cakewalk Next® supports SSO (Single Sign-On) for activation, which allows you to log in via any service supported by BandLab as 
your sign-in authority. Google, Facebook, Apple ID, mobile phone and BandLab user/password credentials are currently supported.

SSO is only used for Next activation, and under normal circumstances you will only need to sign in once. Cakewalk Next® will 
attempt to refresh your activation status silently and automatically on occasion during start up. Use the SSO login as you have done 
with your BandLab account in the past. After signing in, Next will automatically activate itself.

Reactivation normally happens automatically if you are signed in to your BandLab account and connected to the internet. You may 
also manually refresh activation at any time by signing out (Help > Sign Out) then signing back in again (Help > Sign In).
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Offline activation

If Next is installed on a computer that is not connected to the internet, you can use offline activation as long as you have access to 
another computer that is connected to the internet. To use offline activation, follow these steps:

1. In Next, go to Help > Activation > Export Activation Request to open the Save activation request dialog box.

2. Select the folder you want to save the activation request file to, then click Save.

Next saves a Activation request.crq file. This file is encrypted and machine-specific, and can only be used to activate 
Next on the machine that was originally used to create the Activation request.crq file.

By default, Next appends a timestamp to the file name, using the following format: <Month><Day><Year>_<Hour><Minute>. 
For example: 091024_1157Activation request.crq.

3. Copy the Activation request.crq file to removable media, such as a USB flash drive, that you can transfer to another 
computer that is connected to the internet.

4. On the online computer, launch Cakewalk Product Center (see “Cakewalk Product Center” on page 38) and sign in with your 
BandLab ID and password, then click Offline Activation.

5. Select the Activation request.crq file.

6. The app will process the request and return a Activation response.dat file if successful.

7. Copy the Activation response.dat file to removable media that you can transfer back to your offline computer.

8. On the offline computer, open Next and go to Help > Activation > Import Activation Response.

9. Select the Activation response.dat file and click Open.

If the response file is valid, the app is activated.
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Support

Visit bnd.la/cakewalk-support for app support.
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Playback
When you play your Cakewalk Next® project, you have full control over the tempo or speed of playback, which tracks are played, 
which audio devices are used to produce the sound, and what the tracks sound like. You can access all of the playback functions 
from the main toolbar.

See:

“Using the transport” on page 43

“Looping” on page 44

“Setting the project tempo” on page 46

“Setting the project meter (time signature)” on page 47

Using the transport

Starting playback

To start playback, do one of the following:

Click the Play button .

Press the SPACEBAR key.

Select Transport > Play/Pause.

Double-click in the time ruler.

Pausing playback

To pause playback, do one of the following:

Click the Pause button .

Press the SPACEBAR key.

Select Transport > Play/Pause.

Note: By default, playback always resumes at the last start location. To resume at the current now time, disable Playback > 
Resume Playback at Last Start Position.
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Setting the playback position

To move the Now Time marker, click in the time ruler or any empty area in the Clips pane.

You can also set the Now Time in the main toolbar. To do so, position the mouse pointer over the Bar, Beat, or Sub-beat value and 
drag up/down.

Rewinding the playback position

To rewind the playback position, click the Jump Back button  or press W. The playback position will seek to loop positions and 
the playback marker en route to the project start.

Looping

Looping a time range

To enable/disable project looping, click the Toggle Loop Playback button .

When looping is enabled, the loop region is green:

When looping is disabled, the loop region is gray:

See also:

“Loop recording” on page 56

Tip: You can also right-click the green/gray loop region to enable/disable looping.
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Setting the loop region

To set the loop region, do one of the following:

Drag in the section immediately above the time ruler. This will automatically enable looping.

Make a selection, then select Transport > Loop Selection or press SHIFT+L.

Resizing the loop region

To resize the loop region, drag the loop start or end marker:

Moving the loop region

To move the loop region, hold down the CTRL (Windows) / CMD (Mac) key and drag the blue loop range to the desired location.
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Setting the project tempo

To set the project’s tempo, do one of the following:

Double-click the current tempo value and type the desired tempo.

Position the mouse pointer over the tempo display and drag up/down.

Using Tap Tempo

Open the Metronome Options drop-down menu to expose the Tap Tempo control, then click the TAP button repeatedly to tap the 
desired tempo. Click the Apply button to apply the tapped tempo, or press ESC to cancel a pending tempo change.

See also:

“Tempo” on page 63

“Tempo track” on page 65

“Changing tempos” on page 66

“Editing the tempo map” on page 68

“How tempo changes affect audio clips” on page 64

Tip: After clicking the TAP button to give it focus, you can press the ENTER (Windows) / RETURN (Mac) key to tap the tempo.
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Setting the project meter (time signature)

The meter determines the following:

Where the metronome accents are placed

How the Now time is displayed

How grid lines are displayed in the Clips pane and Piano Roll view

By default, a new Next project is in 4/4 time. The denominator (left number) indicates the type of note that equals 1 beat, and 
corresponds to the division of the whole note (for example, the number 4 indicates the note figure equivalent to ¼ of the whole note, 
which is a quarter note). The numerator (right number) indicates the number of beats in a measure.

To set the project’s time signature, double-click the denominator and numerator values and type the desired values.
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Recording
You can add sound or music to a Cakewalk Next® project in many different ways. You can record your own material using a MIDI-
equipped instrument, use a microphone or another audio input to record digital audio information, or import sound or music data 
from an existing digital data file. With the Input monitoring feature, you can hear your audio instruments exactly how they sound in 
Next, including any plugin effects 

To prepare for recording, you need to do the following:

Specify the sample rate and bit depth

Choose your input(s)

Arm one or more tracks for recording

Check your recording levels (audio only)

Tune your instrument if necessary (audio only)

Set the Now time to the point in the project where you want to start recording

Enable the metronome, if necessary

See:

“Specifying the recording format” on page 50

“Setting the sample rate for new projects” on page 51

“Setting the bit depth for new projects” on page 51

“Setting the file format for new projects” on page 51

“Choosing an input” on page 53

“Arming tracks for recording” on page 54

“Recording audio/MIDI” on page 55

“Loop recording” on page 56

“Punch recording” on page 57

“Importing audio” on page 61

“Using the metronome” on page 62
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Specifying the recording format

Each project has an audio sample rate and bit depth that determine the audio fidelity and how accurate the digital recording is to the 
original analog signal.

Bit depth

The bit depth dictates the amplitude resolution of audio files, which affects the dynamic range:

16-bit audio has a maximum dynamic range of 96.3 dB and a resolution of 65,536 values

24-bit audio has a maximum dynamic range of 144.5 dB and a resolution of 16,777,216 values

32-bit floating point audio offers nearly infinite decibel levels (1,528 dB!) and a resolution of 4,294,967,296 values

Higher bit depths do not necessarily result in better audio quality or higher fidelity sound, but will have a lower noise floor. 24-bit files 
require 50% more disk space than 16-bit. 32-bit files require 33% more disk space than 24-bit and 100% more than 16-bit.

Sample rate

The sample rate is the number of times the audio is captured per second, measured in Hertz (Hz). For example, a sampling rate of 
44,100 Hz means that the audio signal is sampled 44,100 times per second.

The Nyquist-Shannon theorem states that in order to prevent any loss of information when digitally sampling a signal, you have to 
sample at a rate of at least twice the highest expected signal frequency. Otherwise the sound is not faithfully reproduced. 

The human ear can only hear frequencies up to 20 kHz (20,000 Hz) at best, so the minimum sample rate must be at least 40 kHz in 
order to digitize this frequency. A sample rate of 44,100 Hz captures frequencies up to the 22 kHz range, while a sample rate of 
48,000 Hz captures frequencies up to the 24 kHz range.

What should my sample rate and bit depth be for recording?

For music production, 44.1kHz/24-bit or 48kHz/24-bit is a good choice and provides a good balance between sound quality, file size 
and processing power, and captures the entire audible frequency spectrum accurately.

Although a high sample rate along with a high bit depth will deliver the best audio quality, it is not always the best option. The higher 
the sample rate and bit depth, the more audio processing power and disk space are required. This will reduce the potential track 
count and number of real-time plugins, and may not make any noticeable sonic difference.

16-bit audio has a low noise floor and a decent amount of dynamic range, and is fine for most music production.

24-bit provides more dynamic range, and lets you record at more conservative levels to avoid exceeding the level of clipping (0 
dBFS) while staying above the noise floor. The added headroom may also be beneficial when editing and mixing.

With 16-bit and 24-bit recording, it’s important to set proper levels prior to recording in order to make sure the audio isn't peaking and 
distorting, while also staying above the noise floor. If the recording level is set too low, raising the track's volume will also increase all 
of the corresponding noise in the recording.

32-bit recording is generally reserved for ultra-high-dynamic-range recording, and is not meant for distribution. The main benefit of 
32-bit float recording is improved flexibility in making level adjustments after recording is complete. There is so much headroom that 
it doesn't really matter much where levels are set while recording digitally. Any signal that clipped in the recording can be recovered 
later by reducing track levels. Signals that exceed 0 dBFS can be reduced to below 0 dBFS, undistorted, and any parts of the 
recording that had low gain can be raised with less chance of increasing the noise floor. This is mostly useful in an uncontrolled 
environment where you are not able to set proper recording levels prior to recording, such as live recordings, but is less critical when 
you are able to set proper recording levels ahead of time.

Note: 32-bit float recording prevents you from clipping the digital recording, but it’s still possible to clip the pre-amps. Most 
distributors use 24-bit or 16-bit files, so a 32-bit project will eventually need to be converted, which may result in some data being 
lost in the process unless you make adjustments to ensure that the audio signal doesn’t get clipped when downsampling. This 
can be achieved by using a limiter or normalizing the audio file.
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Ultimately, the ideal sample rate and bit depth depend on several factors, including

Which sample rate(s) is supported by your audio device. Also, if you plan to perform creative audio manipulation that involves 
time stretching audio files past their recorded length, you may choose to record at a higher sample rate (if your audio interface 
allows for it).

Your computer’s processing power.

The media destined to play your music. You typically want to record at the sample rate of your final destination format (if 
supported by your audio device).

See:

“Setting the file format for new projects” on page 51

“Setting the bit depth for new projects” on page 51

“Setting the sample rate for new projects” on page 51

Setting the file format for new projects

To set the file format for new projects:

1. Go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the Settings dialog box, then select the Audio 
page.

2. Under Recording, specify the desired File Format setting.

Setting the bit depth for new projects

To set the bit depth for new projects:

1. Go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the Settings dialog box, then select the Audio 
page.

2. Under Recording, specify the desired File Bit Depth setting.

Setting the sample rate for new projects

To set the sample rate for new projects:

1. Go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the Settings dialog box, then select the Audio 
page.

2. Under Audio Device, specify the desired Sample Rate value.

It is important to understand the difference between the audio device sample rate and the project sample rate.

Audio device sample rate. The audio device sample rate is set in the Preferences dialog box under Audio > Audio Device > 
Sample Rate.

Recorded audio is always at the device sample rate. Cakewalk Next® does not sample rate convert after recording in order to 
preserve the recorded data.

When opening a project, the audio device sample rate is set to the project sample rate. Doing so prevents unnecessary real-
time sample rate conversion, which may consume extra CPU.

Project sample rate. The project sample rate is set in the Project Info Editor. The default project sample is Auto, which adapts 
to the audio device sample rate. It is strongly recommended that you use the same sample rate for the project and audio device. 
Using different sample rates will cause real-time audio resampling, which may consume extra CPU. When you create a new 
project, if you do not want to use the default audio device sample rate, you must choose a sample rate in the Project Info Editor 
before you start recording audio. For details, see “Project Information” on page 26.

The project sample rate is used when recording and importing audio files.

The project sample rate becomes fixed as soon as any audio clip is present in the project.

When you record or import the first audio clip, the project sample rate will be switched from Auto to whatever the current 
audio device sample rate was at that time. From then on the project sample rate is fixed.

Removing all audio clips from the project resets the project to Auto which means it will follow the device sample rate again.

The project sample rate can be changed at any time from the Project Info Editor. Cakewalk Next® will attempt to auto switch 
the device sample rate to the project sample rate when possible. Auto switch occurs both when changing the project sample 
rate as well as when loading a project.
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Match the project sample rate and audio device sample rate

It is strongly recommended that you use the same sample rate for the project and audio device. Using different sample rates will 
cause real-time audio resampling, which may consume extra CPU. Real-time sample rate conversion ensures that projects can play 
back on virtually any audio device at the correct playback speed, even if the audio device doesn’t support the current sample rate.

The default project sample is Auto, which adapts to the audio device sample rate.

If there is a mismatch, Next will attempt to automatically switch the device sample rate to match the project sample rate when 
possible. Auto switch occurs both when changing the project sample rate and when loading a project.

The sample rate pickers in the Project Info Editor and Preferences > Audio indicate if there is a mismatch between the audio device 
sample rate and project sample rate. A notification also appears if there is a mismatch.
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Choosing an input

To record into a track, you must choose an input for the music or sound to be recorded.The input for each track is displayed in the 
track’s Input field in the Track Inspector.

1. Select the track you want to record on.

2. Open the Track Inspector.

3. In the Track Inspector, click the Input menu and select the desired input device.

When you choose All Input as the input for an instrument track, Next merges material from all MIDI inputs and instruments. This 
means you don’t have to worry about input, channel, or other MIDI settings.

To record different MIDI channels into different tracks, specify the Input port/channel in each track’s Track Inspector.

Enabling track input monitoring

Input monitoring allows you to hear plugin audio effects applied to a live signal. To enable input monitoring on a track, click the 

track’s Track Monitor button .

To disable monitoring on all tracks, click the global Monitor toggle button  in the track pane header. Click again to restore the 
previous monitor state.

See:

“Track Inspector” on page 89
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Arming tracks for recording

Cakewalk Next® lets you record any number of tracks at one time. You indicate the tracks you want to record by arming the tracks. 
You can arm a single track or several tracks at one time. Each track records material received though its selected input.

To arm a track for recording, click its Record Arm button . A track’s Record Arm button turns red  to indicate that the track is 
armed for recording.

To disarm all tracks, click the global Record Arm toggle button  in the track pane header. Click again to restore the previous arm 
state.

Auto arm track for recording

If you are only recording a single track at a time, there is no need to arm the track for recording. Simply selecting the track will auto 
arm it for recording. Only one track can be auto armed at a time.

If no tracks are explicitly armed for recording by engaging the track’s Record Arm button , Next will auto arm the selected track. 
This allows you to quickly start recording a single track without having to arm the track. The auto armed track is indicated by a hollow 

red circle .

A. Explicitly armed B. Auto armed

While recording is in progress, auto arm is locked to the current track. Selecting a different track will not auto arm the new track.

Auto arming will not occur if at least one track is explicitly armed for recording.

You can disarm the auto armed track by clicking its Record Arm button .

When a track is auto armed, its meter functions as follows:

When idle, shows input meter

When recording, shows input meter

When playing back, shows post fader playback meter

Enabling/disabling auto arming of tracks

To enabled/disable auto arming of tracks, select Edit > Preferences and click Audio, then select Auto-Arm Tracks.

Note: You can arm and disarm tracks during playback and recording. This allows you to record to different tracks while the 
transport is rolling, without first having to stop playback in order to arm a track for recording.

 
A

B
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Recording audio/MIDI

After you have set your tempo and metronome, and armed one or more tracks, you are ready to start recording.

To start recording, do one of the following:

Click the Record button . The button is red when enabled .

Press R.

If the metronome count-in is enabled, it will play the count-in.

Play or perform the material you want to record. 

During recording, the recorded signal is shown in red in the Clips pane:

To stop recording, do one of the following:

Click the Play/Pause button .

Select Transport > Play/Pause.

Press SPACEBAR.

Click the Record button . Recording stops, but playback continues.

Select Transport > Record. Recording stops, but playback continues.

Press R. Recording stops, but playback continues.

Listen to the new material. If you’re not happy with the recording, select Edit > Undo to erase the new material. Select Edit > Redo 
command to restore the recording and toggle between Undo and Redo as many times as you like.

Note: When you are finished with recording, don’t forget to disarm any armed tracks to prevent them from being accidentally 

overwritten. To disarm a track, click its red Record Arm button . You can also set a track’s Input control to None to prevent 
any further input signal from reaching the track.
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Loop recording

When recording a vocal or an instrumental section, you might want to record several different takes so that you can choose the one 
you like best. You might even want to record several takes to double a part or merge the best parts of each.

Normally, to record each take you would have to arm a track, start recording, perform the take, and then stop recording. You can 
record multiple takes more easily using loop recording. Loop recording lets you start recording and record as many takes as you like, 
all in a single step.

Cakewalk Next® loops between the loop start and loop end time, allowing you to record one take on each pass. Cakewalk Next® 
automatically places each take into a new, track. All takes/tracks are muted except for the last take.

The following rules apply when loop recording and Transport > Loop Recording Creates Takes in Track Folder is enabled:

 If a track is in a folder, multiple takes use the track's existing folder.

 If a folder already contains one or more takes for the track, the original track is left intact rather than overwriting it. As the latest 
take is always on top (i.e. tracks are ordered by most recent take first), subsequent takes will appear above it in the track order. It 
also means that you will always get a new take track when existing takes exist, even if the last take didn't loop more than once.

When loop recording is finished, the group is always expanded.

The original track is set to be the active track, so the user can start recording again.

To use loop recording

1. Choose the input for the track(s) you want to record, and arm the track(s) for recording.

2. Click the Toggle Loop Playback button  to enable looping.

3. Set the loop start and end times (see “Setting the loop region” on page 45):

Drag in the section immediately above the time ruler.

Make a selection, then select Transport > Loop Selection or press SHIFT+L.

4. Click the Record button  to start recording. The button is red when enabled .

5. Play or perform the material you want to record. At the end of the loop, Next will return to the start of the loop and you can record 
the next take.

6. Click the Play/Pause button  or press the SPACEBAR when you want to stop recording.

The takes are stored in separate tracks, with takes/tracks muted except for the last take.

See also:

“Looping” on page 44

Note:  By default, all loop-recorded tracks are grouped in a track folder, but you can create ungrouped tracks by disabling 
Transport > Loop Recording Creates Takes in Track Folder.
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Punch recording

Punch recording allows you to record within a specific time range. Any previous recordings outside the punch region are not 
overwritten.

Suppose you are happy with most of a track but want to replace some sound or add new material in one small section—perhaps as 
small as a couple of notes. This is where punch recording comes in handy, because it lets you record new material only within a 
specified range of times.

For example, suppose you recorded a 32-bar keyboard solo but made some mistakes in the 24th and 25th bars. With punch 
recording, you can play the entire solo again, so you make sure you can get the feel you want. However, only the bars you want to 
correct are actually recorded. That way, you don’t have to worry about introducing new mistakes elsewhere in the recording.

To use punch recording

1. Choose the input(s) for the track(s) you want to record, and arm the track(s) for recording.

2. Do one of the following to enable/disable punch recording:

Click the Transport menu and select Enable Punch Recording.

Click the Record button  drop-down menu  to open the record settings panel, then select Punch Recording.

When punch record is enabled, the Record button displays a “record punch” icon , and the blue loop markers in the time 
ruler turn red to indicate the punch region.
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3. Set the punch start and end times.

Punch recording utilizes the loop range markers to specify the punch record time range. When punch recording is enabled, the 
blue loop markers turn red to indicate the punch region. Drag the red marker handles to modify the punch region. To move the 
punch region, hold down the CTRL (Windows) / CMD (Mac) key and drag the red punch range to the desired location.

A. Punch Record button B. Punch In marker C. Punch Out marker

4. Set the Now time to a point where you want to start playback.

5. Click the Record button  or press R to start recording. If your metronome count-in is turned on, it will play the count-in 
measures or beats.

6. Play or perform the material you want to record.

7. Click the Play/Pause button  or press the SPACEBAR when you want to stop recording.

The material you play during the punch time is recorded in the chosen track, either replacing any existing material (Overwrite record 
mode) or blending with it (Takes to folder record mode). For details, see “Record options” on page 60.
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After you punch record, choosing Edit > Undo both discards any new material you recorded and restores the original material that 
had been deleted.

You can combine loop (see “Loop recording” on page 56) and punch recording. The time ruler shows the loop/punch record region 
with draggable handles, and uses color coding to indicate if Loop Playback and Punch Record are enabled or disabled. When both 
looping and punch recording are enabled, recording occurs at loop start, and loop recording occurs per usual. When looping is 
enabled, the markers become brighter and the region is shaded.

Note: When punch recording, Next saves the entire recording while the transport is rolling, but the recorded clip is cropped to 
only expose the punch region. By also recording the pre-roll and post-roll, you have more flexibility later when it comes to 
trimming the clip because you have access to audio data before and after the punch region instead of only silence.

 Loop Playback = OFF  and Punch Record = OFF :  Loop Playback = ON  and Punch Record = OFF :

 Loop Playback = OFF  and Punch Record = ON :  Loop Playback = ON  and Punch Record = ON :
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Record options

To configure recording settings, click the Record button  drop-down menu  to open the record settings panel:

Record Count-in. Play the specified number of beats or measures of metronome clicks before recording begins. This can help 
you “get in the groove” before you start performing. When you create a new project, you should set the metronome to play during 
the count-in and while recording. If you are adding material to an existing project, you might only need the metronome for the 
count-in.

Enabled. Enable the record count-in and metronome, which is required in order to use the record count-in.

Value. Specify the number of beats or measures to use for the count-in. Enter the number of clicks for the count-in, then 
select Beats or Measures.

Pre-Roll Audio. Option to pre-roll project during count-in.

Mute metronome after count-in. Mute the metronome after the count-in has completed.

Record Mode. Specify how recording affects existing material:

Overwrite. Recording replaces (overwrites) any existing material in the armed track(s). When loop recording, each pass 
overwrites the previous pass.

Takes to folder. When loop recording, each take is recorded onto a separate track, and all tracks are grouped in a new track 
folder. Only the most recent pass is audible, and older passes are muted.

Punch Recording. Enable/disable punch recording. Punch recording allows you to record new material only within a 
specified range of times, without overwriting the original recording outside the punch region. Punch recording is normally used 
to correct minor mistakes in an otherwise good performance. See “Punch recording” on page 57.

Overdub MIDI. When recording MIDI on instrument tracks, merge new material with existing material. Existing clips on the 
track are left unchanged and all newly recorded material is stored in new clips. While recording, you will be able to hear 
material from existing clips.
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Importing audio

While recording is perhaps the most common way of adding material to a Next project, you can also import audio files of the 
following formats:

WAV

AIF

MP3

MP4

OGG

FLAC

To import audio, drag the audio files, or folder of audio files, into the Clips pane.

Imported audio is converted to the project sample rate if there is a mismatch.

You can also import audio loops and one-shots from the Loop Browser. For details, see “Loop Browser” on page 71 and “Importing 
loops” on page 74.

See also:

“Importing from BandLab” on page 82

Tip: To make it easier to align tracks when exporting individual tracks or stems from another DAW, export full length tracks, padded 
with silence at the start, if necessary, to ensure that all audio data is time aligned at import.

Note: When exporting from Next, clips that do not start at time zero are automatically padded when exporting to BandLab.
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Using the metronome

The metronome counts off each beat in a measure, so you can hear the tempo of your project. You can choose to have the 
metronome sound during recording, during playback, both, or turned off.

Enabling/disabling the metronome

To enable/disable the metronome, click the Metronome button .

Configuring metronome settings

To configure metronome settings, click the Metronome button  drop-down menu  to open the metronome settings panel:

Figure 7. Metronome options.

Click. Specify when the metronome should be enabled:

Recording. Enable the metronome during recording. The metronome button is red when enabled .

Playback. Enable the metronome during playback. The metronome button is green when enabled .

Both. Enable the metronome during recording and playback. The metronome button is blue when enabled .

Levels. Specify the click levels for strong and weak beats:

• Strong. Set the gain for the first beat of each measure.

• Weak. Set the gain for all other beats.

Sound. Select the metronome sound.

Output Level. Adjust the metronome volume.

Output. Select the metronome output bus or hardware device.

TAP. Click the TAP button repeatedly to tap the desired tempo.

Apply. Click the Apply button to apply the tapped tempo, or press ESC to cancel a pending tempo change.

See:

“Setting the project tempo” on page 46
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Tempo
Figure 8. Tempo track.

A. Metronome menu (open for tap tempo) B. Current tempo (double-click or drag up/down to enter a tempo) C. Tempo track D. Tempo envelope

Every project has a tempo, which is expressed in beats per minute (BPM). You can set the tempo in the main toolbar or Tempo track. 
A project can have a single static tempo, or a tempo map that changes over time. A tempo map is simply the complete set of all 
tempo changes in a project. These changes are displayed as an envelope in the Tempo track.

A recording can sometimes sound mechanical if the project has a single static tempo. The tempo in a natural human performances 
tends to drift slightly, which can produce more musical and interesting results.

You can add tempo changes to your project in the following ways:

Setting the project’s initial tempo in the main toolbar. For details, see “Setting the project tempo” on page 66.

By tapping. For details, see “Setting the tempo by tapping” on page 67.

By drawing tempo changes graphically in the Tempo track. For details, see “Editing the tempo map” on page 68.

See:

“How tempo changes affect audio clips” on page 64

“Making an audio clip follow tempo changes” on page 64

“Tempo track” on page 65

“Changing tempos” on page 66

“Setting the project tempo” on page 66

“Setting the tempo by tapping” on page 67

“Editing the tempo map” on page 68

See also:

“Using the metronome” on page 62
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How tempo changes affect audio clips

When you change the tempo of a project that contains audio, Next allows you to automatically stretch or shrink audio clips to follow 
the changed tempo. Otherwise, the MIDI tracks will speed up or slow down while the audio tracks will play at the same speed.

When you change the tempo of your project, audio clips that have stretching enabled change tempo along with the project, while 
those that do not have stretching enabled do not. Audio clips that do not have stretching enabled change in size when moved to a 
part of your project that has a different tempo.

In some situations you may not want to adjust the speed of your audio:

 If your project contains background music and a voice-over, you might want to change the tempo of the background music without 
altering the voice-over.

 If you’re trying to modify the speed of some MIDI tracks to match a sampled drum groove, you want to leave the audio 
unchanged.

Configuring the default loop stretch behavior

By default, looped audio clips follow tempo changes in the project, but regular non-looped audio clips do not.

To configure the default loop stretch behavior, select Edit > Preferences and click Audio, then select Default Loop Stretch 
Behavior.

Stretch audio to follow tempo changes. A clip’s absolute position stays constant, and its M:B:T position shifts. This is the 
default for non-looped audio clips.

Do not stretch to follow tempo changes. A clip’s M:B:T position stays constant, and its absolute position shifts.

See also:

“Preferences” on page 247

“Audio settings” on page 248

Time Base: Musical Time and Absolute Time

An audio clip’s Time Base property determines what happens to the clip’s start time when you change the project tempo:

Musical Time. If the clip is set to the Musical time base, the clip’s M:B:T (Measure:Beat:Tick) position stays constant, and its 
Absolute (Hours:Minutes:Seconds) position shifts.

Absolute Time. If the clip is set to the Absolute time base, its Absolute (Hours:Minutes:Seconds) position stays constant, and 
its M:B:T position shifts.

Making an audio clip follow tempo changes

To make a regular audio clip follow tempo changes, right-click the clip and select Stretch to Tempo.

When you loop an audio clip, it's always in Musical Time, and by default it gets set to follow tempo. You can set it to unfollow tempo 
if you want. To prevent an audio clip from following tempo changes, right-click the clip and select Disable Stretch to Tempo. To 
enable again, right-click the clip and select Stretch to Tempo.

See:

“Tempo track” on page 65

“Changing tempos” on page 66

“Setting the project tempo” on page 66

“Setting the tempo by tapping” on page 67

“Editing the tempo map” on page 68

“Tempo” on page 63

Note: If the Stretch to Tempo command is disabled, it likely means that the clip’s Time Base is set to Absolute Time. In order 
to follow tempo changes, an audio clip must use Musical Time. To toggle between Music Time and Absolute time, right-click the 
clip and select Set to Absolute Time or Set to Musical Time.
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Tempo track
Figure 9. Tempo track.

The Tempo track provides a graphic overview of the project tempo. It allows you to create and edit tempo changes within a project 
(see “Editing the tempo map” on page 68). 

Showing the Tempo track
The Tempo track resides between the Clips pane and time ruler.

To show the Tempo track, do one of the following:

Select Views > Show Tempo Track

Press T

Editing the tempo envelope

In the Tempo track, tempo changes are represented by envelope shapes. You edit the project’s tempo map the same way you edit 
automation envelopes. For details, see “Editing the tempo map” on page 68 and “Creating and editing automation envelopes” on 
page 213.

See:

“Creating and editing automation envelopes” on page 213

“How tempo changes affect audio clips” on page 64

“Making an audio clip follow tempo changes” on page 64

“Changing tempos” on page 66

“Setting the project tempo” on page 66

“Setting the tempo by tapping” on page 67

“Editing the tempo map” on page 68

“Tempo” on page 63

See also:

“How tempo changes affect audio clips” on page 64

“Making an audio clip follow tempo changes” on page 64

“Tempo track” on page 65

“Changing tempos” on page 66

“Setting the project tempo” on page 66

“Setting the tempo by tapping” on page 67

“Editing the tempo map” on page 68

“Tempo” on page 63
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Changing tempos

Next provides various ways to change the project tempo, including the Tempo track and Control Bar Transport module.

The most suitable method depends on the desired outcome. Although there may be multiple ways to achieve the same or similar 
result, below are some suggestions.

 If you only want to set a singe fixed tempo for the duration of the project, use the Control Bar Transport module. For details, see 
“Setting the project tempo” on page 66.

 If you want to set multiple tempo changes or draw tempo changes graphically, use the Tempo track. For details, see “Editing the 
tempo map” on page 68.

 If you don’t know the exact tempo BPM value and would like to tap the tempo, see “Setting the tempo by tapping” on page 67.

 If you want to stretch audio to conform to the project tempo, see “Making an audio clip follow tempo changes” on page 64.

To remove all tempo changes, see “Resetting the entire tempo map” on page 68.

See:

“Setting the project tempo” on page 66

“Setting the tempo by tapping” on page 67

“Editing the tempo map” on page 68

See also:

“How tempo changes affect audio clips” on page 64

“Tempo track” on page 65

“Tempo” on page 63

Setting the project tempo

A. Metronome menu (open for tap tempo) B. Double-click to enter a new tempo (or drag up/down)

The current tempo is shown in the main toolbar as a BPM value, and the value dynamically updates as tempo changes are 
encountered during playback or transport seeking.

To set the project’s tempo at the current Now time position, do one of the following:

Double-click the current tempo value and type the desired tempo, then press ENTER (Windows) / RETURN (Mac).

Position the mouse pointer over the tempo display and drag up/down.

See also:

“Using the metronome” on page 62

See:

“How tempo changes affect audio clips” on page 64

“Tempo track” on page 65

“Changing tempos” on page 66

“Editing the tempo map” on page 68

“Setting the tempo by tapping” on page 67

“Tempo” on page 63
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Setting the tempo by tapping

In a new song, the tempo may not be defined yet. If you don’t know the exact BPM value for your project, you can manually set the 
project tempo by tapping the mouse button or the ENTER (Windows / RETURN (Mac) key. The tapped tempo is inserted at the 
current Now time position.

Using Tap Tempo

1. Click the Metronome button  drop-down menu  to open the metronome settings panel.

2. Click the TAP button repeatedly to tap the desired tempo.

3. Click the Apply button to apply the tapped tempo, or press ESC to cancel a pending tempo change.

See:

“How tempo changes affect audio clips” on page 64

“Tempo track” on page 65

“Changing tempos” on page 66

“Setting the project tempo” on page 66

“Editing the tempo map” on page 68

“Tempo” on page 63

See also:

“Using the metronome” on page 62

Tip: After clicking the TAP button to give it focus, you can press the ENTER (Windows) / RETURN (Mac) key to tap the tempo.
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Editing the tempo map

Figure 10. Tempo track.

In the Tempo track, tempo changes are represented by envelope shapes. You edit the project’s tempo map the same way you edit 
automation envelopes (see “Creating and editing automation envelopes” on page 213 and “Drawing automation” on page 215). If a 
project has a single fixed tempo, the Tempo track shows a straight horizontal line. You create tempo changes by adding envelope 
nodes and editing their values. You can expand the Tempo track to give yourself more room to work, and adjust the range of values 
for the Tempo track.

Resetting the entire tempo map

To reset the entire tempo map and clear all tempo changes, right-click the tempo envelope and select Reset Automation.

See:

“Creating and editing automation envelopes” on page 213

“Drawing automation” on page 215

“Resetting an automation envelope” on page 217

“Deleting automation” on page 217

“Tempo” on page 63

Note: The Tempo track respects the current Snap to Grid settings when dragging envelope nodes horizontally. To make it easier 
to insert tempo changes on beat or measure boundaries, set the Snap to Grid resolution to 1/4 Note or 1 Bar. For details, see 
“Using the Snap Grid” on page 147.

Note: By default, when dragging tempo envelope nodes vertically, tempos automatically snap to whole BPM values, without 
decimal points. To adjust with fine resolution, hold down the SHIFT key.
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Virtual MIDI Controller
The Virtual MIDI Controller allows you to easily record a MIDI performance using a mouse, computer keyboard or by tapping on a 
multi-touch-enabled monitor, without having to use a physical MIDI controller.

Enabling Virtual MIDI Controller

To enable virtual MIDI input and show the Virtual MIDI Controller, do one of the following:\

Select View > Show Virtual MIDI Controller

Press CTRL+M (Windows) / CMD+M (Mac)

Click an instrument track’s track type icon  in the track inspector

Figure 11. Track Inspector.

To enable QWERTY to MIDI input without showing the virtual keyboard, do one of the following:

Select View > Toggle QWERTY to MIDI Input

Press CTRL+ALT+M (Windows) / CTRL+CMD+OPTION+M (Mac)
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Playing the Virtual MIDI Controller with a computer keyboard

To play the polyphonic keyboard, click the on-screen keys or press the corresponding keys on your computer keyboard.

Figure 12. Virtual MIDI Controller.

A. Pitch Wheel B. Modulation C. Black/white keys D. Corresponding computer key E. Current octave F. Hold (Sustain 
pedal) G. Velocity H. Channel I. Octave

Changing the octave

The leftmost white key (A) indicates the current octave (C0-C9). To change the octave, do one of the following:

Drag the blue octave indicator left/right.

Click the octave number an drag up/down.

Press the COMMA (,) key to scroll down one octave, or the PERIOD (.) key to scroll up one octave.

Enabling/disabling sustain

To enable sustain, do one of the following:

Click the Hold button

Press the SHIFT key

Using the pitch wheel

To adjust the pitch wheel, do one of the following:

Drag the Pitch control up/down

Press the UP key to raise the pitch, and DOWN key to lower the pitch

Adjusting modulation

To adjust modulation, do one of the following:

Drag the Mod control up/down

Press the LEFT key to decrease modulation, and RIGHT key to increase modulation

Changing the velocity

The change the velocity, drag the Velocity control up/down.

Changing the MIDI channel

The change the MIDI channel, drag the Channel control up/down.
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Loop Browser
71Loop Browser

The Loop Browser lets you access and import a professionally curated selection of premium audio packs, loops, and one-shots right 
from within Next. Just drag & drop directly into tracks.

Highlights

Royalty-free loops & samples for personal or commercial use. No attribution needed. 100% free, with new samples added 
frequently.

Unlimited access to thousands of samples from mainstream and underground genres.

Hi-res audio quality. All samples are uncompressed (.wav).

World-class content created by artists and professional sound designers.

Preview loops through any bus or hardware output, at the project tempo or recorded tempo.

Showing/hiding the Loop Browser

To show/hide the Loop Browser, do one of the following:

Select View > Show Loop Browser

Press B or F5

Note: You must sign in to your BandLab account (Help > Sign In) in order to access content in the Loop Browser.
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Loop Browser interface

Figure 13. Loop Browser.

A. Show packs B. Show loops C. Show one-Shots D. Filter E. Sort order F. Content (click to see the pack’s 
content) G. Search H. Preview I. Thumbnail image for selected sample (click to navigate to the sample’s parent pack) J. Repeat Loops
K. Previous loop L. Next loop M. Preview at project tempo N. Preview output

The Loop Browser contains the following controls:

Content type. Use the buttons at the top to select the type of content to show:

Packs . A pack is a curated collection of related loops and one-shots. Click a pack to view its collection of loops and one-
shots.

Loops . Loops are short audio clips that are designed to be repeated over and over or “looped”, such as a drum groove. 
When imported into a project, the loop conforms to the project tempo and can be “rolled out” to created multiple repetitions. 

Loops are indicated by the  icon 

One-Shots . One-shots are audio clips that are intended to play just once, such as a sound effect or a single drum hit. 

One-Shots are indicated by the  icon

Search filter. The search filter allows you to only show content that includes a specific text string in the file name or pack name.

Filter . Narrow down the available loops by searching using criteria like genre, instrument, and mood, helping you quickly find 
the desired loop for your project within the large library of BandLab sounds. Click the Filter button to show/hide filter options.

Sort order . Select the desired sort order: Name, Newest, Popular, or Random.

Repeat Loops . Repeat the selected loop continuously during preview.

Previous loop . Play the previous sample in the list.
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Preview . Play the currently selected pack, loop, or one-shot.

Next loop . Play the next sample in the list.

Preview at project tempo . Preview at the project tempo instead of the recorded tempo.

Preview output . Select the output device for previewing audio files.

Figure 14. Click a pack to view its collection of loops and one-shots.
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Importing loops

To import a loop or one-shot, do one of the following:

Drag from the Loop Browser to the Clips pane:

Drop on an existing track to import into the track.

Drop below the last track to import into a new track.

Double-click a loop/one-shot to import at the Now Time in the selected track.

Previewing loops

To preview a pack, loop, or one-shot, click its preview button .

To preview the selected loop, click the Preview button .

By default, loops preview at their original recorded tempo. To preview at the current project tempo, click the Preview at project 

tempo button .

You can preview loops through any bus or hardware output. To select the preview output, click the Preview output button .

Note: Loops and one-shots are downloaded to the path you specify in the Settings dialog box under Loop Cache Path (go to 
Edit > Preferences > Project - Folders Management). For details, see “Preferences” on page 247 and “Project settings” on 
page 253.

Tip: When previewing a loop or one-shot, click the pack thumbnail image at the bottom of the Loop Browser to navigate to the file’s 
parent pack.
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Finding loops with filters

The Loop Browser filter allows you to narrow down the available loops by searching using criteria like name, genre, instrument, and 
mood, helping you quickly find the desired loop for your project within the large library of BandLab sounds. 

To filter by name, click in the Search field and type a name. The Loop Browser will show only content that includes a specific text 
string in the file or pack name.

Figure 15. Search filter.

A. Search/filter box B. Clear current search filter

To filter by tags, click the Filter button  to show filter tags, then expand the Genres, Instruments, or Mood panel(s) to select the 
desired tag(s).

To clear an individual tag, click the tag’s “X” button.

To clear all filter tags, click Clear All.

Figure 16. Filter tags.

A. Show/hide filter controls B. Clear all tags C. Expand/collapse tag panel B. Clear tag
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You can combine search and filter tags for even more granular filtering. For example, you can search for samples that contain the 
name “Drums” and have an “Upbeat” mood.

Figure 17. Search and filter tags combined.

Sorting content

You can sort Loop Browser content by Name, Newest, Popular, or Random. To do so, click the Sort Order drop-down button  

(to the right of the Filter button ) and select the desired sort order.

Figure 18. Sort order.
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BandLab library import/export
Cakewalk Next® provides complete integration with your BandLab library, with support for downloads and uploads, tracking revision 
state, and setting song properties directly from within Next. You can export Next projects to BandLab as well as download projects 
from your BandLab library and open them in Next.

BandLab integration allows you to publish Next stems and mixes to the BandLab cloud, continue working on your songs using 
BandLab on mobile (iOS and Android) or web, and import your changes back to Next. This workflow presents many possibilities, 
including:

Publish Next projects, stems and mixes to your BandLab library, and easily share audio on mobile and web

Quickly open BandLab projects in Next

Collaborate easily by sharing audio tracks via the BandLab cloud

Bring projects started on mobile into Next for VST effects and advanced editing

Fly in vocals or other parts for a Next project from iOS and Android

Curate your music as playlists that you can play anywhere from your mobile device
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Quickly audition multiple mixes on different platforms (for example, check the mix in your car by connecting via Bluetooth to your 
car stereo)

Publish your Next projects to BandLab, then embed the song on the Next User-submitted Songs forum at https://
discuss.cakewalk.com/index.php?/forum/30-songs (this is much more powerful than posting a stereo mix to your song, because if 
you additionally provide stems others can offer more constructive advice on your mixes)

For more information about the free BandLab social music service, visit www.BandLab.com.

Publishing to your BandLab library
When publishing to BandLab, a project can be uploaded as a new project, or as a revision of the current BandLab project (see “What 
is a revision?” on page 78).

To publish the current project to your BandLab library, do one of the following:

Click the Share button  and select Publish to BandLab

Select File > Publish to BandLab

Press CTRL+B (Windows) / CMD+B (Mac) to open the Publish to BandLab dialog box

Click the Publish button drop-down menu  to specify the combination of project assets you wish to upload to the BandLab 
project. Tracks and buses are mixed down prior to uploading to BandLab.

For details, see “Publishing to BandLab” on page 79.

Importing from your BandLab library
To open a BandLab project, go to File > Open Project to open the Quick Start screen, then select the Online Library page. You 
may open as a new Next project or import into an existing project. Note that revisions are only tracked if you open as a new Next 

project. Click the Song Download Options button  to select the types of assets from the BandLab project you wish to download 
and open.

For details, see “Importing from BandLab” on page 82.

What is a revision?

A Revision is a revised edit of your project with a unique date/timestamp. A new revision is created every time you make a new 
BandLab project or save an edit of your existing BandLab project.

Revisions ensure that nothing is overwritten. All revisions are saved, and you can go back to an older version of your project at any 
time.

Cakewalk Next® projects opened from BandLab songs automatically inherit the song revision they were derived from. Subsequent 
uploads of the project by default are automatically linked to the last song revision. 

Projects that originate from Next also follow the same rules. You may also create fresh BandLab songs from a revision by selecting 
Upload as New Project in the Publish to BandLab dialog box (File > Publish to BandLab).

Collaborate with others

You can invite other people to collaborate on a project via the BandLab cloud. For details, see “Inviting collaborators” on page 85.

Switching BandLab user accounts

If you have multiple BandLab user accounts and would like to sign in as a different user, select Help > Sign Out, then select Help > 
Sign In to sign in with a different account.

See:

“Publishing to BandLab” on page 79

“Importing from BandLab” on page 82

“Inviting collaborators” on page 85

See also:

“Exporting” on page 241
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Publishing to BandLab

Max duration and track limit

When publishing to BandLab, you can export a maximum duration of 15 minutes and up to 16 tracks or buses.

If the project or selection exceeds these limits, adjust the selection before publishing to BandLab.

Public vs private projects

A BandLab project can be either public or private. When a project is marked as Public, anyone will be able to listen, comment and 
share the project. Mark a project as Public when you want to share your song with the BandLab community.

By default, all content is set to “Private”, meaning that only you and any invited collaborators can access it, make adaptations of it 
and use it. When Public is enabled, other users can view your content or play it on BandLab by streaming, but they will not be able 
to download, adapt, synchronize or use that content.

Publishing the current project to your BandLab library

After you have recorded and arranged your tracks, you can publish the project to your BandLab library.

To publish the current project:

1. Do one of the following:

Click the Share button  and select Publish to BandLab

Select File > Publish to BandLab

Press CTRL+B (Windows) / CMD+B (Mac) to open the Publish to BandLab dialog box

2. In the Publish to BandLab dialog box, you can modify the following project settings:

Title. Specify the name of the project as you want it to appear in BandLab. By default, the name is inherited from the Next 
project name.

Description. Enter a brief description for the project/revision (up to 250 characters).

Upload as New Project. [Only available if the current project has already been published] Instead of uploading as a revision 
of the current project, upload as a new project. Different edited versions of BandLab songs are linked together by a revision 
control system. For details, see “What is a revision?” on page 78.

Make Public. Share your song with the BandLab community. Anyone will be able to listen, comment and share this project. 
By default, all content is set to “Private”, meaning that only you and any invited collaborators can access it, make adaptations 
of it and use it. When Make Public is enabled, other users to view your content or play it on BandLab by streaming, but they 
will not be able to download, adapt, synchronize or use that content. For details, see “Public vs private projects” on page 79.

Publish options . Select the project assets you want to upload:

• Include Empty Tracks. Upload empty tracks. The project must contain at least one non-empty track.

• Include Track Regions. Upload individual clips instead of track mixdowns.

• Include Track Effects. Upload track effects.

• Add Track Mixdown. Publish individual audio tracks and Instrument track audio, up to a maximum of 16 tracks. All clips in 
a track are mixed down to a single region.

• Add Bus Mixdown. Publish stereo bus outputs, up to a maximum of 16 buses.

• Add Project Mixdown. Publish the entire mix as a single track. If you publish both individual tracks and a project 
mixdown, the project mixdown will be muted in order to prevent doubled audio.

Note: After the first export, subsequent exports from the same Next project will appear as revisions of the original BandLab 
project.
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3. Click Publish.

The project is exported to your BandLab library.

A toast notification appears after the export has been uploaded to the BandLab cloud.

Note: Projects will export as either 16-bit / 44.1kHz or 16-bit / 48kHz WAV files, depending on the project’s settings. Higher 
settings will automatically downsample to the required format during export.
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Canceling an in-progress upload

To cancel an in-progress upload, click the  button in the progress indicator.

Max duration and track limit

When publishing to BandLab, you can export a maximum duration of 15 minutes and up to 24 tracks or top-level track folders. 
Export is disabled if the project exceeds these limits.

You can group multiple audio tracks into a track folder in order to reduce the track count. Each track folder only counts as a single 
track. For details, see “Track folders” on page 17 and “Grouping tracks with track folders” on page 35.

See:

“Importing from BandLab” on page 82

“Inviting collaborators” on page 85

“BandLab library import/export” on page 77
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Importing from BandLab

You can open a BandLab project as a new Next project, or import a BandLab project into the current Next project.

To open or import a BandLab project that has not been downloaded yet. See “Opening or importing a project from your 
BandLab library” on page 82.

To open a BandLab project that has already been downloaded. See “Opening a downloaded BandLab project” on page 84.

Opening or importing a project from your BandLab library

You can load a project from your BandLab library, or import it into the current project.

To open or import a project from your BandLab library:

1. Go to File > Open Project to open the Quick Start screen, then select the Online Library page.

If you are not already logged in to your BandLab account, you will be prompted to log in.

2. Select the project you want to open or import.
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3. Click the Song Download Options button  and, specify which assets to include when opening/importing the selected project:

• Include Empty Tracks. Include tracks that contain no data.

• Include Track Regions. Include individual clips instead of track mixdowns.

• Include Track Effects. Include track effects.

• Add Track Mixdown. Include individual track stems.

• Add Bus Mixdown. Include individual bus stems.

• Add Project Mixdown. Include a stereo mixdown of the project. If you import both individual tracks and a project 
mixdown, the project mixdown will be muted in order to prevent doubled audio.

4. Do one of the following:

To open the project as a new Next project, double-click the project.

To append the project to the current Next project, enable Import, then double-click the project.

Figure 19. Quick Start screen: Online Library page.

A. Show Online Library B. Import (enable to import; disable to load) C. Song Download Options D. Refresh project list E. Search F. View Selected 
Song Online G. Selected project is highlighted

Note: The BandLab server must generate individual track mixdowns. The timing for this is dependent on server availability. If 
the server is busy you may get a message notifying you that track mixdowns are not ready yet. You can choose to download 
without the mixdowns, or retry downloading the project again later.
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The Quick Start screen Online Library page contains the following settings:

Projects. List of all projects in your BandLab library.

 Import. Enable to import and append the selected project to the current Next project instead of opening as a new project.

Song Download Options . Specify which assets to include when opening/importing the selected project:

 Include Empty Tracks. Include tracks that contain no data.

 Include Track Regions. Include individual clips instead of track mixdowns. 

 Include Track Effects. Include track effects.

Add Track Mixdown. Include individual track stems.

Add Bus Mixdown. Include individual bus stems.

Add Project Mixdown. Include a stereo mixdown of the project.

Refresh . Refresh the project list.

Search. Search the project list.

View Selected Song Online . View the project on www.bandlab.com, where you can view project history, view and invite 
collaborators, and open the project in BandLab Mix Editor.

Opening a downloaded BandLab project

If you have already downloaded a BandLab project to your local file system (see “Opening or importing a project from your BandLab 
library” on page 82), you can open it as a new Next project without having to redownload the project.

To open a downloaded BandLab project as a new Next project, do one of the following:

1. Go to File > Open Project to open the Quick Start screen.

2. Click the Browse button  to open the Open Project dialog box.

3. Navigate to the C:\Users\<user name>\Documents\BandLab\Downloads folder.

4. Double-click the desired project folder.

5. Select the BandLab Interchange file (.blx) and click Open.

The BandLab Interchange file opens as a new untitled Next project that must be saved with a new file name.

See:

“Publishing to BandLab” on page 79

“Inviting collaborators” on page 85

“BandLab library import/export” on page 77

Note: The BandLab server must generate individual track mixdowns. The timing for this is dependent on server availability. If 
the server is busy you may get a message notifying you that track mixdowns are not ready yet. You can choose to download 
without the mixdowns, or retry downloading the project again later.
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Inviting collaborators

You can invite other people to collaborate on a project. To do so:

1. Go to File > Open Project to open the Quick Start screen, then select the Online Library page.

2. Select the project you would like to collaborate on, then click the View Selected Song Online button  to open the project in 
your web browser.

3. On the project web page, click Project Details.

4. Click the Options button  and select Invite Collaborators.

5. Enter the person’s BandLab username or email address, provide an optional message, then click Send.

When a collaborator makes any changes to the project, it is uploaded as a revision, so your original project is not be modified 
directly.

You can also share the project URL with others. Anyone who has access to the link can join and edit the project.

The number of collaborators is shown in the Quick Start screen Online Library page after the project author name.

See:

“Publishing to BandLab” on page 79

“Importing from BandLab” on page 82

“BandLab library import/export” on page 77

Note: Collaborators can access your project even when it's set to Private.
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Inspectors
When working on a project, you will frequently need to access track and clip parameters and mix controls. The Track Inspector and 
Clip Inspector provide easy access to relevant settings for the selected track.

The Inspectors appears below the Track view. There are two separate inspectors:

Track Inspector. The Track Inspector lets you add effects and configure input echo, input, output, and sends for the selected 
track/bus/track folder. For details, see “Track Inspector” on page 89.

Piano Roll view. The Clip Inspector lets you edit MIDI data in the selected instrument track. For details, see “Clip inspector / 
Piano Roll view” on page 94.

Audio Clip view. The Audio clip view allows you to precisely edit individual audio clips in your project, including Track view clips 
and Loop Browser files. For details, see “Audio Clip view” on page 97.

Arranger Inspector. The Arranger Inspector shows all the arranger sections defined in the project’s timeline, and allows you to 
create unlimited different arrangements of the current project. Each arrangement can contain any combination of sections, in any 
order. For details, see “Arranger” on page 101 and “Arranger Inspector” on page 106.

Lyrics Inspector. The Lyrics Inspector can toggle between showing the Lyrics Editor (and Lyrics Scratch Pad) and Lyrics 
Prompter. For details, see “Lyrics” on page 221 and “Lyrics Inspector” on page 225.

A. Arranger Inspector B. Lyrics Inspector (the Track Inspector and Clip Inspector also appear here)

See:

“Track Inspector” on page 89
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“Clip inspector / Piano Roll view” on page 94
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Track Inspector

The Track Inspector lets you add effects and configure input echo, input, output, and sends for the selected track/bus/track folder.

To show/hide the Track Inspector, do one of the following:

Select View > Show Track Inspector

Press F3

Double-click a track’s icon

Figure 20. Track Inspector.

A. Track Name B. Icon C. Color D. Bypass Effect D. Output E. Track Type Icon F. Input G. Output H. Send Bypass I. Send Level J. Send 
Destination K. Add Send L. Pre Fader/Post Fader/Input M. Show/Hide Menu N. Effect input meter O. Show/Hide Effect Parameters P. Effect 
Parameters Q. Add Effect

The left side of the Track Inspector contains the following controls.

Track type icon. Track type icons are used to distinguish between different track types. These icon are separate from the 
assignable per-track icons.

  = Audio track

  = Instrument track, including Sampler, Pad Controller, and Instrument Rack (click to open the Virtual MIDI Controller. For 
details, see “Virtual MIDI Controller” on page 69).

  = Track folder

  = Bus

Name. The Name control lets you assign a descriptive name to each track. Double-click to edit.

 Icon. Assign a descriptive icon to identify the track content.

Color. Track colors make it easy to distinguish tracks. Click to change the track color.

 

E

G

L N OM P

D

Q

F

A B C

KH I J
89Inspectors

Track Inspector



Routing. The Routing sections lets you assign the input and output device.

 Input . Select the input device to use for recording and input monitoring.

Output . Select the output device to use for playback.

Sends. Click  to send the signal to an existing or new bus. Each send contains the following controls:

Bypass. Bypass the send.

Name. Name of the destination bus.

Send level. Controls volume of audio data sent by the send.

Tap point. Specify the send’s tap point:

• Input . The send signal goes to the bus prior to the track’s effects.

• Pre Fader . The send signal goes to the bus prior to the track’s volume fader.

• Post Fader . The send signal goes to the bus after the volume fader.

Show/Hide Menu  / . Show/hide the left pane of the Track Inspector.

The right side of the Track Inspector shows effects and effect parameters. To show/hide effect parameters, hover over the plugin 

name and click an effect’s expand/collapse button  /  or double-click the plugin name.

See:

“Enabling track input monitoring” on page 53

“Choosing an input” on page 53

“Inserting effects” on page 193

“Replacing an instrument” on page 30

Note: Input and Input Monitoring controls are not available for track folders and buses.
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Plugin Modules

Plugin modules are ergonomic representations of track plugins, presented to fit in the track Track Inspector.

Instruments and effects parameters are automatically allocated to module control slots and made available for track automation (see 
“Automating effects” on page 218). To map VST effect parameters to control slots, see “Mapping plugin parameters” on page 200.

Figure 21. Effect plugin module.

A. Bypass B. Effect parameters C. Open Plugin UI D. Input meter E. Effect name F. Parameter menu (add, reset, delete parameters) G. Expand/
Collapse Effect Module

See:

“Inserting effects” on page 193

“Opening an effect’s UI” on page 199

“Mapping plugin parameters” on page 200
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Tags

Tags make it easy to filter the list of audio effects, instrument, and chains based on categories.

A. Tags

Filtering by tags

Tags are shown in the leftmost column in the plugin browser. To filter the list by tags, click one or more tags. Tags are highlighted 
when selected.
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Assigning tags to audio effects and instruments

To assign one or more tags to an audio effect, instrument, or template:

1. Open the Track Inspector and click the Add Effect button .

2. Right-click the name of the effect/instrument, then select the tag(s) that you want to assign.

To create a new tag, type in the Add New Tag text box and press ENTER.

Editing a tag’s name and color

To edit a tag’s name and color:

1. Right-click the tag and select Edit.

2. Type a name or select a color.

3. Click Apply.

Removing a tag

To delete a tag and remove it from any objects that may be using it, right-click the tag and select Remove.

See:

“Filtering by tags” on page 196.

“Assigning tags to audio effects and instruments” on page 93
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Clip inspector / Piano Roll view

The Clip Inspector lets you edit MIDI data in the selected instrument track.

To show/hide the Clip Inspector, do one of the following:

Select View > Show Piano Roll

Press F4

Double-click a MIDI clip header

Figure 22. Clip Inspector / Piano Roll.

A. Show Only Active Notes / Show Full Note Range B. Toggle Note Audition C. Draw Tool D. Toggle MIDI Velocity Display E. Edit Clip 
Automation F. Automation Parameter G. Clip Channel Menu H. View Options I. Velocity J. What to Quantize K. Quantize L. Quantize 
Resolution M. Show/Hide Menu N. Piano Roll keys O. MIDI clip P. Snap to Grid

The right side of the Clip Inspector contains the Piano Roll editor, which lets you edit MIDI note events and controllers.

Draw Tool . Enable/disable the Note Drawing tool. When enabled, you can drag to draw notes. When disabled, you must 
double-click to add notes. For details, see “Drawing note events” on page 141.

Step Mode . Step Mode allows you to quickly draw multiple notes with a specified duration. This is very useful when 
drawing repeated notes, such as cymbals. For details, see “Step Draw Mode” on page 142.

Toggle MIDI Velocity Display . Show/hide the velocity graph, which shows a velocity stem for each note event.

Edit Clip Automation . Show/hide clip automation in the Piano Roll editor. Use the Automation menu in the left pane to 
select the automation parameter. For details, see “MIDI clip automation” on page 219.

Automation parameter. Select the MIDI clip automation parameter you want to see/edit in the Piano Roll editor. To hide the 

automation parameter again, click the Edit Clip Automation button .

Snap to Grid . The Piano Roll editor’s Snap to Grid control is located in the bottom right corner (see “Using the Snap Grid” 
on page 147.
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View Options . The View Options menu contains the following:

Note velocity color. Specify how note velocity values affect note colors:

• Temperature. Lower velocities register as blue and higher velocities register as red (like a typical heat map).

• Brightness. Notes display their clip color plus a brightness value as a factor of velocity.

Zoom to fit. Zoom the selection horizontally.

Note height presets. Resize the note heights.

The left side of the Clip Inspector contains the following controls:

Velocity. Adjust the velocity of the selected note(s). Velocity represents how fast the key was struck. For details, see “Adjusting 
Note velocities” on page 145.

Quantize. Quantize adjusts the start time and duration of selected notes so that they line up with a fixed size grid.

Note start. Quantize the start position of selected notes.

Note end. Quantize the end position of selected notes.

Both. Quantize both the start and end positions of selected notes.

Amount. Select the desired quantize resolution to apply when you click the Quantize button.

Quantize. Apply the selected quantize resolution to the selected note(s). For details, see “Quantizing notes” on page 144.

Show Only Active Notes  / Show Full Note Range . By default, the Piano Roll shows the full note range. Click to toggle 
between showing the full note range and only active notes. For details, see “Showing only active notes” on page 146.

Toggle Note Audition  / . Audition notes while drawing, selecting, moving, transposing, and trimming notes.

Show/Hide Menu  / . Show/hide the left pane of the Clip Inspector.
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Note names and icons

The Piano Roll editor automatically shows note names and icons when editing BandLab drum instruments and Pad Controller 
tracks.

When displaying notes for a BandLab drum instrument track, only pitches that are assigned to a timber are shown.

When displaying notes for a Pad Controller track, only the 16 notes that correspond to the Pad Controller’s assigned input note 
values are shown. For details, see “Specifying a pad’s MIDI input note” on page 176.

See also:

“Instruments” on page 153

“Pad Controller” on page 171

See:

“Editing MIDI notes in the Piano Roll” on page 141

“MIDI clip automation” on page 219

 BandLab drum instrument: Pad Controller:
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Audio Clip view

The Audio clip view allows you to precisely edit individual audio clips in your project, including Track view clips and Loop Browser 
files. You can trim loop content in place while preserving the original clip boundaries and duration, adjust loop points, and drop new 
audio content into an existing clip.

To show the Audio clip view, do one of the following:

Select a clip, then select View > Show Audio Clip

Double-click an audio clip header

The Audio Clip view is docked at the bottom of the main view.

UI overview

The Audio Clip view shows the audio waveform of the sample and allows you to modify the following playback properties:

Sample start/end times (see “Trimming a clip” on page 98)

Sample loop start/end times (see “Adjusting clip loop start/end points” on page 99)

Figure 23. Audio Clip view.

A. Source clip B. Audio Clip view

By default, the Audio Clip view shows the full waveform of a trimmed clip. Drag vertically to zoom, and drag horizontally to scroll.
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Trimming a clip

To trim the start or end of a one-shot sample, drag the left or right edge of the waveform. The trimmed area is dimmed, and will not 
be audible during playback.

If the clip is set to Stretch to Tempo, the clip stretches and unstretches to follow the project tempo.

A. Trimmed region B. Trim start C. Trim end
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Adjusting clip loop start/end points

If a clip is Loop enabled (see “Looping a clip” on page 136), the Audio Clip view shows the loop region as a blue bar above the 
waveform.

To specify which section of the clip to loop, drag in the Audio Clip view time ruler, or drag the blue loop start and loop end handles.

To move the loop region, hold down the CTRL (Windows) / CMD (Mac) key and drag the blue loop range to the desired location.

A. Loop start B. Loop end

In the Track view, a looped clip may be rolled out to show multiple repetitions. The Audio Clip view, however, only shows a single 
repetition.

A. Main loop B. Repetition (3x)
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Replacing a loop’s content

You can drag and drop replacement audio into an existing clip, without disturbing the placement of the clip in the Track view. 

To do so, drag samples from the Loop Browser into the Audio Clip view. The clip’s original duration will remain intact, and loop 
repetitions will be added/removed as needed according to the source length. This allows you to audition different loops quickly in 
context without affecting the original clip position and length.

1. Double-click clip header to open the Audio Clip view2. Drag sample from Loop Browser to Audio Clip view to replace clip content

See also:

“Editing clips” on page 134
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Arranger
Overview

The Arranger track is an arrangement tool that provides several workflow benefits:

Easily rearrange sections of the entire project as one unit instead of moving individual clips. For example, instantly swap the 
positions of the first and second chorus for all tracks, or copy the first verse in order to double its duration (see “Arranger track 
drag operations” on page 120).

Experiment with different song structures in a non-destructive and non-linear manner. For example, does your song work best in 
AABA, ABAB, or ABAC song form? Define time range sections and sequence them in any order without destructively moving any 
clip data. You can even save multiple arrangements within each project (see “Creating arrangements” on page 121), and create 
Arranger templates that can be used in any project (see “Arranger templates” on page 124).

Create a color coded overview of the song structure, and use the Arranger Inspector to quickly navigate around the project and 
jump to song sections (see “Navigating by Arranger sections” on page 123).

Create arbitrary song sections anywhere on the project timeline, then later string them together for seamless playback (see 
“Defining sections of your song” on page 111 and “Creating arrangements” on page 121).

Sections provide an additional way to perform time based selections and edits of the project.

Create an unlimited number of arrangements per project, which can all be exported simultaneously (see “Exporting 
arrangements” on page 124).

Arranger functionality is distributed across two views:

Arranger track (see “Arranger track” on page 103)

Arranger Inspector (see “Arranger Inspector” on page 106)

Figure 24. Arranger track.

A. Arranger Inspector B. Arranger track(s)/timeline C. Sections D. Current arrangement
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An arrangement is comprised of Sections, each spanning a unique time range. Other section properties include name and color, to 
clearly delineate regions of time and track content by musical function.

Basic workflow

1. Create and edit sections either within the Arranger Inspector or Arranger track timeline (see “Defining sections of your song” on 
page 111).

2. Move, add, delete, trim and reorder sections (see “Editing sections” on page 117).

3. [Optional] Create arrangements (see “Creating arrangements” on page 121):

a) Create alternate orders of sections, called arrangements, without affecting track events.

b) Arrangement sections can be edited and previewed independently of project sections.

c) An arrangement can subsequently be rendered to the project timeline and/or exported (see “Exporting arrangements” on 
page 124).

See:

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Section types” on page 114

“Editing sections” on page 117

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124

Note: By default, clicking an Arranger section does not select any underlying track events. To enable automatic selection of track 

events when selecting sections, click the Select Events with Sections button  in the Arranger track header.

When enabled, clicking an Arranger section also selects underlying track events. Clicking again deselects track events, while 
retaining selection of the section. This behavior allows you to easily determine whether or not track events are included in section edit 
operations. Note that the selection highlight in the Clips pane indicates selected track events.
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Arranger track

A. Arranger track header B. Select Events with Sections C. Add Arranger Section D. Sections

The Arranger track allows you to define multiple sections, each with a unique time range (Verse, Chorus, etc.). You can then use the 
Arranger Inspector to create multiple arrangements that play back the sections in any desired order.

Figure 25. Arranger track.

A. Arranger Inspector B. Arranger track(s)/timeline C. Sections D. Current arrangement
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Showing/hiding the Arranger track

To show or hide the Arranger track, do one of the following:

Click the Track View Options button  and select Arranger under Project Tracks

Select View > Show Arranger Track

Press A

To resize the Arranger track, drag the splitter bar between the Arranger pane and the Track pane to change its height.

Figure 26. Drag the splitter bar vertically to resize the Arranger track.

The Arranger track is empty until you define one or more sections (see “Defining sections of your song” on page 111).

Arranger timeline

Figure 27. Arranger track timeline.

The Arranger track timeline shows all defined sections. You can drag to create and rearrange sections, then freely move them along 
the timeline.

Any changes in the Arranger timeline are immediately reflected in the Arranger Inspector’s Sections list, and vice versa.
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Arranger track time base

The time base format for the Arranger track can be set to either Musical or Absolute. The time base format determines what 
happens to sections when you change the project tempo.

To specify the time base format, right-click the Arranger track header, then select one of the following:

Musical.  A section’s M:B:T position stays constant, and its absolute position shifts.

Absolute.  A section’s absolute position stays constant, and its M:B:T position shifts. The Arranger track tooltip shows time as 
H:M:S:F and samples.

See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Section types” on page 114

“Editing sections” on page 117

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124
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Arranger Inspector

The Arranger Inspector manages a list of project sections, and facilitates quick reordering of sections without having to drag or zoom 
horizontally within the Clips pane.

Showing/hiding the Arranger Inspector

To show/hide the Arranger Inspector, do one of the following:

Select View > Show Arranger Inspector

Double-click a section in the Arranger track timeline

Press F6

Figure 28. Arranger Inspector.

A. Add section B. Sections C. Add all sections to current arrangement D. Preview current arrangement E. Elapsed time F. Current 
arrangement G. Commit current arrangement to project H. Arrangements menu (select and create new arrangements) I. Remaining time
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Sections

Sections are the building blocks that make up the song. Each section defines a time range in the project, such as Intro, Verse, 
Chorus, etc. An arrangement is an ordered set of sections. You can sort the sections in any order to define the playback order. To do 
so, drag the sections from the Sections area down to the Arrangements area.

The Sections area lists all the arranger sections defined in the project’s timeline, from which a custom arrangement can be built. 
The order of the sections reflect the order in which they appear in the timeline.

The Sections list provides an additional way to edit time based selections of the project. Any operation performed in the Sections 
list is immediately reflected in the project/timeline, and vice versa.

To copy all sections to the current arrangement, click the Add All Sections to Arrangement button . If one or more sections are 
selected, only the selected sections will be copied.

Add Section button

The Add Section button  inserts a new section.

The new section duration is inherited from the last clicked section, or defaults to 1 measure.

 If no sections are selected, the new section is added at the end.

 If at least one section is selected, the new section is added at the beginning of the selection, and downstream sections move to 
make room. Any selected track events also move.

See also:

“Defining sections of your song” on page 111

Tip: Right-click the Add Section button  or click the Select Section Type drop-down menu to insert a section of a specific type 
(see “Section types” on page 114).
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Arrangements

Figure 29. Arranger Inspector.

A. Add all sections to the current arrangement B. Drag here

The Arrangements area allows you to sequence sections in a non-linear manner without destructively moving any clip data, 
regardless of which order they appear in the project’s timeline.

The Sections list is a collection of project sections from which an arrangement can be built. To create an arrangement, drag sections 
from the Sections list or from the Arranger track. Any section can appear multiple times within an arrangement (or not at all).

To move sections in the list, drag them up or down.

To play the current arrangement, click the Preview button  (see “Previewing an arrangement” on page 122). The Arrangements 
list shows the order in which the sections are played back, from top to bottom.

To (destructively) render the current arrangement to the project’s timeline, click the Commit Arrangement to Project button  
(see “Committing an arrangement” on page 123).

Add All Sections to Arrangement button

The Add All Sections to Arrangement button  copies all sections to the current arrangement.

If one or more sections are selected, only the selected sections will be copied.

Note: Operations performed in the Arrangements section have no effect on the linear project structure until you click the 

Commit Arrangement to Project button , at which time the Arranger track timeline and the Sections list in the Arranger 
Inspector inherit the structure of the arrangement.
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Arrangement menu

The Arrangements menu lets you create, select, duplicate, rename, and delete arrangements.

Figure 30. Arrangements menu.

See also:

“Creating a new arrangement” on page 121

“Deleting an arrangement” on page 122

“Renaming an arrangement” on page 122

“Duplicating an arrangement” on page 122

Preview button

The Preview button  plays back the current Arrangement.

Arranger preview can only be started from the Arranger Inspector, not from the transport in the main toolbar.

To start preview from a specific section, click a section’s preview button in the Arranger Inspector.

To enable/disable preview looping, click the Loop Enable/Disable button .

Figure 31. Arranger Preview buttons.

A. Arrangement preview B. Section preview C. Loop arrangement preview

See also:

“Previewing an arrangement” on page 122
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Commit Arrangement to Project button

The Commit Arrangement to Project button  renders the arrangement to the project’s timeline and updates track content 
accordingly.

To insert a committed arrangement into the existing project at the Now Time, right-click the Commit Arrangement to Project button 

 and select Insert Committed Arrangement.

See also:

“Committing an arrangement” on page 123

Elapsed / remaining time

The elapsed and remaining time is displayed in H:M:S time format for the current arrangement.

During preview, the first time value increments to show elapsed time. The second time value decrements to show time remaining.

Figure 32. Arranger Inspector.

A. Elapsed time B. Remaining time

See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Section types” on page 114

“Editing sections” on page 117

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124
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Defining sections of your song

To use the Arranger track, you must first define time range sections such as Intro, Verse, Chorus, etc. Sections can be of any 
duration, but it is common to start/end them at measure boundaries.

Section behaviors

Sections are presented above the Clips pane, immediately below the time ruler.

Sections cannot overlap, but do not have to be contiguous.

Changing the position of a section changes the relative positions of track content within the section, with ripple effect.

Section position can also be changed without modifying track events.

Adding a section

If the Arranger track is not visible, select View > Show Arranger Track, or press A.

If the Arranger Inspector is not visible, select View > Show Arranger Inspector, or press F6.

New sections can be created by any of the following means:

Draw a range within the Arranger track timeline (below the time ruler).

Hold down the ALT (Windows) / OPTION (Mac) key to overwrite any downstream sections you draw over.

Hold down the SHIFT key to move over any downstream sections.

Double-click a blank area in the Arranger track. The new section duration is inherited from the last clicked section.

To insert a new section that spans the gap between two existing sections, hold down the ALT (Windows) / OPTION (Mac) key 
and double-click the gap, or right-click the gap and select Span Sections.

To insert a section at the mouse position, right-click the blank area in the Arranger track timeline and point to Insert Section, then 
select Here and select the desired section type.

To insert a section at the Now Time, right-click the blank area in the Arranger track timeline and point to Insert Section, then 
select At Now Time and select the desired section type.

A new section appears at the Now Time position.

 If there is space between the Now Time and the next section, the new section will be equal to the size of the previous selected 
section, or truncated to fit in the gap.

 If there is no space between the Now Time and the next section, the new section will be equal to the size of the previous 
selected section, and downstream sections move to make room. Any selected track events also move.

 If the Now Time position overlaps an existing section, the new section is added at the end.

Click the Add Section button  in the Arranger Inspector or Arranger track header.

The new section duration is inherited from the last clicked section, or defaults to 1 measure.

 If no sections are selected, the new section is added at the end.

 If at least one section is selected, the new section is added at the beginning of the selection, and downstream sections move 
to make room. Any selected track events also move.

New sections are given a default name and color, which can be changed by right-clicking the section (see “Renaming a section” on 
page 117 and “Changing the section color” on page 117).

Tip: When drawing section in the Arranger timeline, enable Snap to Grid and set the snap resolution to Measure.

Tip: Right-click the Add Section button  or click the Select Section Type drop-down menu to insert a section of a specific type 
(see “Section types” on page 114).
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Figure 33. Adding a section in the Arranger track timeline adds it in the Arranger Inspector as well.

Figure 34. Adding a section in the Arranger Inspector adds it in the Arranger track timeline as well.

By default, drawing a section or clicking the Add Section button  creates a new unassigned section, which can then be assigned 
to a specific section type (see “Assigning a section type to a section” on page 114). However, you can also directly insert a section of 
a specific type. This can be done in the following ways:

Right-click in the Arranger track and point to Insert Section, then select the desired section type from the submenu.

Right-click the Add Section button  in the Arranger Inspector or Arranger track header and select the section type from the 
pop-up menu.

Click the Select Section Type drop-down menu  in the Arranger Inspector.

Figure 35. Insert Section menu.

A. Insert the section at the location you clicked B. Insert the section at the Now Time C. Insert an unassigned section D. Section type to insert 

For more information about section types, see “Section types” on page 114.
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See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Section types” on page 114

“Section types” on page 114

“Editing sections” on page 117

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124
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Section types

Arranger sections can be assigned to an optional section type attribute, such as Verse, Chorus, Bridge, etc. Cakewalk Next® 
includes many common section types, and you can create your own custom section type presets (see “Creating a new section type 
preset” on page 115).

Section types provide the following benefits:

By tagging sections with type attributes, you can use Arranger templates (see “Arranger templates” on page 124) to instantly 
create new arrangements from your existing sections (see “To create a new arrangement from an Arranger template” on page 
125).

Quickly assign consistent names and colors to sections that serve specific musical functions in a song.

Directly insert new sections that automatically use appropriate names and colors.

Figure 36. Section types.

A. Section type name B. Section type abbreviation (indicates that the section has been assigned to a type) C. Section Type menu

To insert a section of a specific type, right-click the Add Section button  or click the Select Section Type drop-down menu in the 
Arranger Inspector.

Assigning a section type to a section
To assign a section type to a section, right-click a section in the Arranger track or Arranger Inspector, point to Section Type, and 
select the desired section type.

The section inherits the name and color from the section type preset.

When a section is assigned to a type, the type abbreviation is shown in the top right corner of the section. This serves as a visual 
aide to help you identify which sections have been assigned to a type.
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Creating a new section type preset

To create a new section type preset:

1. Create a section that has the name, color, and default length that you want to save as a preset. The section name must be 
different than any existing factory or user section types.

2. Right-click the section and select Section Type > New.

A new section type preset is created and assigned to the section.

Section type presets are global, not per project.

Figure 37. Section Type menu.

A. Section that is used as the source for a new section type preset (the section name must be different than any existing section type presets)

Note: If you have previously given the section a custom name, the original name is retained after assigning a section type. If 
you want to use the default style name, clear the current section name via the Rename command. A blank name will 
automatically use the stored style name. Should you want to use a blank section name, simply use a single space character as 
the name.

Note: In order to create a new section type, the selected section must have a unique name.The New command is disabled if:

• The selected section is assigned to a factory section type or an existing user section type
• The selected section has the same name as an existing section type. In order to create a new section type, the selected 

section must have a unique name.
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Figure 38. Factory section types and user section types are listed separately in the Section Type submenu.

A. No section type (unassigned) B. Factory section types C. User section types

To delete a user section type preset

Right-click a section that is assigned to the user section type that you want to delete, then select Section Type > Delete.

Section types are global. If a user section type is deleted, any sections that were assigned to the deleted type (in any project) will 
automatically be reassigned to No Section Type.

Unassigning a section

Right-click the section that you want to unassign, then select Section Type > No Section Type.

Unassigned sections do not display an abbreviated name in the top right corner.

See:

“Arranger” on page 101

“Arranger track” on page 103

Tip: Custom user section types are stored in userArrangerSectionTypes.json in %AppData%\Cakewalk\Cakewalk 
Core in case you want to back up or copy your custom section presets to a different computer.

Note: Factory section types cannot be deleted, only user section types.
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Editing sections

Arranger sections can be edited in the Arranger Inspectors Sections list, or in the Arranger track timeline.

If the Arranger track is not visible, click the View menu and select Show Arranger Track, or press A.

If the Arranger Inspector is not visible, click the View menu and select Show Arranger Inspector, or press F6.

Renaming a section

To rename a section, do one of the following:

Right-click the section and select Rename.

Double-click the section in the Arranger Inspector.

Select the section and press F2.

See also:

“Section types” on page 114

Changing the section color

To change a section’s color, right-click the section and select a color on the pop-up menu.

Resizing a section

To resize a section, drag the left or right section edge.

Abutting sections will move over if extending the section duration.

To overwrite abutting sections, hold down the ALT (Windows) / OPTION (Mac) key while resizing a section.

To move downstream sections when events are selected, hold down the SHIFT key while resizing a section.

Selecting a section

To select a single section, click the section in the Arranger track timeline or Arranger Inspector Sections list.

Selecting multiple sections
To select discontiguous sections, hold down the CTRL key and click the sections you want to select/deselect.

To select a range of sections, do one of the following:

Drag with the right mouse button to lasso select in the Arranger track timeline.

Click the first section, then hold down the SHIFT key and click the last section.

Drag in the time ruler to make a selection.

Tip: You can select multiple sections to change their color simultaneously. To select discontiguous sections, hold down the CTRL key 
and click the sections you want to select/deselect. To select a range of sections, click the first section, then hold down the SHIFT key 
and click the last section (see “Selecting multiple sections” on page 117). 

By default, clicking an Arranger section also selects underlying track events. Clicking again deselects track events, while 
retaining selection of the section. This behavior allows you to easily determine whether or not track events are included in section 
edit operations. Note that the selection highlight in the Clips pane indicates selected track events.
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Selecting all sections

To select all sections, without selecting the underlying track events, right-click any blank area in the Arranger track and select Select 
All.

Only the sections themselves are selected. Track events associated with the sections are not selected.

Selecting all sections and underlying track events
To select all sections along with any underlying track events, right-click any blank area in the Arranger track and select Select All + 
Events.

Cakewalk Next® selects all sections and track events across all tracks, within the bounds of the sections.

Track events not associated with selected sections are not affected.

Deleting a section

To delete a section, do one of the following:

Right-click the section and select Delete.

Click the section, then press the DELETE key.

Copying/duplicating a section

To copy/duplicate a section, do one of the following:

Hold down the CTRL (Windows) / OPTION (Mac) key and drag a section.

Right-click the section and select Duplicate.

Splitting a section

To split a section, position the Now Time at the location where you want to split the section, then right-click the section and select 
Split at Now Time.

Note: When deleting a section, you will also delete any selected track events. Click the section to toggle between selecting only 
the section or section+events.

Caution: An arrangement section is an instance of a project section. Deleting a project section will also remove all instances of 
that section from all arrangements.

Note: You can also split clips at section boundaries. To do so, make a selection, then right-click and select Split Clips at 
Boundaries.
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Merging multiple sections

To merge multiple sections, select two or more contiguous sections you want to merge (or drag in the time ruler to make a time 
selection), then right-click a selected section and select Merge.

Moving a section

To move a section, drag the section to the desired location (see “Arranger track drag operations” on page 120).

Swapping two sections
To swap two sections, drag a section onto the middle of another section.

Moving a section after another section

To move a section after another section, drag the section onto the end of another section.

To copy instead of move, hold down the CTRL (Windows) / OPTION (Mac) key.

Moving a section before another section

To move a section before another section, drag the section onto the beginning of another section.

To copy instead of move, hold down the CTRL (Windows) / OPTION (Mac) key.

Overwriting an existing section

To overwrite an existing section, hold down the ALT (Windows) / CTRL (Mac) key and drag a section onto another section.

Replacing an existing section

To replace an existing section, hold down ALT+SHIFT (Windows) / CTRL+SHIFT (Mac) and drag a section onto another section.

Moving a section to the middle of another section (and split target section)

To move a section to the middle of another section (and split target section), hold down the SHIFT key and drag a section onto the 
middle of another section.

To copy instead of move, hold down CTRL+SHIFT (Windows) / OPTION+SHIFT (Mac).

Note: You can use standard CTRL and SHIFT modifiers to select multiple sections.

Tip: When merging multiple sections, the merged section will inherit its name and color from the section you right-click.

When moving a section, you will also move any selected track events. Click the section to toggle between selecting only the 
section and section+track events.
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Arranger track drag operations

You can arrange sections in a variety of ways by using modifier keys. Some operations behave differently depending on whether you 
drop at the start, middle, or end on an existing section. The tooltip shows the current operation.

Arranger Inspector drag operations

To cancel a drag operation, press the ESC key.

See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124

Default
CTRL (Windows) /
OPTION (Mac)

ALT (Windows) /
CTRL (Mac)

SHIFT
CTRL+SHIFT 
(Windows) /
CMD+SHIFT (Mac)

ALT+SHIFT 
(Windows) /
CTRL+SHIFT (Mac)

Move to the middle of 
existing section: Swap
Move to end of 
existing section: insert 
after existing section
Move to beginning of 
existing section: insert 
before existing section

Make a copy of 
section:
Drag to middle of 
existing section: insert 
copy at beginning or 
end
Drag to end of existing 
section: insert copy 
after existing section
Drag to beginning of 
existing section: insert 
copy before existing 
section

Disables ripple for 
operation; overwrites if 
dropping into an 
existing section

Split destination 
section at drop point 
and move everything 
over

Split destination 
section at drop point, 
insert copy at drop 
point and move 
everything else over

Replace an existing 
section

Table 1. Arranger track drag operations

Default
CTRL (Windows) /
OPTION (Mac)

ALT (Windows) /
CTRL (Mac)

SHIFT

CTRL+SHIFT 
(Windows) /
OPTION+SHIFT 
(Mac)

ALT+SHIFT 
(Windows) /
CTRL+SHIFT (Mac)

Move
Move Before
Swap
Move After

Insert Copy Before
Insert Copy After

Overwrite Split and Insert Split and Insert Copy Replace

Table 2. Arranger track drag operations

Default
CTRL (Windows) /
CMD (Mac)

ALT (Windows) /
CTRL (Mac)

Move directly on top of existing section: Swap
Move above existing section: Insert before with 
ripple
Move below existing section: Insert after with 
ripple

Make a copy of section
Drag to middle of existing: insert copy at 
beginning or end
Drag to end of existing: insert copy at end
Drag to beginning: insert copy at beginning

Disables Ripple for operation (flips replace/
swap behavior)

Table 3. Arranger Inspector drag operations
Editing sections



Creating arrangements

An arrangement describes the overall structure of the song.

Sections can be sequenced in any order to create arrangements, without affecting project data. The sections don’t have to live on 
the project timeline in any specific location or order, because the arrangement determines in which order they are played back.

The Arranger Inspector allows you to create unlimited different arrangements of the current project. Each arrangement can contain 
any combination of sections, in any order. All arrangements are saved within the project.

If the Arranger Inspector is not visible, select View > Show Arranger Inspector or press F6.

Creating a new arrangement

To create a new arrangement:

1. Click the Arrangements menu and select New.

2. Drag sections from the Sections list down to the Arrangements list. You can also drag sections directly from the Arranger track.

Creating a new arrangement based on an existing arrangement

You can quickly create a new arrangement by selecting sections in an existing arrangement. To do so, select the desired sections in 
the Arranger Inspector’s Arrangements pane, then right-click in the Arrangements pane and select New Arrangement From 
Selection.

Adding a section to the current arrangement

To add a section to the current arrangement, do one of the following:

Drag the section(s) from the Sections area or from the Arranger track timeline down to the Arrangements area.

 In the Sections area, select the section(s) you want to add to the current arrangement, then click the Add Selected Sections to 

Arrangement button .

To move sections in the Arrangements list, drag them up or down.

Adding all sections to the current arrangement

To add all sections to the current arrangement:

1. Make sure either no sections are selected, or all sections are selected.

2. Click the Add All Sections to Arrangement button .

If one or more sections are selected, only the selected sections will be copied.

Removing a section from the current arrangement

To remove a section from the current arrangement, do one of the following:

Select the section in the Arrangements list and press the DELETE key.

Right-click the section in the Arrangements list and select Remove.

The Remove command removes the section from the arrangement, but does not delete it from the Sections list or from the 
Arranger track timeline.

Removing all sections from the current arrangement

To remove all sections from the current arrangement, right-click an empty area in the Arrangements list and select Remove All 
Arrangement Sections.

Only the sections themselves are removed. Track events associated with the sections are not affected.

Tip: To remove all instances of a specific section from the current arrangement, click the section in the Arranger Inspector’s Sections 
list. This selects all the instances of the section in the current arrangement. Next, right-click any of the selected instances of the section 
in the Arrangements list and select Remove.
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Selecting all sections in the current arrangement

To select all sections in the current arrangement, right-click an empty area in the Arrangements list and select Select All 
Arrangement Sections.

Only the sections themselves are selected. Track events associated with the sections are not selected.

Previewing an arrangement

To preview the current arrangement, click the Preview button  in the Arranger Inspector. Cakewalk Next® plays back the 
Arrangements list instead of the project’s linear timeline.

To start preview from a specific section, click a section’s preview button in the Arranger Inspector. Cakewalk Next® plays the current 
section to the end, then jumps to the next section until the end of the arrangement is reached.

To enable/disable preview looping, click the Loop Enable/Disable button .

Figure 39. Arranger Preview buttons.

A. Arrangement preview B. Section preview C. Loop arrangement preview

To preview only a single section, click the section’s preview button in the Arranger Inspector Sections list.

To start preview from somewhere within a section, position the Now Time where you would like preview to start from, then hold down 
the CTRL key and click a preview button. If the Now Time is within the section, then preview will start from the Now time. If the Now 
Time lies outside the preview section time region, preview will start from the beginning of the section as normal.

Deleting an arrangement
To delete an arrangement:

1. Select the arrangement you want to delete.

2. Click the Arrangements menu and select Delete.

The arrangement is removed from the menu and all sections in the Arrangements list are removed. No track events or Arranger 
track sections are affected.

Renaming an arrangement

To rename an arrangement:

1. Select the arrangement you want to rename.

2. Click the Arrangements menu and select Rename.

or

Double-click on the name displayed in the closed Arrangements menu.

Duplicating an arrangement

To duplicate an arrangement:

1. Select the arrangement you want to duplicate.

2. Click the Arrangements menu and select Duplicate.

Note: Clicking a section in the Arrangements list only sets the Now Time. The sections is not selected in the Arranger track 
timeline, and no track events are selected.

 

A

B

C
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Committing an arrangement

When you have configured an arrangement the way you like, and you are certain that you do not want to edit it any further, you can 
convert it to a linear project.

To commit an arrangement to the project’s timeline, select the arrangement, then click the Commit Arrangement to Project button 

.

The selected arrangement is converted into a linear project, updating track content and section display in the timeline accordingly.

Inserting an arrangement at the Now Time

You can insert a committed arrangement into the existing project at the Now Time. To do so, right-click the Commit Arrangement to 

Project button  and select Insert Committed Arrangement.

Sections for the inserted arrangement are added to the Arranger track. 

Any existing events after the Now Time will be shifted over to make room for the inserted arrangement.

See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Editing sections” on page 117

“Navigating by Arranger sections” on page 123

“Exporting arrangements” on page 124

“Arranger templates” on page 124

Navigating by Arranger sections

To locate the Now Time to the start of a section, click the section in the Arranger Inspector.

See:

“Arranger” on page 101

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Editing sections” on page 117

“Creating arrangements” on page 121

“Exporting arrangements” on page 124

Caution: Rendering an arrangement may potentially remove events from the project, so only use Commit Arrangement to 
Project when you no longer need to edit the arrangement. If in doubt, save a backup copy of the project before rendering the 
arrangement.

Note: Some generative VST instruments (EZkeys, EZdrummer, Jamstix, etc.) have their own internal timeline. If you sequence 
parts within the VSTi to play based on the original project timeline, the VSTi will play back using its internal timeline as a 
reference, and will not be aware of your new song structure after committing an arrangement.
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Exporting arrangements

You can export one or more arrangements without first having to render it to the timeline. To do so, click the Arrangements menu and 
select Export as Audio.

See:

“Arranger” on page 101

“Arranger track” on page 103

“Arranger Inspector” on page 106

“Defining sections of your song” on page 111

“Editing sections” on page 117

“Creating arrangements” on page 121

“Navigating by Arranger sections” on page 123

Arranger templates

Arranger templates are pre-defined song forms that store the order in which sections are arranged. You can think of an Arranger 
template as a map of an entire song.

Arranger templates are global and can be used in several ways:

Create a new arrangement track from a template. The template is applied to the Arranger track, which creates new sections. 
This is useful when starting a new song and you want to quickly create all Arranger sections for a typical song form that you can 
fill in with music.

Create a new arrangement. If your project already contains existing sections, you can use Arranger templates to create new 
arrangements from the existing sections. This allows you to preview your existing sections with different song forms. Sections that 
exist in the template but not in the project can be optionally created at the end of the project in the active Arranger track.

Arranger templates store the following information:

Section order

Section types

Section names

Section durations

Section colors

Cakewalk Next® includes many common Arranger templates, and you can create your own custom templates that can be used in 
any project. Arranger templates can be created from an existing Arranger track or from an existing arrangement.

To save the current arrangement as a template

1. In the Arranger track timeline or Arranger Inspector’s Section list, arrange sections in the desired order.

[Optional] To get the most benefit from Arranger templates, assign a section type to each section (see “Assigning a section type 
to a section” on page 114). This will allow templates to map their saved sections to existing sections.

2. Do one of the following:

 In the Arranger Inspector, click the Sections menu and select Save as Arranger Template.

 In the Track view, right-click the Arranger track name and select Save as Arranger Template.

To save an arrangement as a template

1. In the Arranger Inspector’s Arrangements list, arrange sections in the desired order.

2. Click the Arrangements menu and select Save as Arranger Template.

Note: Gaps between sections are not saved in Arranger templates.
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To insert a template into the current arrangement

To insert an Arranger template into the current arrangement, do one of the following:

 In the Arranger Inspector, click the Templates and Time Base button  and select Insert Arranger Track Template.

Right-click the Arranger track header and select Insert Arranger Track Template.

To create a new arrangement from an Arranger template

To create a new arrangement from an Arranger template, do one of the following:

 In the Arranger Inspector, click the Arrangements menu and select New Arrangement from Template.

Cakewalk Next® will try to match the sections in the project with the types specified within the template, and create a new 
arrangement from them.

Deleting Arranger templates

To delete an Arranger template, navigate to \Cakewalk\Next\Templates\Arranger and delete the desired Arranger template 
(.arr) file.

Arranger template location and naming convention

Next includes many Arranger templates that are based on common song forms such as AB, AABA, ABC, etc., where A typically 
refers to the Verse, B refers to the Chorus, and C refers to the Bridge.

By default, Arranger templates are stored in \Cakewalk\Next\Templates\Arranger.

See:

“Arranger track” on page 103

Note: When creating a new arrangement from a template, Cakewalk Next® attempts to automatically map sections that are 
stored in the template to sections that already exist in the project. The mapping is based on section names and types.

If the template contains types that don't exist in the project, it will try to find a section with the same name as that type. If there is no 
match, you will have the option of creating new blank sections of that type in the active Arranger track, or simply skipping sections of 
that type.
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Editing
See:

“Selecting” on page 127

“Editing tracks & track folders” on page 128

“Editing clips” on page 134

“Ripple editing” on page 139

“Editing MIDI notes in the Piano Roll” on page 141

“Using the Snap Grid” on page 147

“Aim assist” on page 148

See also:

“Stem separation” on page 149

Selecting

Selecting a single event

To select a single event, click on the event.

Selecting all events

To select all tracks/clips/events, select Edit > Select All or press CTRL+A (Windows) / CMD+A (Mac).

Making a time selection
To make a time selection, drag in the Clips pane or bottom half of the time ruler.
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Lasso selecting

To lasso select, do one of the following:

Hold down the ALT (Windows) / OPTION (Mac) key and drag

Dag with the right mouse button

Drag from below the last track

Editing tracks & track folders

Adjusting level and panning

To adjust a track, bus, or track folder’s playback level and pan, drag the Volume and Pan sliders.

To reset a slider to its default value, double-click the slider, or hold down the ALT (Windows) / OPTION (Mac) key and click the slider.

To adjust with fine resolution, hold down the SHIFT key and drag a slider.

See also:

“Quick grouping” on page 192

Muting/Unmuting a track/bus/track folder

To mute/unmute a track, bus, or track folder, click its Mute button  / .

 

 Volume slider: Pan knob:
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A track can become muted as a result of soloing another track. When soloing a track, all other non-soloed tracks become 

temporarily “soft” muted. This is indicated by a small orange dot next to the Mute button .

To unmute all tracks, click the global Mute toggle button  in the track pane header. Click again to restore the previous mute 
state.

Soloing/Unsoloing a track/bus/track folder

To solo/unsolo a track, bus, or track folder, click its Solo button  / .

To unsolo all tracks, click the global Solo toggle button  in the track pane header. Click again to restore the previous solo state.
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Resizing tracks

To resize a track vertically, drag the bottom of the track strip up/down.

To resize multiple tracks, select the track(s) you want to resize, then do one of the following:

Drag the bottom of any selected track strip up/down.

Press CTRL+UP/DOWN (Windows) / CMD+UP/DOWN (Mac).

To resize all tracks, do one of the following:

Select View > Track Heights and select the desired height.

Click the Track View Options button  and select the desired setting under Resize Tracks.

Press SHIFT+F to fit all tracks vertically.

Duplicating tracks

To duplicate one or more tracks, select the track(s), then do one of the following:

Select Edit > Duplicate.

Press CTRL+D (Windows) / CMD+D (Mac).

Renaming a track/bus/track folder

To rename a track, double-click the current name, type a new name, then press ENTER.

To show/hide track numbers, select Edit > Preferences and click Display, then select Track Number Display.
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Selecting a track/bus/track folder

To select a track, bus, or track folder, click any empty area in the channel strip background. Selected tracks are highlighted.

To modify a selection, hold down the CTRL (Windows) / CMD (Mac) key while making the selection.

To extend a selection, hold down the SHIFT key while making the selection.

Deleting a track/bus/track folder

Select the track(s), bus(s), and/or track folder(s) you want to delete, then go to Edit > Delete or press DELETE.

See also:

“Selecting a track/bus/track folder” on page 131

Grouping/ungrouping tracks in track folders

You can add and remove audio tracks from track folders at any time. A common use is to group tracks by instrument type and to 
ensure a project does not exceed a total of 24 tracks or top-level track folders if you intend to export the project to your BandLab 
library.

To place tracks into a new track folder, do one of the following:

Select the tracks you want to group, then press CTRL+G (Windows) / CMD+G (Mac), or go to Edit > Move to Track Folder.

To place tracks into an existing track folder:

Select the tracks you want to move to a track folder, then drag any of the selected tracks into the folder.

To remove all tracks from a track folder:

Select the track folder and press CTRL+U (Windows) / CMD+U (Mac), or go to Edit > Remove From Folder.

To remove tracks from a track folder, do one of the following:

Drag the tracks out of the folder.

See also:

“Track folders” on page 17

Note: If you delete a track folder, it will also delete everything inside the folder. Deleting a track folder will not ungroup its child 
tracks/subfolders.
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Expanding/collapsing track folders

To expand or collapse a track folder, click the arrow button (  / ). A track folder can only be expanded if it contains at least one 
track or nested track folder.

Sorting tracks

To rearrange one or more selected tracks, buses, or track folders, drag any selected track/bus/track folder vertically. A bold 
horizontal line indicates a valid drop location. 

Changing track color

To change the color of the selected track(s), do one of the following:

Click the color button in the Track Inspector.

Right-click the track and select Track Color. 

Inserted tracks, buses, and track folders cycle through the color palette.

 

 Folder collapsed:  Folder expanded:
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Adjusting sliders and knobs

There are several ways to adjust sliders and knobs:

Click and drag sliders horizontally

Click and drag knobs vertically

Hover over sliders/knobs and rotate the mouse wheel

Double-click a slider/knob to reset its default value

Hold down the SHIFT key and drag a slider/knob to adjust with fine resolution

See also:

“Quick grouping” on page 192

Bouncing tracks

The Edit > Bounce Tracks in Place command lets you mix down tracks that may be too complex for your machine to actually play 
in real time. If you require more CPU processing for real-time effects, use Bounce Tracks in Place to premix some of your tracks 
with real-time effects applied, saving CPU time during playback.

To bounce tracks:

1. Select the tracks that you want to mix down/bounce.

2. Select Edit > Bounce Tracks in Place.

Tracks are bounced in place, in their entirety. All clips in the track are combined into a single clip, with empty space between clips 
is filled with silence in the new clip.Effects, mix settings and automation are applied during the bounce, then cleared from the 
track.

See also:

“Bouncing audio” on page 206

“Bouncing clips” on page 138

Note: When bouncing an Instrument (MIDI) track, the Instrument track is converted to an audio track.

 Slider: Knob:
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Editing clips

Selecting a clip

To select a clip, click the clip header.

When selected, a clip header becomes brighter and the content colors invert.

Lasso selection

To lasso select clips, do one of the following:

Hold down th ALT (Windows) / OPTION (Mac) key and drag

Dag with the right mouse button

Drag from below the last track

Moving a clip

To move a clip, point to the clip header so the mouse cursor changes to a hand, then drag the clip to the desired location:

To move a clip to a different start time, drag the clip horizontally.

To move a clip to another track, drag the clip vertically.

Tip: Hold down the SHIFT key to constrain vertical or horizontal movement, depending on the direction you first move.

 

Not selected: Selected:

 

 

134 Editing

Editing clips



135Editing

Trimming a clip

To trim a clip's duration, point to the left or right clip edge until the mouse cursor changes to a double arrow, then drag the clip edge 
to a new location.

Only visible data will be audible during playback. Trimming is nondestructive, so you can drag a clip edge to reveal any hidden data. 
You cannot extend a clip beyond its original duration.

Trimming silence from a clip

To trim silence from both the beginning and end of the selected clip(s):

1. Right-click the clip and select Process > Trim Silence to open the Trim Silence dialog box.

2. Select the desired Threshold level, or double-click to type a custom value.

3. Click Trim.

Audio that falls below the threshold level is trimmed from the beginning and end of the clip(s).

Note: You can also trim MIDI clips in the Clip Inspector’s Piano Roll editor.
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Splitting a clip

To split a clip, do one of the following:

To split all selected clips at the Now time (if no clips are selected, all clips will be split):

Press S

Select Edit > Split

Right-click any selected clip header and select Split

To split a single clip at the mouse position, hold down the ALT (Windows) / CMD (Mac) key and point to the clip header so the 
mouse cursor changes to scissors, then click the clip header.

To split all selected clips at the mouse position, hold down ALT+SHIFT (Windows) / CMD+SHIFT (Mac) and point to the clip 
header so the mouse cursor changes to scissors, then click the clip header.

Splitting is non-destructive, so you can drag a clip’s edge at any time to reveal the trimmed content.

After splitting a clip, the left portion of the clip is selected by default. To specify the default split behavior, go to Edit > Preferences or 
press CTRL+, (Windows) / CMD+, (Mac) to open the Preferences dialog box, then select the Display page and select the desired 
setting in the Clip Selection After Split drop-down menu.

Looping a clip

To loop a clip:

1. Do one of the following:

Right-click the clip and select Loop/Unloop Clip.

Select the clip and press CTRL+L (Windows) / CMD+L (Mac).

2. Drag the clip edge to create repetitions.

Loop enabled clips are identified by a loop icon  in the bottom corners, and the start of each repetition is indicated by indentations 
in the clip and a dotted vertical line.

You can trim loop content in place and drag and drop replacement audio into an existing clip, without disturbing the placement of the 
clip in the Track view. For details, see “Audio Clip view” on page 97.

Note: To recombine multiple split clips, do one of the following:

• Delete one of the clips, then “unroll” the remaining clip to reveal the trimmed content.
• Select the clips that you want to combine, then right-click any selected clip header and select Bounce to New Clip.
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Stretching a clip

To stretch a clip, hold down the CTRL (Windows) / CMD (Mac) key and drag the clip edge.

Stretch enabled clips are identified by a stretch icon  in the bottom right corner.

To reset a stretched clip to 0% stretching, right-click the clip header and select Reset Stretch.

Fading an audio clip

To create a fade in, click the fade handle in the top left portion of the waveform, then drag to the right.

To create a fade out, click the fade handle in the top right portion of the waveform, then drag to the left.

Renaming a clip

To rename a clip, right-click the clip and select Rename.

Deleting a clip
To delete a clip, select the clip, then press DELETE, or select Edit > Delete.

Duplicating clips

To duplicate one or more clips, select the clip(s), then do one of the following:

Select Edit > Duplicate.

Press CTRL+D (Windows) / CMD+D (Mac).
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Inserting an empty MIDI clip

To insert an empty MIDI clip on an Instrument track, do one of the following:

Double-click an empty area in the Clips pane

Right-click an empty area in the Clips pane and select Insert Empty MIDI Clip on the context menu

Bouncing clips
You can consolidate multiple clips into a single clip. To do so, make a time selection that spans the clips you wan to combine, then 
right-click one of the selected clip headers and select Bounce to New Clip.

You can also bounce tracks in place. To do so, select the tracks that you want to bounce, then select Edit > Bounce Tracks in 
Place. This creates one clip per track that spans from the start of the project to the end of each track. For details, see “Bouncing 
tracks” on page 133.

Specifying a clip’s time base

The time base format for each clip can be set to either musical time or absolute time. The time base format determines what 
happens to clips when you change the project tempo:

Musical.  A clip’s M:B:T position stays constant, and its absolute position shifts.

Absolute.  A clip’s absolute position stays constant, and its M:B:T position shifts.

By default, clips are set to musical time. To toggle between musical and absolute time, right-click a clip header and select Set to 
Absolute Time or Set to Musical Time.

When a clip is set to absolute time, a small clock icon  appears in the top left corner of the clip.

See also:

“Stem separation” on page 149

“Audio Clip view” on page 97

 Musical time:  Absolute time:
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Ripple editing

Ripple editing means to adjust the position of a clip in the Track view, and automatically adjust the start position of all subsequent 
clips to compensate for the change.

Ripple editing is a convenient way to arrange clips and maintain sync relationships without leaving unintended gaps between the 
clips.

Ripple edit modes

You can choose to ripple edit just the selection, or all tracks plus Arranger track and Lyric track data. Click the Ripple Options button 

 drop-down menu  to specify the ripple edit mode:

Ripple Edit Selection . Affects all clips that are downstream from the selected clip(s). Only selected tracks, or tracks 
included via range selection within the clips pane are affected.

Ripple Edit All . In addition to downstream clips in all tracks, also affects Arranger and Lyric track data.

Enabling/disabling ripple editing

To enable/disable ripple editing, do one of the following:

Click the Enable/Disable Ripple button .Click the drop-down menu  to specify the ripple edit mode:

Ripple Edit Selection. Affects all clips that are downstream from the selected clip(s). Only selected tracks, or tracks 
included via range selection within the clips pane are affected.

Ripple Edit All. In addition to downstream clips in all tracks, also affects Arranger and Lyric track data.

Select Edit > Enable Ripple Edit.

Press CTRL+R.

Figure 40. Enable/Disable Ripple Edit button and menu.

Caution: Use caution when ripple editing, and make sure you don’t unintentionally move track data that is off screen. It is good 
practice to check the results often when editing multiple tracks.
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What works with ripple editing?

The following operations in the Track view support ripple editing:

Moving clips

Stretching/trimming the right edge of a clip

Delete, cut, and paste

 Import audio/MIDI

Delete empty space

Deleting empty space (close a gap)

To delete empty space and shift downstream data:

1. Click the Enable/Disable Ripple Editing Lanes button  drop-down menu  and select Ripple Edit Selection or Ripple 
Edit All.

2. Drag in the time ruler or Clips pane to select the time range you want to delete, then go to Edit > Delete or press the DELETE 
key.

Note: Automation envelopes follow when ripple editing clips.
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Editing MIDI notes in the Piano Roll

You can edit the selected instrument track’s MIDI notes in the Clip Inspector’s Piano Roll editor (see “Clip inspector / Piano Roll 
view” on page 94).

Drawing note events

To create new note events, do one of the following:

 If the Note drawing tool  is disabled, double-click to insert new note events.

 If the Note drawing tool  is enabled, click or drag to draw new note events. While drawing, you can drag in any direction to 
change the note duration or pitch.

Note drawing obeys the current Snap to Grid  setting (see “Using the Snap Grid” on page 147).

When drawing notes, use the SHIFT modifier to constrain the pitch to the row in which the drag operation originated.

The SHIFT modifier may be applied before or during the draw operation:

 If SHIFT is pressed after drawing has started, it will clamp the pitch

 If SHIFT is pressed before drawing, it will invoke the existing lasso select behavior:

SHIFT + lasso selects the notes, replacing the existing selection

CTRL (Windows) / CMD (Mac) + lasso selects the notes, adding to the existing selection

Note: When using BandLab instruments, the piano keys in the Piano Roll editor indicate the valid note range for the current 
instrument. Keys that are out of range are dimmed.
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Step Draw Mode

The Draw tool  has an optional Step Mode , which allows you to quickly draw multiple notes with a specified duration. 
This is very useful when drawing repeated notes, such as cymbals.

Step Mode is only available when the Draw tool  is enabled. To enable/disable Step Mode, click the Step Mode button . 
To specify the step duration, click the Step Mode button drop-down menu.

A. Enable/disable Step Mode B. Step duration menu C. Draw tool (must be enabled)

Drag left or right to draw notes with the specified duration. While drawing, you can move the mouse up or down to draw different 
pitches, or hold down the SHIFT key to constrain the pitch.

Note: The Step Mode note duration automatically follows the last custom note duration. If you manually adjust a note length while 
Step Mode is engaged, the Step Mode note duration value updates to reflect that value, and any subsequent step note drawing will 
follow the last edited note duration.
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Note audition

To audition notes while drawing, selecting, moving, transposing, and trimming notes, click the Toggle Note Audition button .

Selecting notes

To select a note event, click the note

To select multiple notes, hold down the CTRL (Windows) / CMD (Mac) key and click each note that you want to select

To make a lasso selection, hold down the CTRL (Windows) / CMD (Mac) key and drag from an empty location

You can also select notes by clicking or dragging vertically on the Piano Roll keyboard. If a clip is selected, only corresponding notes 
in the currently selected clip(s) will be selected. If no clip is selected, all corresponding notes in the track will be selected.

To select all notes of a single pitch, click the corresponding piano key

To select all notes of several adjacent pitches, drag across the corresponding piano keys, or hold down the SHIFT key and click to 
extend the selection

To add to the selection, hold the SHIFT key while clicking on a piano key

To toggle the selection, hold the CTRL (Windows) / CMD (Mac) key while clicking on a piano key

Moving notes

To move a note event, click anywhere in the middle of a note and drag to the desired location. You can also use the arrow keys to 
move any selected notes.

To move all selected notes, drag any selected note (see “Selecting” on page 127).

Transposing notes

To transpose all selected notes up/down chromatically, press the UP/DOWN ARROW keys.

To transpose all selected notes up/down by octaves, hold down the SHIFT key and press the UP/DOWN ARROW keys.

Resizing notes
To resize a note event, drag the left or right edge of the note.

To resize note heights, click the View Options  button and select a note height preset, or hold down CTRL+SHIFT and use the 
mouse wheel.

Tip: To clear the note selection, press the ESCAPE key.
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Splitting notes

To split the selected note(s) into equal subdivisions, right-click and select Split Notes or press SHIFT+S.

The default subdivision is 2, unless Step Mode is enabled, in which case the notes will be split at the Step Mode intervals.

Merging notes

To merge the selected notes, right-click and select Merge Notes or press SHIFT+ALT+M (Windows) / SHIFT+OPTION+M (Mac).

Notes must be the same pitch in order to be merged.

Quantizing notes

To quantize notes:

1. Select the notes you want to quantize.

2. On the left side of the Clip Inspector, specify the desired quantize settings, then click the Quantize button.
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Adjusting Note velocities

There are two ways to adjust note velocities:

Select the note(s) you want to adjust, then drag the Velocity slider.

Click the Toggle MIDI Velocity Display button  (or right-click in the Piano Roll and select Toggle MIDI Velocity Display) to 
show velocity handles for all note events, then drag the desired handle(s) up/down.

Deleting notes

To delete notes, do one of the following:

Select the note(s) that you want to delete, then press the DELETE key, or right-click and select Delete

Double-click a note
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Editing clips in the Piano Roll

The Piano Roll shows a clip header for each clip, which allows you perform basic clip editing directly in the Piano Roll:

Click the header to select all events in the clip.

Drag the header to move the clip.

Drag the left or right header edge to trim the clip.

Double-click the header to fit the clip horizontally.

Double-click the clip name to rename the clip.

Specifying a clip’s MIDI channel

To specify a MIDI clip’s channel, click the clip’s menu button  in the Clip Inspector / Piano Roll, point to Clip Channel and select 
the desired channel (1–16).

Figure 41. Click a MIDI clip’s menu button to specify the MIDI channel.

Showing only active notes

By default, the Piano Roll shows the full note range. To only show active notes, click the Show Only Active Notes button . 

Click the button  again to toggle between the full note range and active notes.

See also:

“Note names and icons” on page 96
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Using the Snap Grid
Figure 42. Snap to Grid control.

Cakewalk Next® lets you define a snap grid that makes it easier to align clips and note events, select time ranges, set the loop 
region, and control automation envelope drawing. When drawing, moving, and resizing objects, the objects will snap to the nearest 
point on the snap grid.

You can set the snap resolution to an interval of bars, notes, or automatically adjust the resolution depending on the horizontal zoom 
level. The Clips pane and Piano Roll view have independent snap settings that allow you to align edits to specific note or measure 
boundaries.

Enabling/disabling the Snap Grid

To enable/disable snapping, click the Snap button  in the Clips pane or Piano Roll editor.

When snap is enabled, the vertical grid lines are solid. When snap is disabled, the vertical grid lines are dotted.

Figure 43. Snap to Grid menu.

A. Snap enable/disable B. Snap resolution
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Setting the snap resolution

To change the snap resolution, click the Snap Options button  to the right of the Snap button: . The following snap settings 
are available:

Adaptive. The snap resolution is dynamically determined by the horizontal zoom level. The snap grid is optimized to show 
relevant snap locations.

<Bar resolution>. Specify the snap resolution as a number of bars/measures (8, 4, 2, and 1).

<Note resolution>. Specify the snap resolution as a note duration (whole note – 1/256th note).

Dotted. Increase the size of the selected resolution by half of its original value (150%).

Triplet. Reduce the size of the selected resolution to 2/3 of its original value (three bars/notes fit in the space of two).

Magnetic. Enable magnetic snapping. While dragging the boundary of an object, you can move the boundary freely until the 
boundary gets within a certain number of ticks from the snap target. The closer the object gets to the snap target, the more 
strongly the object is pulled toward the target.

Overriding snap

To momentarily override the snap grid, hold down the ALT (Windows) / CTRL (Mac) key.

Aim assist

Aim Assist is a vertical line that shows the mouse pointer’s horizontal position in the Clips pane and Piano Roll editor. Aim Assist is a 
helpful guide when editing, making it easy to align the mouse pointer with events on different tracks.

When Snap to Grid is enabled, the Aim Assist line snaps to the nearest snap boundary.

Enabling/disabling Aim Assist

To enable/disable the vertical Aim Assist line, do one of the following:

Select View > Aim Assist

Press X

The vertical Aim Assist line is shown or hidden.

Figure 44. The Aim Assist line is a helpful guide when editing in the Clips pane.

A. Vertical Aim Assist line

Note: If the Clips pane or Piano Roll view is zoomed out a certain amount, the time boundary around the snap target will appear 
to be quite small, and you might think that the snap grid is not functioning. If this is the case, zoom in closer to enhance your 
editing experience.
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Stem separation
Use the integrated AI-powered stem separation tool to separate a mix into four separate tracks (known as audio stems):
Vocals

Bass

Drums

Other Instruments (guitar, piano, strings, etc.).

Stem separation makes it possible to remix songs, solo and manipulate individual instrument tracks, create backing tracks without 
vocals or guitars, dissect songs and learn individual parts, etc.

Note: Stem separation is processed on the BandLab server, so your computer must be online and you must be signed in to your 
BandLab account in order to use this feature.
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Separating stems from a mix

1. Import a song that you would like to separate into individual stems.

2. Right-click the imported audio clip and select Separate into Stems.

3. Click Yes to confirm.
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i) Next uploads the audio file to the BandLab server for processing. Stem separation happens in the background and may 
take a few minutes. You can continue to use Next during this time, and you will be notified when stem separation is 
complete.

ii) The online AI-powered stem separation tool analyzes the audio mix and separates the mix into separate stems.

iii) When processing is complete, the separated stems are downloaded to your computer.
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4. When the stems have been downloaded, click Create Stem Tracks to import the stems into the current project.

The stem tracks are created inside a new track folder named Separated Stems. You can now mute or remove the original audio 
track if it is no longer needed.

A. Original stereo mix B. Track folder that contains the separated stem tracks C. Stem tracks

See:

“Importing audio” on page 61

“Editing clips” on page 134

“Mixing” on page 187
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Instruments
Cakewalk Next® seamlessly integrates VST and BandLab software instruments.

Instruments can be played in various ways:

From an external MIDI controller (see “Playing an instrument from a MIDI controller” on page 155).

From Next’s virtual on-screen keyboard controller (see “Virtual MIDI Controller” on page 69).

By interacting with the soft synth’s UI (see “Opening an instrument’s plugin editor” on page 154).

By playing back recorded MIDI data (see “Playing an instrument with recorded MIDI data” on page 155).

See:

“Inserting an instrument” on page 153

“Replacing an instrument” on page 154

“Opening an instrument’s plugin editor” on page 154

“Playing an instrument” on page 155

“Triggering an instrument in real-time” on page 155

“Converting an Instrument track to audio” on page 155

“XSampler” on page 156

“Pad Controller” on page 171

“Instrument Rack” on page 177

Inserting an instrument

To insert an instrument:

1. Do one of the following:

Click the Insert Track button , then select Instrument .

Select Insert > Insert Instrument Track.

Press CTRL+SHIFT+T (Windows) / CMD+SHIFT+T (Mac).

2. In the Instrument Browser dialog box, select the desired instrument.

3. Click Add.

Previewing BandLab instruments

You can preview BandLab instruments from within the Plugin Browser before inserting an instrument. To do so, click the Preview  
button to the right of the instrument name.
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Opening an instrument’s plugin editor

To show a VST plugin’s native UI, click the Show plugin window button  above the plugin name in the Track Inspector.

Replacing an instrument

To replace an instrument with a different instrument:

1. Right-click the instrument’s module header in the Track Inspector and select Replace.

2. Select the desired instrument, then click Add.

Note: BandLab instruments do not have any UI, so they do not expose the Show plugin window button .
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Playing an instrument

There are several ways to play a software instrument:

Play back MIDI notes from the Piano Roll view and use the soft synth as a playback device.

Play the instrument in real-time from a MIDI controller or keyboard.

Triggering an instrument in real-time

There are several ways to trigger an instrument in real-time while recording:

From an external MIDI controller (see “Playing an instrument from a MIDI controller” on page 155).

From Next’s virtual on-screen keyboard controller (see “Virtual MIDI Controller” on page 69).

By interacting with the soft synth’s UI (see “Opening an instrument’s plugin editor” on page 154).

By playing back recorded MIDI data (see “Playing an instrument with recorded MIDI data” on page 155).

Playing an instrument with recorded MIDI data

1. Insert the desired instrument as an Instrument track.

2. Record or import some MIDI data into the Instrument track.

3. Play back the project.

When you play back the recorded MIDI data, you should hear the instrument through your audio device outputs. 

You can add effects to each of the synth tracks. You can also add MIDI effects to your soft synth MIDI tracks.

Playing an instrument from a MIDI controller

When an instrument track has focus, you can play the instrument with an external MIDI controller.

1. Make sure your MIDI controller is set to local off.

2. Insert the desired instrument as an Instrument track.

3. In the Track Inspector, select the MIDI input device and channel that your MIDI controller is transmitting on.

4. Make sure that the Instrument track has the focus, and play your MIDI controller.

Converting an Instrument track to audio

When your project sounds the way you want it to, it’s extremely easy to convert your Instrument tracks to audio for further processing 
if you prefer to work with audio data instead of MIDI events.

To convert an instrument track to a new audio track:

1. Select the instrument track(s) that you don’t want to convert to audio.

2. Click the Edit menu and select Bounce Tracks in Place.

See:

“XSampler” on page 156

“Pad Controller” on page 171

“Instrument Rack” on page 177

See also:

“Inserting instrument tracks” on page 29

“Replacing an instrument” on page 30

“Assigning tags to audio effects and instruments” on page 93

“VST plugin scanner” on page 203

“Plugin Manager” on page 209

“Converting MIDI to audio” on page 206
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XSampler

XSampler is a simple sampler that lets you import or record audio, perform basic processing, and play it like an instrument with up to 
16 voices. Instantly convert a single audio file into a playable or triggable sound that can be played back at different pitches and 
speeds.

Figure 45. XSampler.

There are many ways to get audio into XSampler: (see “Adding a sample” on page 164):

 Import audio from the file system

Record directly into XSampler

Drag loops and one-shots from the Loop Browser

Drag audio clips from any track

After audio has been added, you can loop, trim, crossfade, change playback behavior and modulation or filtering options to create 
interesting musical ideas. For details, see “Editing the sample” on page 168.

Highlights:

Multiple trigger modes

Up to 16 voices

Amplitude envelope generator (EG)

Filter

Pitch adjustment

Key mapping

See:

“Inserting XSampler” on page 157

“UI overview” on page 158

“Control panel” on page 162

“Adding a sample” on page 164

“Importing a sample” on page 164

“Recording a sample” on page 165
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“Triggering the sample” on page 166

“Editing the sample” on page 168

“Setting the root note” on page 167

“Setting the sample playback mode” on page 167

“Trimming the sample” on page 168

“Looping the sample” on page 169

“Crossfading a looped sample” on page 170

“Normalizing the sample” on page 170

“Reversing the sample” on page 170

Inserting XSampler

To quickly create an XSampler instrument, do one of the following:

Click the Insert Track button , then select Sampler .

Select Insert > Insert Sampler Track.

Press CTRL+SHIFT+X (Windows) / CMD+SHIFT+X (Mac).

Drag an audio clip/file to the track header pane.

Select Cakewalk > XSampler in the Plugin Browser.
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UI overview

To show the XSampler interface, open the Track Inspector for the Sampler track (Tip: double-click the Sampler track icon).

A. Browse audio B. Show/hide advanced settings C. Menu D. Gate mode E. Loop mode F. One-Shot mode G. Preview H. Record I. Bypass
J. Expand/Collapse K. Root key L. Keyboard M. Crossfade handle

XSampler contains the following primary views:

“Toolbar” on page 159

“Waveform panel” on page 160

“Keyboard view” on page 161

“Control panel” on page 162
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Toolbar

The main toolbar contains the following controls:

Browse Audio . Import an audio file from any folder. Supported formats include WAV, FLAC, OGG, MP3, M4A, AIF, AU, 
and WMA. You can also drag audio files directly into the Waveform panel.

Show/Hide Controls . Show/hide the Control panel, which contains additional parameters that let you process the sample. 
For details, see “Control panel” on page 162.

Edit Menu . Click the menu button to show the following commands:

Normalize Sample. Normalize the audio sample using either peak or RMS normalization. For details, see “Normalizing 
audio” on page 207.

Reverse Sample. Reverse the audio sample, making it play backwards. For details, see “Reversing audio” on page 208.

Reset All Parameters. Reset all parameters to the default values.

Playback modes. Select the sample’s playback mode:

Gate . The sample plays through its entirety or until a note off is received, at which point amplitude decreases steadily 
to -inf over the duration specified by the amplitude EG Release time.

Loop . The sample plays through until it reaches the loop end marker, at which point it seeks to the loop start marker, 
repeating until a note off event at a volume level specified by the Sustain level. When a note off occurs, volume decreases to 
-inf for the duration specified by the amplitude EG Release time. For details, see “Looping the sample” on page 169.

One-Shot . The sample plays from start to end whether a key is held or not, following only the Attack portion of the 
amplitude EG. If you retrigger the sample while it is already playing, it will play again from the beginning, and the previous 
instance will decreases to -inf for the duration specified by the amplitude EG Release time. One-Shot mode is suitable for 
single drum sounds or sound effects where you always want the entire sound to play.

Preview . Preview the sample at its root note value (Tip: Use when adjusting the loop boundaries in Loop mode).

Record . Record audio directly into XSampler from any audio input. To select the audio input source, click the drop-down 

menu  to open the Record Input menu. For details, see “Recording a sample” on page 165.
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Waveform panel

The waveform panel shows the audio waveform of the sample and allows you to graphically set the sample start and end points, set 
loop points, and set the loop crossfade length.

A. Loop drag zone B. Trim drag zone C. Crossfade drag zone

The Waveform panel is divided into three zones:

Top. Drag to adjust the loop region in Loop mode. For details, see “Looping the sample” on page 169.

Right-click the time ruler to select the time format (Absolute Time or Samples).

Middle. Drag the waveform edges to trim the sample. For details, see “Trimming the sample” on page 168.

Drag vertically to zoom.

Drag horizontally to scroll.

Bottom. Drag the crossfade handle in Loop mode. For details, see “Crossfading a looped sample” on page 170.

As you move the pointer across the Waveform panel, it changes to indicate that you can move a marker.

You can also drag audio directly into the Waveform panel to import an audio clip or file.
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Keyboard view

The Keyboard view provides the following capabilities:

Highlights playable key range.

Play notes. Click the keys will trigger the sample at the corresponding pitch. MIDI input keys are highlighted.

Set root key. The root key is blue. To change the root key, hold down the CTRL (Windows) / CMD (Mac) key and click a key. 
You can also drag the Root parameter up/down.

If the Stretch Mode parameter in the Controls panel is set to Original or n Bars, the sample can be pitch shifted +/- 1 octave. Keys 
below the root key will play the sample at a lower pitch and slower speed. Keys above the root key will play the sample at a higher 
pitch and faster speed. The keyboard highlights the valid key range (blue root one +/- 1 octave). To transpose the key range, change 
the root note.

A. Key range B. Root key (drag up/down to adjust) C. Root key (hold down CTRL (Windows) / CMD (Mac) and click to set) D. Triggered key

See:

“Triggering the sample” on page 166

“Key mapping” on page 166

“Setting the root note” on page 167
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Control panel

The Control panel provides access to a number of sound shaping parameters, such as pitch, filter, and an amplitude generator (EG). 
Use these parameters to quickly change the sound of the sample.

The waveform display is still available in a smaller format, but the keyboard is hidden.

Figure 46. XSampler Control panel.

The Control panel contains the following:

Waveform preview. The small waveform preview lets you perform the same functions as in the large waveform display. For 
details, see “Waveform panel” on page 160.

Amp Envelope section. You have full control over the ADSR sections, which allow hold-sustain performance of the sample:

Attack. The time it takes for the sample to reach its target level after being triggered (0.00 milliseconds – 20.0 seconds).

Decay. The time it takes for the sample to reach its sustain level after the attack phase (1.00 milliseconds – 60.0 seconds).

Sustain. The level at which the sample will play while being held (-Inf dB – 0 dB).

Release. The time it takes for the sample level to fade after note release (1.00 milliseconds – 60.0 seconds).

Mono. Limits the number of simultaneous voices to one.

Mix section:

Gain. Set the overall output volume level (-Inf dB – 6 dB).

Pan. Set the overall panorama position in the stereo field (100L – 100R).

Audio Type. Select the type that best matches the sampler's audio material for optimized audio processing:

• Drums.

• Vocals.

• Music.

Pitch section:

Shift. Tune the sample pitch in semitone steps (-12 steps – 12 steps).

Fine. Fine tune the sample pitch in cents (-50 cents – 50 cents). One cent is 1/100th of a semitone.
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Filter section:

Cutoff Frequency. Controls the filter cutoff frequency (20Hz – 20.0kHz).

Resonance. Amount of signal emphasis relative to the cutoff frequency (0.10 – 10.00). Higher settings boost frequencies in 
the immediate vicinity of the cutoff frequency.

Filter Type. Select a filter type to enable cutoff and resonance:

• None. No filter is applied.

• LowPass. Passes lower frequencies and attenuates content above the cutoff frequency.

• BandPass. Passes a select range of frequencies that surround the cutoff frequency, and attenuates the portions above 
and below that band.

• HighPass. Passes higher frequencies and attenuates content below the cutoff frequency.

Time Stretch section:

Stretch Mode. Specify the sample playback speed/duration:

• None. The sample duration changes according to pitch. Keys below the root key will play the sample at a lower pitch and 
slower speed. Keys above the root key will play the sample at a higher pitch and faster speed.

• Original. The sample plays at its original speed for all note pitches.

• n bars. The sample duration matches the bars value relative to the current tempo.

Note: If the Stretch Mode parameter is set to Original or n Bars, the sample can be pitch shifted +/- 1 octave, as indicated by 
the highlighted keyboard keys.

Note: The parameters in the Control panel can be adjusted over time by using automation. For details, see “Automation” on 
page 211.
163Instruments

XSampler



Adding a sample

There are many ways to get audio into XSampler:

 Import audio from the file system (see “Importing a sample” on page 164)

Drag loops and one-shots from the Loop Browser

Drag audio clips from any track

Record directly into XSampler (see “Recording a sample” on page 165)

Importing a sample

When you a Sampler track, the sampler is initially empty, ready for you to import or record audio.

To import an audio file, do one of the following:

Click the Browse Audio  button, then select the audio file that you want to import. Supported formats include WAV, FLAC, 
OGG, MP3, M4A, AIF, AU, and WMA. The button tooltip shows the imported audio file’s full folder path.

Drag a loop or one-shot from the Loop Browser to XSampler.

Drag a clip from an audio track to XSampler.

The imported file is automatically copied to the project’s \Audio folder.

Note: Each instance of XSampler can only store a single sample, so if you import or record another sample, it will overwrite the 
previous sample. You can select Edit > Undo to revert to the previous sample.
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Recording a sample

In addition to loading existing audio files, you can directly record your own samples into XSampler.

1. Click XSampler’s Record button  drop-down menu  to open the Record Input menu, then select the desired audio input 
source. The first input is selected by default (mono).

2. Click XSampler’s Record button  to start recording. During recording, the waveform appears in real-time.

3. Click the Record button  again to stop recording.

You can now play back the sample.

You may need to edit the start and end points of the recorded sample. For details, see “Editing the sample” on page 168 and 
“Trimming the sample” on page 168.
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Triggering the sample

There are several ways to trigger XSampler:

Click the XSampler keyboard keys (see “Keyboard view” on page 161)

Use an external MIDI controller as the Sampler track’s input (see “Playing an instrument from a MIDI controller” on page 155)

Use the Virtual MIDI Controller while the XSampler track has focus (see “Virtual MIDI Controller” on page 69)

Play back MIDI notes from the Piano Roll view (see “Editing MIDI notes in the Piano Roll” on page 141 and “Clip inspector / Piano 
Roll view” on page 94)

There are three primary settings that determine how a sample behaves when triggered:

Sample Playback Mode.  The sample playback mode determines whether sample playback stops on key release or plays 
through the entirety of the sample (see “Setting the sample playback mode” on page 167)

Root key. The root key specifies which key plays the sample at its original pitch and speed (see “Setting the root note” on page 
167).

Stretch Mode. If the Stretch Mode control is set to Original or n Bars, the sample can be pitch shifted +/- 1 octave from the 
root key. The keyboard highlights the valid key range. To transpose the valid key range, you must change the root note.

Key mapping

The sample is mapped to keys above and below the defined root key. Keys below the root key will play the sample at a lower pitch, 
and keys above the root key will play the sample at a higher pitch.

By default, XSampler automatically maps the sample across the entire MIDI note range (0–127) and sets the root note to C3.

If the Stretch Mode parameter in the Controls panel is set to Original or n Bars, the sample can be pitch shifted +/- 1 octave from 
the root key. Any incoming MIDI note events within this range will trigger the assigned sample. The keyboard highlights the valid key 
range (blue root one +/- 1 octave). To transpose the valid key range, you must change the root note (see “Setting the root note” on 
page 167).

A. Key range B. Root key

See:

“Keyboard view” on page 161

“Setting the root note” on page 167

“Control panel” on page 162
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Setting the root note

The sample is mapped to keys above and below the defined root key. The root key defines which keyboard note value is used to 
play the sample at the original pitch. Keys below the root key will play the sample at a lower pitch, and keys above the root key will 
play the sample at a higher pitch.

To change the root key, do one of the following:

To the left of the keyboard, drag the Root value up/down

Hold down the CTRL (Windows) / CMD (Mac) key and click the desired keyboard key

A. Root key (drag up/down to adjust) B. Root key (hold down CTRL (Windows) / CMD (Mac) and click to set)

Setting the sample playback mode

The sample playback mode determines whether sample playback stops on key release or plays through the entirety of the sample.

To specify the sample playback mode, select one of the following modes in the main toolbar:

Gate . The sample plays through its entirety or until a note off is received, at which point amplitude decreases steadily to -
inf over the duration specified by the amplitude EG Release time.

Loop . The sample play through until it reaches the loop end marker, at which point it seeks to the loop start marker, 
repeating until a note off event at a volume level specified by the Sustain level. When a note off occurs, volume decreases to -inf 
for the duration specified by the amplitude EG Release time. For details, see “Looping the sample” on page 169.

One-Shot . The sample plays from start to end whether a key is held or not, following only the Attack portion of the 
amplitude EG. If you retrigger the sample while it is already playing, it will play again from the beginning, and the previous 
instance will decreases to -inf for the duration specified by the amplitude EG Release time. One-Shot mode is suitable for single 
drum sounds or sound effects where you always want the entire sound to play.

Note: You can only click highlighted keys. If the desired root key is outside the current key range, hold down the CTRL (Windows) 
/ CMD (Mac) key and drag the blue root key to the desired key.
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Editing the sample

You can use the Waveform panel to set the trim start and end points, set loop points, and set the crossfade duration.

Use the Control panel to apply pitch shifting, ADSR envelope and filters.

You can use the Control panel to change the sound of the sample by applying various processing effects, including filters, pitch 

shifting, and ADSR amplitude envelope. To access these settings, click the Show/Hide Controls  button to show the Control 
panel. For details, see “Control panel” on page 162.

See:

“Trimming the sample” on page 168

“Looping the sample” on page 169

“Crossfading a looped sample” on page 170

“Normalizing the sample” on page 170

“Reversing the sample” on page 170

“Waveform panel” on page 160

Trimming the sample

To trim the start or end of the sample, drag the left or right edge of the waveform. The trimmed area is dimmed, and will not be 
audible during playback.

A. Trimmed region B. Trim start C. Trim end

Tip: You can modulate parameters over time by using automation. For details, see “Automation” on page 211.
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Looping the sample

To loop a sample, set its playback mode to Loop . The loop region is indicated by a blue bar above the waveform.

To adjust the loop region, drag in the loop zone, or drag the loop start and loop end handles. 

To move the loop region, hold down the CTRL (Windows) / CMD (Mac) key and drag the blue loop range to the desired location.

A. Loop start B. Loop end C. Loop enable/disable

Tip: To make sure the sample loops smoothly, click the Preview  button so you can hear the results while you adjust the loop 
start and loop end points.
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Crossfading a looped sample

When a sample’s playback mode is set to Loop , you can adjust the crossfade length between the loop start and loop end. To 

do so, drag the crossfade handle  left/right.

A. Fade out B. Fade in C. Crossfade handle

Normalizing the sample

To normalize the audio sample, click the menu button  and select Normalize Sample. For details, see “Normalizing audio” on 
page 207.

Reversing the sample

To reverse the audio sample so plays backwards, click the menu button  and select Reverse Sample. For details, see “Reversing 
audio” on page 208.

See:

“Instruments” on page 153

“XSampler” on page 156

Note: The crossfade handle cannot be moved if the loop region starts at the beginning of the sample.
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Pad Controller
Figure 47. Pad Controller.

Pad Controller consists of 16 trigger pads that can trigger audio samples or instruments. Each pad can contain a single sample or 
instrument. You can drag existing audio files to a pad, or record new audio directly to a pad. Pads can be triggered via a MIDI 
controller, by clicking, or from notes in an Instrument track.

Inserting Pad Controller

To insert Pad Controller, do one of the following:

Click the Insert Track button , then select Pad Controller .

Select Insert > Insert Pad Controller Track.

Press CTRL+SHIFT+P (Windows) / CMD+SHIFT+P (Mac).

Select Cakewalk > Pad Controller in the Plugin Browser.

UI overview

A. Input note B. Options menu C. Click empty background to give focus to the pad D. Audio or Instrument icon (click to trigger pad) E. Output/root 
note

Each pad contains the following:

 Input note (top left). Input: Which MIDI note the pad responds to. This is the note that triggers the pad. The 16 pads can be 
triggered via MIDI. The 16 pads are assigned to 16 consecutive MIDI pitches. Drag the slider to set the pitch range for all 16 pads. 
The default range is C3 – D#4.

Output note (bottom right). Which MIDI note the pad transmits when triggered. Click to give focus (XSampler); Want to default 
to root note of sample

 Icon/Trigger. Click to trigger sample; drag audio to pad or record in-place
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Options menu .

Browse Audio. Import an audio file into the pad. The audio sample is loaded into an instance of XSampler. For details, see 
“Importing audio to a pad” on page 173.

 Insert Empty XSampler. Add an empty instance of XSampler, which you can record into or import audio into.

Browse Instruments. Assign an instrument to the pad. For details, see “Assigning an instrument to a pad” on page 174.

Delete. Clear the pad so it becomes empty. For details, see “Clearing a pad” on page 176.

 Icon. Indicates if a pad contains an audio sample  or an instrument . Click the icon to trigger the pad. The pad is empty if 
it has no icon.

See:

“Adding content to a pad” on page 172

“Importing audio to a pad” on page 173

“Recording audio to a pad” on page 174

“Assigning an instrument to a pad” on page 174

“Triggering a pad” on page 175

“Stopping a pad from playing” on page 175

“Specifying a pad’s MIDI input note” on page 176

“Specifying a pad’s root (output) note” on page 176

“Clearing a pad” on page 176

Adding content to a pad

Each pad can be assigned to an audio file or instrument. There are several ways add content to a pad:

 Import audio from the file system (see “Importing audio to a pad” on page 173)

Drag loops and one-shots from the Loop Browser

Drag audio clips from any track

Record directly into a pad (see “Recording audio to a pad” on page 174)

 Insert an instrument (see “Assigning an instrument to a pad” on page 174)

See:

“Importing audio to a pad” on page 173

“Recording audio to a pad” on page 174

“Assigning an instrument to a pad” on page 174
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Importing audio to a pad

There are several ways import audio to a pad:

Drag loops and one-shots from the Loop Browser to the pad

Drag audio clips from any track to the pad

Click the pad’s Options button  and select Browse Audio.

The audio sample is loaded into a new instance of XSampler (see “XSampler” on page 156).

To show the imported audio in XSampler for a specific pad, click anywhere on the pad’s empty background to give it focus. The 
focused pad is outlined.

Pads that contain audio content are indicated by an audio icon 

A. Click a pad’s empty background to give focus to the pad (the focused pad is highlighted) B. Trigger pitch C. Root key D. Waveform icon 
indicates that the pad contains audio
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Recording audio to a pad

To record audio to a pad:

1. Click the pad’s Options button  and select Insert Empty XSampler to insert an empty instance of XSampler.

2. Click XSampler’s Record button  drop-down menu  to open the Record Input menu, then select the desired audio input.

3. Click XSampler’s Record button  to start recording.

4. Click the Record button  again to stop recording.

See also:

“XSampler” on page 156

“Recording a sample” on page 165

Assigning an instrument to a pad

To assign an instrument to a pad, click the pad’s Options button  and select Browse Instruments, then select the desired 
instrument.

Pads that contain an instrument content are indicated by an instrument icon 

See also:

“Inserting an instrument” on page 153
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Triggering a pad

Each pad has an input note and an output note. The input note in the top left corner is the MIDI note that triggers the pad. The output 
note in the bottom right corner is the MIDI note the pad transmits when triggered. For details, see “Specifying a pad’s MIDI input 
note” on page 176 and “Specifying a pad’s root (output) note” on page 176.

A. Input/Trigger note B. Output/root note

There are several ways to trigger a pad:

Click the pad’s icon

From an external MIDI controller (see “Playing an instrument from a MIDI controller” on page 155).

From Next’s virtual on-screen keyboard controller (see “Virtual MIDI Controller” on page 69).

By playing back recorded MIDI data on the Pad Controller track (see “Playing an instrument with recorded MIDI data” on page 
155).

A pad becomes highlighted when triggered.

A. Input/Trigger note (double-click to edit) A. Click the icon to trigger the pad

Stopping a pad from playing

To stop a pad from playing/previewing, click any empty area on the pad.
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Specifying a pad’s MIDI input note

The 16 pads can be triggered via MIDI. By default, the 16 pads are assigned to 16 consecutive MIDI pitches (C4 – D#5).

To change a pad’s input note, double-click the pad’s input note label.

Specifying a pad’s root (output) note

A pad’s root/output note determines which MIDI note the pad triggers.

To change a pad’s output/ note, double-click the pad’s output note label.

Clearing a pad

To clear all content from a pad, click the pad’s Options button  and select Clear Pad.

See:

“Instruments” on page 153

“XSampler” on page 156

Note: When editing a pad Controller track in the Piano Roll editor, the editor only shows the 16 notes that correspond to the Pad 
Controller’s input notes. For details, see “Clip inspector / Piano Roll view” on page 94 and “Note names and icons” on page 96.
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Instrument Rack
Figure 48. Instrument Rack.

Instrument Rack is a multi-instrument container, similar to Pad Controller, which allows you to layer multiple virtual instruments so 
they can be played simultaneously in parallel within a single track. Key capabilities include:

Up to 16 instruments can be added to each instance of Instrument Rack

Adjust volume and pan per instrument

Specify the MIDI input channel per instrument

 Isolate or overlap note ranges and velocity ranges

Add affects to each individual instrument and master effects for the entire rack

See:

“Inserting Instrument Rack” on page 177

“UI overview” on page 178

“Inserting an instrument in the rack” on page 181

“Specifying the MIDI input channel” on page 182

“Adjusting the velocity range” on page 183

“Adjusting the note range” on page 184

“Adding effects” on page 185

Inserting Instrument Rack

To insert Instrument Rack, do one of the following:

Click the Insert Track button , then select Instrument Rack .

Select Insert > Insert Instrument Rack Track.

Press CTRL+SHIFT+R (Windows) / CMD+SHIFT+R (Mac).

Select Cakewalk > Instrument Rack in the Plugin Browser.
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UI overview

To show the Instrument Rack interface, open the Track Inspector for the Instrument Rack track (Tip: double-click the Instrument 
Rack track icon).

Figure 49. Instrument Rack.

A. Instrument Rack B. Add slot effects C. Rack master effects D. Selected rack item E. Add instrument to rack F. Chain Settings module for 
selected instrument/slot

Instrument Rack contains the following primary modules:

“Rack” on page 179

“Chain Settings” on page 180
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Rack

Each instrument slot contains the following controls:

 Instrument name. Name of the inserted instrument.

Chain Solo. Solo the instrument within the Instrument Rack chain.

Chain Mute. Mute the instrument

Chain Volume. Set the instrument’s output volume level (-Inf dB – 6 dB). To specify if the level is pre- or post-fader (track 
volume), right-click the slider and select Pre Fader or Post Fader.

Pan. Set the instrument’s panorama position in the stereo field (100L – 100R).

A. Instrument name B. Solo C. Mute D. Volume E. Pan F. Add instrument to rack

 

B

F

D

CA

E

179Instruments

Instrument Rack



Chain Settings

The Chain Settings module shows MIDI input filter settings for the selected instrument slot:

MIDI Filters:

Channel. MIDI input channel (All, 1–16).

Velocity Range.  Drag the Low and High handles horizontally to specify the MIDI note velocity range.

Note Range.  Drag the Low and High handles horizontally to specify the MIDI note range.

A. Selected instrument B. MIDI input channel C. Velocity Range D. Note Range E. Expand/collapse chain settings F. Low handle G. High handle
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Inserting an instrument in the rack

To insert an instrument in the rack, click the + button in the Instrument Rack module.

You can add up to 16 instruments in a rack. An instrument slot may contain any AU, VST, BandLab or Cakewalk instrument, 
excluding instances of Instrument Rack and Pad Controller

A. Add instrument to rack

Tip: To replace an instrument in the rack, right-click the instrument name and select Browse Instruments.
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Specifying the MIDI input channel

To specify an instrument slot’s MIDI input channel:

1. Select the instrument slot in the rack.

2. Expand the Chain Settings module.

3. Click the Channel drop-down menu and select the desired MIDI input channel (All, 1–16).

1. Select instrument slot 2. Expand Chain Settings module 3. Select MIDI input channel
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Adjusting the velocity range

Velocity zones allow you to trigger specific instruments depending on the velocity of incoming MIDI notes. For example, trigger a 
fingered bass instrument when playing softly, and trigger a slap bass instrument when playing loudly. This is achieved by assigning 
each instrument in the rack to a unique velocity range.

To set an instrument slot’s note velocity range:

1. Select the instrument slot in the rack.

2. Expand the Chain Settings module.

3. Under Velocity Range, drag the Low handle to set the lowest velocity value.

4. Drag the High handle to set the highest velocity value.

1. Select instrument slot 2. Expand Chain Settings module 3. Drag Low handle 4. Drag High handle

Tip: To shift the current velocity range, hold down the SHIFT key and drag the range control left/right.
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Adjusting the note range

By adjusting the note range for each instrument in the rack, you can layer/blend different instruments that share the same note 
range, or isolate instruments by assigning unique note ranges to each instrument. For example, trigger a bass with the lowest 
octave, trigger a piano with the middle octaves, and trigger strings with the top octave.

To set an instrument slot’s note velocity range:

1. Select the instrument slot in the rack.

2. Expand the Chain Settings module.

3. Under Note Range, drag the Low handle to set the lowest note value.

4. Drag the High handle to set the highest note value.

1. Select instrument slot 2. Expand Chain Settings module 3. Drag Low handle 4. Drag High handle

Tip: To shift the current note range, hold down the SHIFT key and drag the range control left/right.
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Adding effects

You can add effects to individual instrument slots or master effects to the entire Instrument Rack.

To add an effect to only the selected instrument slot, click the small Add Effect  button in the Track Inspector. Slot effects are 
only shown for the selected slot.

To add an effect to the entire Instrument Rack, click the large rightmost Add Effect  button in the Track Inspector. Master rack 
effects are always shown, regardless of which instrument slot is selected.

A. Selected instrument B. Add effects to selected instrument slot C. Add master effects to entire Instrument Rack

See also:

“Effects” on page 193

See:

“Instruments” on page 153

“Instrument Rack” on page 177
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Mixing
Cakewalk Next® lets you mix your projects with tremendous control and flexibility, with support for track folders, buses, sends, VST 
plugins, metering, and automation. Track view and Track Inspector contain all the controls you need to mix your project.

See:

“Adjusting levels” on page 188

“Aux sends” on page 189

“Quick grouping” on page 192

“Effects” on page 193

“Inserting effects” on page 193

“Inserting BandLab effect chains” on page 194

“Opening an effect’s UI” on page 199

“Mapping plugin parameters” on page 200

“Bypassing effects” on page 202

“Replacing effects” on page 202

“Removing effects” on page 202

“VST plugin scanner” on page 203

“Converting MIDI to audio” on page 206

“Bouncing audio” on page 206

“Normalizing audio” on page 207

“Reversing audio” on page 208

“Plugin Management” on page 209

See also:

“Automation” on page 211

“Stem separation” on page 149
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Adjusting levels

Adjusting the monitor level

To adjust the monitor level, drag the Monitor Level knob in the main toolbar.

Adjusting track levels

To adjust a track, bus, or track folder’s playback level, drag its Volume slider.

To reset a slider to its default value, double-click the slider, or hold down the ALT (Windows) / OPTION (Mac) key and click the slider.

To adjust with fine resolution, hold down the SHIFT key and drag a slider.
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Aux sends

Aux sends allow you to process multiple tracks with the same effects, such as reverb. Instead of inserting the same effect on all 
tracks, you can insert a single instance of the effect on a bus, then send multiple tracks to that bus.

A track can contain multiple sends, and each send can be tapped before or after the track’s volume control. Each track’s audio 
passes through the track’s send level on its way to the bus.

Inserting a send

To add a new aux send, click the Add Send button  in the track’s Track Inspector, then select an existing bus or select Create 
New Bus to create a new bus.
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Each send contains the following controls:

Bypass. Bypass the send.

Name. Name of the destination bus.

Send level. Controls volume of audio data sent by the send.

Tap point. Specify the send’s tap point:

 Input . The send signal goes to the bus prior to the track’s effects.

Pre Fader . The send signal goes to the bus prior to the track’s volume fader.

Post Fader . The send signal goes to the bus after the volume fader.

Figure 50. Send controls.

A. Bypass B. Send level C. Send destination D. Tap point (Input, Pre Fader, or Post Fader)

Specifying a send’s tap point

A send can be tapped before or after the track’s volume control. Each track’s audio passes through the track’s send level on its way 
to the bus. To specify the tap point, click the tap point menu and select on of the following:

 Input . The send signal goes to the bus prior to the track’s effects.

Pre Fader . The send signal goes to the bus prior to the track’s volume fader.

Post Fader . The send signal goes to the bus after the volume fader.

B DA C
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Bypassing a send

To bypass/unbypass a send, click its Bypass button .

When bypassed, the send is dimmed.

Deleting a send

To delete a send, click the tap point menu (Input/Pre Fader/Post Fader) and select Delete Send.
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Quick grouping

By default, adjusting a control only affects that specific control. Quick Groups allow you to effortlessly adjust identical controls across 
multiple selected tracks or buses.

The following controls can be adjusted via a Quick Group:

Volume

Pan

Mute

Solo

Record Arm

Track Monitor

Effect module bypass

To use Quick Groups, do one of the following:

To adjust identical controls by a relative amount. Select the tracks you want to adjust, then hold down the CTRL (Windows) 
/ CMD (Mac) key and adjust a control in any selected track. Cakewalk Next® automatically applies the same delta value to all 
other selected tracks. Button states will invert.

To adjust identical controls by an absolute amount. Select the tracks you want to adjust, then hold down CTRL+ALT 
(Windows) / CMD+OPTION (Mac) and adjust a control in any selected track. Cakewalk Next® automatically applies the same 
value to all other selected tracks.

Note: Quick Groups do not work between tracks and buses.
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Effects

You can add audio effects to tracks, track folders, and buses. Effects are processed in real-time, preserving your track’s original 
data.

Inserting effects

You can insert BandLab, VST,VST3, and AudioUnit (Mac only) effects on any track, bus, or track folder.

Adding an effect

To add an effect at the end of the effect chain:

1. Select the target track/bus/track folder.

2. Open the Track Inspector and click the Add Effect button .

3. Make sure Effects is selected.

4. Select the desired effect and click Add.
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Inserting an effect before an existing effect

To insert an effect before an existing effect, position the mouse pointer to the left of the effect module until you see a blue vertical 
line, then click and select the desired effect.

Inserting BandLab effect chains

You can insert a complete BandLab effect chains from a preset. To insert effect chains:

1. Select the target track/bus/track folder.

2. Open the Track Inspector and click the Add Effect button .

3. Select Chains

4. Select the desired BandLab effect chain and click Add.

See also:

“Saving a track template” on page 32
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Copying and pasting effects between tracks

You can copy effects from one track and paste them to another track:

1. In the Track Inspector, select the effect(s) that you want to copy, then go to Edit > Copy or press CTRL+C (Windows) / CMD+C 
(Mac).

2. Select the track that you want to paste the effects into, then go to Edit > Paste Plugins or press CTRL+V (Windows) / CMD+V 
(Mac).

You can also drag and drop effects between tracks:

1. In the Track Inspector, select the effect(s) that you want to copy.

2. Hold down the CTRL (Windows) / OPTION (Mac) key, then drag the selected effect(s) to the desired track strip header. The 
mouse cursor indicates how many effects are copied.

 

195Mixing

Effects



Filtering the plugin list

You can filter the plugin list in various ways to quickly find a specific plugin.

Filtering by name
To filter the effect/instrument/template list by items that match a specific name, type a name in the Search box.

To clear the search filter, click the Clear Search Terms button .

Filtering by tags

Tags make it easy to filter the list of audio effects, instrument, and templates based on categories.

To filter the list by tags, click one or more tags.

For more details, see “Tags” on page 92.
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Filtering by manufacturer

To filter the effect/instrument/preset list by manufacturer, select the desired manufacturer.

Filtering by plugin type

To filter by plugin type, click the Show/Hide Filter Formats button , then elect the plugin type(s) that you want to see (AudioUnit 

(Mac only), BandLab, VST, VST3) .
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Filtering by favorites

To tag an effect/instrument/preset as a favorite, click its star icon:

To only show favorite effects, instruments, or templates, click the Show only favorites button  in the Tags panel.

See:

“Tags” on page 92

“Filtering by tags” on page 196
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Opening an effect’s UI

Expanding/collapsing an effect module

To show a plugin’s small plugin module in the Track Inspector, hover over the plugin name and click the effect’s expand/collapse 

button  or double-click the plugin name:

Figure 51. Effect module.

A. Bypass B. Effect parameters C. Show Plugin Editor D. Input meter E. Effect name F. Add Parameters G. Expand/collapse

Note: If an effect module contains many parameters, you may need to resize the Track Inspector to make it taller or scroll the 
module vertically in order to see all parameters. You can use the mouse wheel to scroll, but be aware that parameter values will 
change if the mouse pointer is over a slider when you use the mouse wheel.

 

Plugin module collapsed: Plugin module expanded:
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Opening a plugin’s editor

To show a plugin’s native UI, click the Show plugin editor button  above the plugin name in the Track Inspector.

Mapping plugin parameters

The right side of the Track Inspector shows effect plugin modules. Click the effect’s expand/collapse button  to show the effect’s 
mapped automatable parameters.

Figure 52. Effect module.

A. Mapped parameters B. Parameter menu (add, reset, delete parameters)
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To map additional parameters from the plugin’s editor. Click the Parameters button  and select Learn Parameters. The 
plugins UI opens and prompts you to move any parameters that you want to map to the plugin module. The controls you touch in 
the plugin’s UI are added to the plugin module, and also become available in the parent track’s Automation menu. The effect 
module pulses with a green outline while in mapping mode.

To map additional parameters from a parameter list. Click the Parameters button  and select Add Parameter, then 
select the desired parameter(s).

To reset the parameters to the default list. Click the Parameters button  and select Reset Parameters.

To remove a mapped parameter. Right-click the parameter in the effect module and select Remove Parameter.

To remove all mapped parameters. Click the Parameters button  and select Delete All Parameters.

To replace a mapped parameter with another parameter. Right-click the parameter in the effect module and select Replace 
Parameter from Plugin Editor or Replace Parameter from Parameter List.
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Bypassing effects

To bypass an effect, click the effect’s Bypass button  in the Track Inspector. When an effect is bypass, its module is dimmed.

To bypass multiple effects simultaneously, select the effect modules that you want to bypass, then hold down the CTRL (Windows / 
CMD (Mac) key and click a selected effect’s Bypass button.

Replacing effects

To replace an effect with another effect:

1. In the Track Inspector, right-click the name of the effect you want to replace and select Replace. 

2. Select the new effect.

3. Click Add.

Removing effects

To remove an effect, select the effect in the Track Inspector, then press the DELETE key, or right-click the effect name and select 
Delete.

See also:

“Opening a project in Safe Mode” on page 22
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Reordering effects

To reorder effects in the Track Inspector, select the effect(s) you want to move, then drag the selected effect(s) to the desired 
location. A vertical line indicates a valid drop location.

A. Drop location B. Selected effects

VST plugin scanner

When you install or update VST plugins, Next needs to scan your VST folder(s) to detect any changes. To automatically scan your 
VST folder when Next starts, go to Edit > Preferences > Plugins and enable Scan for Plugins on Startup.

To manually perform a scan, click Scan Now.

To add a new VST plugin folder to be scanned, click the folder button  under Custom VST Plugin Locations and navigate to the 
desired folder.

To remove a folder from the scan list, click the delete button  next to the displayed folder path.

See:

“Plugins settings” on page 251

See also:

“Automating effects” on page 218

“Aux sends” on page 189

“[Mac only] Using Intel x86 plugins on an Apple Silicon Mac (M1/M2)” on page 204

Note: If a plugin crashes during scanning or takes a long time to scan, it becomes quarantined and will be skipped by future 
scans. To manually rescan quarantined plugins, go to Edit > Preferences > Plugins, then click Plugin Scan Mode and select 
Scan Quarantine Plugins, then finally click Start Plugin Scan. To see a list of all quarantined plugins, click Open under Open 
Plugin Quarantine Manager. For details, see “Plugin Management” on page 209.
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[Mac only] Using Intel x86 plugins on an Apple Silicon Mac (M1/M2)

In order to use Intel x86 architecture plugins on an M-series Mac, you must run Next using Rosetta mode.

Rosetta is a translation layer that emulates the Intel x86 architecture on a Silicon platform, which allows a Mac with Apple silicon 
(M1/M2) to use plugins built for Macs with an Intel processor.

Rosetta is not needed if all of your plugins are already updated to support Apple Silicon.

Installing Rosetta

Rosetta 2 is available only for Mac computers with Apple silicon, but does not come pre-installed. The system will prompt you to 
install Rosetta the first time you open an app that needs Rosetta. Click Install, then enter your user name and password to allow 
installation to proceed.

To install Rosetta manually:

1. From the Finder menu bar, select Go > Go to Folder.

2. Type /System/Library/CoreServices/Rosetta2 Updater. app, then click Go.

3. Double-click Rosetta 2 Updater, then follow the prompts to install Rosetta.

Running Cakewalk Next in Rosetta mode

To switch Next to Rosetta mode:

1. Exit Next if it is running.

2. Open the Finder and find the Cakewalk Next® app in your Applications folder.

3. Right-click the Cakewalk Next® app icon and select Get Info.

4. In the Info window, select Open using Rosetta.

5. Close the Info window.

6. Restart Next and rescan for all plugins.

Note: When using Rosetta mode, Next uses a different plugin catalog named PluginCatalog_x86_64.xml to ensure that 
native Apple Universal/Silicon arm64 plugins are not mixed in the same catalog. The normal native catalog is named 
PluginCatalog.xml.
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Cakewalk Next® will open in Rosetta mode at next launch, and show a confirmation notification.

You can always confirm the current app mode from the Next’s About box:
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Converting MIDI to audio

Instrument tracks contain MIDI clips. If you want to edit the data as audio (or simply reclaim CPU processing power used by the 
instrument), you can convert Instrument tracks to audio tracks. To do so, select the Instrument track(s) and go to Edit > Bounce 
Tracks in Place. Any effects will be applied and removed from the new audio track.

Bouncing audio

Individual clips in the same track can be combined into a single clip by bouncing the clips. You can bounce entire tracks or a time 
range.

Bouncing tracks can also be useful if you require more CPU time for your real-time effects. You can premix some of your tracks with 
real-time effects applied, saving CPU time during playback.

Bouncing tracks in place

To bounce entire tracks, select the track(s) that you want to bounce, then select Edit > Bounce Tracks in Place.

The clips are combined into a single clip. Empty space between clips is filled with silence in the new clip.

Any automation and effects are applied to the bounced audio, then removed from the track(s).

Bouncing tracks to new individual tracks

To bounce entire tracks to new individual tracks, select the track(s) that you want to bounce, then select Edit > Bounce to New 
Tracks.

Any automation and effects are applied to the bounced audio, then removed from the track(s).

Bounce to New Tracks respect time selections and only bounce those regions to new tracks.

Bouncing an Instrument (MIDI) track renders the audio and creates a new audio track.

Bouncing a track folder will mixdown all tracks within the group, creating a new bounced track outside the track folder.

Bouncing a bus creates a mixed track of everything that routes through the bus, including bus effects and automation.

Bounced tracks are automatically given the (Bounced) suffix.

Bouncing clips

To bounce a time range, make a time selection that spans one or more tracks, then right-click and select Bounce to New Clip.

The clips are combined into a single clip. Empty space between clips is filled with silence in the new clip.

Note: When bouncing an Instrument (MIDI) track, the Instrument track is converted to an audio track.

Note: Like any clips, trimmed clips can be combined with other clips using the Bounce to New Clip command. When a trimmed 
clip is combined with another clip, any trimmed data (audio clips or MIDI events that are cropped from view) is overwritten.
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Normalizing audio

To normalize audio is to change its overall volume by a fixed amount in order to reach a target perceived amplitude or volume level 
while preserving the dynamic range.

Why Normalize?

Normalizing audio is not always necessary, so you should decide on a track-by-track basis whether or not the process is required.

There are two primary reasons to normalize audio:

 Increase levels. If you have a very quiet audio file, you may want to make it as loud as possible without changing its dynamic 
range. If a track was recorded too low (and re-recording the track at a more appropriate level is not an option) and you can’t use 
the volume fader to make the track loud enough in the mix, normalizing can salvage an otherwise unusable take.

Match levels. Create consistent levels across multiple tracks, or multiple clips on the same track, before or during mixing.

You can also apply normalization when exporting audio (see “Exporting audio” on page 242). This is especially useful when 
distributing your music to various streaming platforms that apply loudness normalization, such as Apple Music, Spotify, Amazon 
Music, SoundCloud, Tidal, YouTube, etc.

There are a few things to be aware of before normalizing audio:

Normalizing raises the signal level, but also raises the noise floor.

Louder tracks leave less headroom before clipping occurs when processed with EQ and effects.

The sum of all audio signals played together cannot exceed the waveform amplitude limit. Even though no individual clip is 
clipped, the combination may cause distortion.

Audio normalization is a destructive process. Normalizing is not recommended for simply making waveforms bigger since it 
permanently alters audio files.

Types of normalization

There are different ways of measuring the volume of audio. The results will vary depending on which method you use. Cakewalk 
Next® provides two types of audio normalization:

Peak normalization. Peak normalization detects the maximum (peak) level in the selected track or clip, then raises or lowers 
the entire signal by the same fixed amount to reach the specified target level, without affecting the dynamic range. Peak 
normalization does not account for the apparent loudness of the content, and tends to work well on shorter clips and single-shot 
samples such as drum hits.

RMS (Root Mean Square) normalization. RMS normalization measures the average level of all peaks in the selected audio, 
then brings the average loudness to the specified target level. RMS normalization tends to works best on long audio files that 
have varying peaks.

A. Peak B. RMS C. Target Level D. Normalize

Peak. Normalize to the highest peak.

RMS. Normalize to the average loudness level.
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Target Level. Specify the normalization target level. Double-click to type a custom value. It is generally not a good idea to 
normalize to 0 dBFS peak in a multi-track recording. It’s good practice to reserve at least 3–6 dB of headroom to allow for further 
audio processing that may increase the level.

Normalize. Apply normalization.

Normalizing clips

To normalize clips:

1. Select individual clips or make a time selection that spans one or more tracks.

2. Right-click and select Process > Normalize or press CTRL+SHIFT+N (Windows / CMD+SHIFT+N (Mac) to open the Normalize 
Audio dialog box.

3. Specify the normalization method (Peak or RMS) and target level (double-click to type a custom value).

4. Click Normalize.

When normalizing a time range, selected clips on the same track are combined into a single clip. Empty space between clips is filled 
with silence in the new clip.

When normalizing multiple fully selected clips, the individual clips are retained.

It’s always a good idea to listen to the processed audio. You can use the Edit > Undo command if you don’t like the results, and then 
try a different setting in the Normalize dialog box.

Normalizing tracks

To normalize an entire track(s):

1. Select the track(s) that you want to normalize.

2. Select Edit > Normalize Audio Tracks or press CTRL+ALT+N (Windows / CMD+OPTION+N (Mac) to open the Normalize 
Audio dialog box.

3. Specify the normalization method (Peak or RMS) and target level (double-click to type a custom value).

4. Click Normalize.

The clips are combined into a single clip for each track. Empty space between clips is filled with silence in the new clip.

Reversing audio

By reversing audio data, you can make it play backwards. You may want to do this to obtain unusual sounds for special effects.

To reverse audio, select a clip or time range that contains audio, then right-click and select Process > Reverse.

Note: If the selection contains any loud signals, Normalize Audio may not seem to have any effect. This is because the volume 
increase is determined by the loudest audio in the selection. If an audio clip contains segments that are too quiet and others that 
are loud, you should probably split off the quiet segments into separate clips and then normalize those.

Note: When you reverse a time range, the selection is bounce to a new clip and the sample order is reversed within the bounds 
of the selection.

When you reverse multiple fully selected clips, the individual clips are retained and the samples inside each clip are reversed.
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Plugin Management

Plugin Manager

The Plugin Manager lets you manage audio effects, instrument, and templates.

To open the Plugin Manager, go to Edit > Preferences > Plugins and click Open under Open Plugin Manager.

For each plugin, you can specify the following:

Favorites . To tag a plugin as a favorite, click the Toggle Plugin Favorite Status  button. For details, see “Filtering by 
favorites” on page 198.

Visibility in Browser . To show/hide the plugin in the Plugin Browser, click the Toggle Plugin Visibility in Browser  
button.

DPI Awareness  (Windows only). Cakewalk Next® supports per-plugin DPI awareness in Windows 10 and above, which 
ensures that DPI-aware plugins will render correctly whenever the DPI changes. Non-DPI Aware plugins may become blurry 
whenever the DPI changes to a scale factor greater than 100% (96 DPI). To enable/disable DPI awareness, click the Toggle 

Plugin DPI Awareness  button.

Tags. To assign tags, right-click the plugin. For details, see “Filtering by tags” on page 196 and “Assigning tags to audio effects 
and instruments” on page 93.

To show the Plugin Manager, go to Edit > Preferences > Plugins and click Open under Open Plugin Manager.

Figure 53. Plugin Manager.

A. Show audio effects B. Show instruments C. Show Effect Chains D. Toggle plugin favorite status E. Toggle plugin visibility in Browser F. Toggle 
plugin DPI awareness
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Plugin Quarantine Manager

If a plugin crashes during scanning or takes a long time to scan, it becomes quarantined and will be skipped by future scans. 

The Plugin Quarantine Manager lets you rescan quarantined plugins.

To open the Plugin Quarantine Manager, go to Edit > Preferences > Plugins and click Open under Open Plugin Quarantine 
Manager.

Figure 54. Plugin Quarantine Manager.

A. Quarantined plugins B. Rescan plugin C. Rescan selected plugins D. Rescan all plugins

To rescan a single quarantined plugin, click its Rescan button.

To rescan the selected quarantined plugins, click Rescan Selected.

To rescan all quarantined plugins, click Rescan All.

See also:

“VST plugin scanner” on page 203
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Automation
Automation means to record the movement of a fader, knob, or other control so that the next time you play your project, that control 
moves automatically. This allows you to dynamically change parameters over the course of a project’s timeline.

The following parameters can be automated:

Track/bus/track folder Volume, Pan, and Mute

Effect/plugin parameters

MIDI controllers

You can record fader moves and parameter changes with a mouse in real time, or edit automation envelopes graphically.

Below are some examples of when you may want to use automation:

 If you want a track to slowly fade in or out, automate the tracks Volume control.

 If a particular plugin is only required during a specific section in a song, automate the plugin’s Bypass parameter during the parts 
of the track where the plugin is not required.

 If you want a certain sound to pan across speakers at given points during a song, “record” the panning movements.

See:

“Creating and editing automation envelopes” on page 213

“Showing/hiding automation lanes” on page 213

“Adding a new automation lane” on page 214

“Hiding an automation lane” on page 214

“Deleting an automation lane” on page 214

“Reassigning an automation lane to a different parameter” on page 214

“Copying/pasting automation between lanes” on page 215

“Drawing automation” on page 215

Note: Track and effect automation is track based, and is performed in the Track view. MIDI automation is clip based, and is 
performed in the Clip Editor’s Piano Roll editor.
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“Recording automation” on page 216

“Bypassing automation” on page 217

“Resetting an automation envelope” on page 217

“Deleting automation” on page 217

“Automating effects” on page 218

“MIDI clip automation” on page 219
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Creating and editing automation envelopes

Automation envelopes are shown in separate automation lanes below the track strip.

A. Show/Hide Automation Lanes B. Automation options C. Bypass automation D. Add Automation Lane E. Automation parameter F. Parameter 
value G. Hide Automation Lane H. Automation envelope

Showing/hiding automation lanes

To show/hide automation lanes on all tracks, click the Show/Hide Automation Lanes button .

By default, each track strip shows a single automation lane at a time. To show multiple automation parameters simultaneously, add 
additional automation lanes (see “Adding a new automation lane” on page 214). Each lane can be assigned to any automatable 
parameter (see “Reassigning an automation lane to a different parameter” on page 214).

In the following examples, the Volume and Pan parameters are shown in separate automation lanes:

Automation envelopes are color coded as follows:

Volume = Blue

Pan = Yellow

Mute = Orange

Effect/plugin parameters = Purple

A B

C

D

E F G

H
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Adding a new automation lane

To create a new automation lane, click the Add Automation Lane button  below the last lane, then select the desired parameter.

Colored text in the automation menu indicates that automation exists for that parameter, even if the lane is not visible.

Showing only active automation lanes

To only show automation lanes on tracks that already contain automation, click the Show/Hide Automation Lanes button  

drop-down menu  and select Show lanes with active automation.

Hiding an automation lane

To hide a single automation lane without deleting its envelope, click the lane’s Hide Automation Lane button .

To reshow a hidden lane, do one of the following:

Add a new automation lane and select the hidden parameter (see “Adding a new automation lane” on page 214). All existing 
envelopes appear color coed in the automation menu.

Reassign an existing automation lane to the hidden parameter (see “Reassigning an automation lane to a different parameter” on 
page 214).

Deleting an automation lane

To delete an automation lane and its envelope, click the lane’s menu and select Delete Lane and Automation.

See also:

“Deleting automation” on page 217

Reassigning an automation lane to a different parameter

To reassign an existing automation lane to a different parameter, click the lane’s Automation menu and select the desired parameter. 
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Copying/pasting automation between lanes

You can copy automation data in a lane and paste into any lane:

1. In the Track view, make a time selection in an automation lane to select the automation data that you want to copy.

2. Go to Edit > Copy or press CTRL+C (Windows) / CMD+C (Mac) to copy the automation data to the clipboard.

3. Click in any automation lane where you want to paste the clipboard content.

4. Go to Edit > Paste Automations or press CTRL+V (Windows) / CMD+V (Mac) to paste the automation data.

See also:

“Adding a new automation lane” on page 214

“MIDI clip automation” on page 219

Drawing automation

To modify the shape of an automation envelope. Click anywhere on the envelope to create a new node, then drag the node 
to create a ramp. To adjust a node with finer control, hold down the SHIFT key while dragging the node up/down.

To create a slow or fast curve. Right-click an envelope line and select Slow Curve or Fast Curve.

To adjust the slope of an automation curve. Hold down the CTRL (Windows) / CMD (Mac) key and drag the slope up/down.

To convert a slope to a line. Right-click the slope and select one of the following options:

Linear. Resets the curve so it’s a straight line (Tip: you can also hold down the CTRL (Windows) / CMD (Mac) key and 
double-click the curve).

Flatten Left. Sets the right hand node value to the value of the left hand node, making it a horizontal shelf.

Flatten Right. Sets the left hand node value to the value of the right hand node, making it a horizontal shelf.

To create a shelf. Make a time selection (see “Making a time selection” on page 127), then hold down the CTRL (Windows) / 
CMD (Mac) key and drag the selected envelope range up/down.

Note: The previously assigned automation envelope is not deleted from the track; it is simply not shown in an automation lane. 
Existing envelopes are color coded in the automation menu. You can show hidden envelopes at any time by adding a new 
automation lane or reassigning an existing automation lane.
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Recording automation

To record automation:

1. Do one of the following:

To arm a single control for recording, double-click the control. The controls show a small red circle when armed.

To arm all controls for recording, click the Show/Hide Automation Lanes button  drop-down menu  and select 

Capture automation changes during playback/record. A red circle  indicates that automation recording is enabled, 
and all automatable controls show a small red circle.

2. Do one of the following:

 If you want to record automation in real-time, start playback.

 If you want to adjust automation at only a specific location on the timeline, position the playhead at the desired location.

3. Adjust the desired automatable fader/knob/button.

4. When you are finished with recording automation, stop playback, then click the Show/Hide Automation button  drop-down 

menu  again and disable Capture automation changes during playback/record.

 

 

Automation recording disabled: Automation recording enabled:
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Bypassing automation

To bypass/unbypass an automation lane/envelope, do one of the following:

Click the automation lane’s Bypass button .

Click the automation lane’s drop-down menu and select Bypass.

Right-click the envelope and select Bypass Automation.

When an automation envelope is bypassed, the parameter name appears in brackets and the envelope is dimmed.

Resetting an automation envelope

To reset an automation envelope (delete all nodes), do one of the following:

Click the Automation menu and select Reset Automation.

Right-click the automation envelope and select Reset Automation.

Deleting automation
To delete an automation lane and its automation envelope, click the Automation menu and select Delete Lane and Automation.

To delete a single automation envelope node, right-click the node and select Delete Node.

To delete multiple automation envelope nodes, make a time selection that spans the nodes that you want to delete, then right-click 
the automation envelope and select Delete Nodes, or press DELETE.

See also:

“Deleting an automation lane” on page 214
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Automating effects

Automating effect parameters is similar to automating track parameters (see “Creating and editing automation envelopes” on page 
213 and “Recording effect automation” on page 218).

Recording effect automation

Effect parameters are armed for automation recording the same way you arm track parameters (see “Recording automation” on 
page 216. Once armed, you can adjust an effect’s parameter from any of the following locations:

The parent track’s automation control or automation lanes

The Track Inspector’s plugin module

The plugin’s editor

Figure 55. Plugin parameter is armed for automation recording.
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MIDI clip automation

You can draw MIDI controller events in the Clip Inspector’s Piano Roll editor.

To show/hide MIDI automation, click the Edit Clip Automation button .

To select the MIDI controller you want to edit, click the Automation menu and select the desired controller. If automation exists for a 
parameter, the parameter name is highlighted in the menu.

MIDI automation envelopes can be edited the same way as track automation envelopes. For details, see “Drawing automation” on 
page 215.

Note: MIDI automation is clip based. If the selected instrument track is empty, double-click in the Clips pane to create a new 
empty MIDI clip that can contain the MIDI automation.
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Lyrics
The Lyrics track allows you to create lyrics that are perfectly in sync with the music. Large scrolling lyrics can be shown in the Lyric 
Inspector’s teleprompter.

You can edit lyrics directly in the Lyrics track timeline, or in the dedicated Lyrics Inspector editor.

The Lyrics features consist of the following elements:

Lyrics track. The Lyrics track shows all lyric lines on a horizontal timeline above regular tracks. You can freely edit lyric lines 
directly in the Lyrics track. For details, see “Lyrics track” on page 223.

Lyrics Inspector. The Lyrics Inspector can toggle between showing the Lyrics Editor (and Lyrics Scratch Pad) and Lyrics 
Prompter. For details, see “Lyrics Inspector” on page 225.

Lyrics Editor. Use the Lyrics Editor to edit lyrics text and color, or rearrange lyric lines in a vertical list. For details, see 
“Lyrics Editor” on page 226.

• Lyrics Scratch Pad. Use the Lyrics Scratch Pad to type lyric ideas and notes that are not visible in the Lyrics track. You 
can quickly apply selected text in the Lyrics Scratch Pad to existing or new lyric lines in the Lyrics tracks. For details, see 
“Lyrics Scratch Pad” on page 228.

Lyrics Prompter. See large scrolling lyrics synchronized with the music during playback. Use as a guide during vocal 
recording. For details, see “Lyrics Prompter” on page 229.

A. Lyrics track B. Lyrics Inspector C. Lyric lines
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Basic workflows

There are two basic workflows for authoring lyrics:

Line-by-line authoring. Type one lyric line at a time.

Sync existing text. Select a single or multiple existing text lines in the Lyrics Scratch Pad, then automatically create new lyric 
lines or apply the selected text to existing lyric lines.

For details, see “Time-syncing lyrics” on page 234.

See:

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229
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Lyrics track

The Lyrics track allows you to create multiple lyric lines and easily edit the time range of each lyric line.

Showing/hiding the Lyrics track

To show or hide the Lyrics track, do one of the following:

Click the Track View Options button  and select Lyrics under Project Tracks.

Select View > Show Lyrics Track

Press ALT+L (Windows) / OPTION+L (Mac)

The Lyrics track is shown directly under the Arranger track (if visible), above regular tracks.

To resize the Lyrics track, drag the splitter bar between the Lyrics pane and the Track pane to change its height.

Figure 56. Drag the splitter bar vertically to resize the Lyrics track.

The Lyrics track is empty until you define one or more lyric lines (see “Adding lyrics” on page 230).

Lyrics track timeline

The Lyrics track timeline shows all defined lyric lines.

You can edit lyric lines directly in the timeline, including resize, move, split, merge, duplicate, copy/paste, and delete. Drag to create 
and rearrange lyric lines, then freely move them along the timeline. For details, see “Editing lyrics” on page 231.

Any changes in the Lyrics track timeline are immediately reflected in the Lyrics Inspector, and vice versa.
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Lyrics track time base

The time base format for the Lyrics track can be set to either Musical or Absolute. The time base format determines what happens 
to lyric lines when you change the project tempo.

To specify the time base format, right-click the Lyrics track header, then select one of the following:

Musical.  A lyric line’s M:B:T position stays constant, and its absolute position shifts.

Absolute.  A lyric line’s absolute position stays constant, and its M:B:T position shifts. The Lyrics track tooltip shows time as 
H:M:S:F and samples.

See:

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221
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Lyrics Inspector

The Lyrics Inspector consists of the Lyrics Editor (see “Lyrics Editor” on page 226), Lyrics Scratch Pad (see “Lyrics Scratch Pad” on 
page 228), and Lyrics Prompter (see “Lyrics Prompter” on page 229).

Showing/hiding the Lyrics Inspector

To show/hide the Lyrics Inspector, do one of the following:

Select View > Show Lyrics Inspector

Double-click a lyric line in the Lyrics track timeline

Press F7

A. Lyrics Inspector B. Lyrics Editor C. Lyrics Scratch Pad D. Toggle Prompter Mode

To toggle between the Lyrics Editor and Lyrics Prompter, click the Toggle Prompter Mode button .

See:

“Lyrics track” on page 223

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221
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Lyrics Editor

The Lyrics Editor functions much like a standard text editor, and allows you to change text, add, duplicate, rearrange, delete, and 
change the color of lyric lines.

Changes you make in the Lyrics Editor are reflected in the Lyrics track, and vice versa. The Lyrics Editor facilitates quick editing 
without having to drag or zoom horizontally within the Clips pane.

Showing/hiding the Lyrics Editor

To show/hide the Lyrics Editor, select View > Show Lyrics Inspector and make sure the Toggle Prompter Mode button  is not 
selected.

Each lyric line is shown on a separate line, and displays the lyric line’s color, text, start time, and end time.

A. Selected lyric lines B. Focused lyric line C. Color D. Lyric text E. Start time F. End time

The Lyrics Editor also features a teleprompter mode, in which enlarged lyric text scrolls and highlights in sync with the position of the 

Now Time. To toggle between the Lyrics Editor and Lyrics Prompter, click the Toggle Prompter Mode button  or press ALT+F7 
(Windows) / OPTION+F7 (Mac). For details, see “Lyrics Prompter” on page 229.

A. Lyrics track B. Lyrics Inspector C. Lyrics Editor D. Lyrics Scratch Pad
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Add a New Lyric Line button

The Add a New Lyric Line button  inserts a new lyric line.

The new lyric line duration is inherited from the last clicked lyric line

During playback, a new empty lyric line is inserted at the Now time, without opening a text editor. The Snap to Grid setting is 
obeyed.

When idle, the new lyric line is added at the end and presents a text editor.

Lyrics Editor keyboard shortcuts

The following keyboard shortcuts can be used to navigate and edit lyric lines in the Lyrics Editor:

See also:

“Adding lyrics” on page 230

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221

Command Windows Mac

Edit the focused lyric line
(press ENTER (Windows) / (RETUNR (Mac) to save changes or ESC to cancel)

CTRL+ENTER CMD+RETURN

While editing text, insert a new line at the caret position SHIFT+ENTER SHIFT+RETURN

Insert new lyric line immediately after the focused lyric line
If no lyric line is focused, insert at the end
If there are no existing lyric lines, insert at the Now time

ENTER RETURN

Insert a new lyric line immediately before the focused lyric line, shifting 
subsequent lyric lines to make room
If no lyric line is focused, insert at the end
If there are no existing lyric lines, insert at the Now time

INSERT INSERT or Fn+RETURN

Moves focus down one lyric line DOWN or TAB DOWN or TAB

Moves focus up one lyric line UP or SHIFT+TAB UP or SHIFT+TAB

Delete the focused or selected lyric lines DELETE DELETE

Table 4. Lyrics Editor keyboard shortcuts 
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Lyrics Scratch Pad

The Lyrics Scratch Pad is a free form text editor that allows you to store lyric ideas and other notes/reminders without cluttering the 
actual Lyrics track. Text in the Lyrics Scratch Pad does not appear in the Lyrics track timeline or Lyrics Prompter, but you can easily 
copy text from the Lyrics Scratch Pad into the Lyrics track. For details, see “Add Selection as Lyric Lines button” on page 228 and 
“Line-by-line authoring in the Lyrics Inspector” on page 238.

Showing/hiding the Lyrics Scratch Pad
To show/hide the Lyrics Scratch Pad, select View > Show Lyrics Inspector.

The Lyrics Scratch Pad appears in a re-sizable pane to the right of the Lyrics Editor.

Resizing the Lyrics Scratch Pad

To resize the Lyrics Scratch Pad, drag the vertical splitter bar.

Add Selection as Lyric Lines button

The Add Selection as Lyric Lines button  allows you to copy selected text in the Lyrics Scratch Pad into selected lyric lines.

 If any lyric lines are selected, the selected Lyrics Scratch Pad text will copy into the selected lyric lines and replace any existing 
text.

 If no lyric lines are selected, the selected Lyrics Scratch Pad text will copy as new lyric lines.

 If there are more Lyrics Scratch Pad lines selected than lyric lines, the text is distributed evenly across selected lyric lines and any 
overflow text is copied as multiple lines in the last selected lyric line.

 If more lyric lines than Lyrics Scratch Pad lines are selected, no text is copied.

Context menu

The Lyrics Scratch Pad contains the following context menu commands:

Add Selection as Lyric Lines. Copy selected Lyrics Scratch Pad text as new lyric lines at the end.

 Insert Selection Into Selected Lyric Lines. Copy selected Lyrics Scratch Pad text into selected lyric lines. Same as the Add 

Selection as Lyric Lines button .

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Prompter” on page 229

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221
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Lyrics Prompter

The Lyrics Prompter functions like a karaoke line-by-line teleprompter, in which enlarged lyric text scrolls and highlights in sync with 
the position of the Now Time during playback.

Showing/hiding the Lyrics Prompter
To show/hide the Lyrics Prompter, first open the Lyrics Inspector (see “Showing/hiding the Lyrics Inspector” on page 225), then do 
one of the following:

Click the Toggle Prompter Mode button 

Select View > Show Lyrics Prompter

Press ALT+F7 (Windows) / OPTION+F7 (Mac)

A. Toggle Prompter Mode B. Lyric Prompter C. Lyric Size

Adjusting the text size

To adjust the text size in the Lyrics Prompter, drag the Lyric Size slider.

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221

Note: The Lyrics Prompter shows only the lyrics that have been added to the project, not text that lives in the Lyrics Scratch Pad.

 

A

B

C
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Adding lyrics

Lyric lines can be added in the Lyrics track timeline or the Lyrics Inspector.

Lyric lines
A lyric line can be a single word, a sentence, or even an entire paragraph. It’s up to you to decide how granular you want the lyrics to 
be highlighted in the Lyrics Prompter during playback. A single lyric line can also contain multiple lines of text.

In general, a lyric line typically contain a complete sentence/phrase, which makes it easy to arrange and edit lyrics.

Each lyric line contains the following properties:

Text (if a lyric line contains no text, it is considered an “interlude” event and shows as music notes)

Color

Start time

End time

Adding a lyric line

To add a new lyric line, do one of the following:

Double-click or drag in the Lyrics track timeline.

 In the Lyrics track header, click the Add a New Lyric Line button .

 In the Lyrics Inspector’s editor, click the Add a New Lyric Line button  or double-click an empty area.

Select text in the Lyrics Scratch Pad, then right-click and select Add Selection as Lyric Lines.

To insert a new lyric line between two existing lyric lines, select an existing lyric line in the Lyrics Editor, then press ENTER 
(Windows) / RETURN (Mac) to insert a new lyric line after the selected lyric line. Any subsequent lyric lines are shifted to make 
room for the new lyric line.

See also:

“Changing lyric text” on page 231

Adding an interlude (no lyrics) event

By default, a new lyric line contain no text and is considered an “interlude” event, as indicated by its music notes.

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Editing lyrics” on page 231

“Time-syncing lyrics” on page 234

“Lyrics” on page 221
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Editing lyrics

Lyric lines can be edited in the Lyrics track timeline or in the Lyrics Inspector.

See also:

“Lyrics Editor keyboard shortcuts” on page 227

Changing lyric text

To change existing lyric text:

1. Do one of the following:

Right-click the lyric line and select Change Lyric Text.

Double-click the lyric line in the Lyrics Inspector.

Select the lyric line and press F2.

2. Type or paste text into the text cell, then press ENTER (Windows) / RETURN (Mac).

Selecting a lyric line

To select a single lyric line, click the lyric line in the Lyrics track timeline or Lyrics Inspector editor.

Selecting multiple lyric lines

To select discontiguous lyric lines, hold down the CTRL key and click the lyric lines you want to select/deselect.

To select all lyric lines, right-click any blank area in the Lyrics track and select Select All.

To select a range of lyric line, do one of the following:

Drag with the right mouse button to lasso select in the Lyrics track timeline.

Click the first lyric line, then hold down the SHIFT key and click the last lyric line.

Drag in the time ruler to make a selection.

Changing the lyric line color

To change a lyric line’s color, right-click the lyric line and point to Section Color, then select a color.

Deleting a lyric line

To delete a lyric line, do one of the following:

Right-click the lyric line and select Delete.

Click the lyric line, then press the DELETE key.

Copying/duplicating a lyric line
To copy/duplicate a lyric line, do one of the following:

Hold down the CTRL (Windows) / OPTION (Mac) key and drag the lyric line.

Right-click the lyric line and select Duplicate.

Select the lyric line and press CTRL+D (Windows) / CMD+D (Mac).

Splitting a lyric line

To split a lyric line, position the Now Time at the location where you want to split the lyric line, then right-click the lyric line and select 
Split at Now Time.

Tip: You can select multiple lyric lines to change their color simultaneously. To select discontiguous lyric lines, hold down the CTRL 
key and click the lyric lines you want to select/deselect. To select a range of lyric lines, click the first lyric line, then hold down the SHIFT 
key and click the last lyric line (see “Selecting multiple lyric lines” on page 231). 
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Merging multiple lyric lines

To merge multiple lyric line, select two or more contiguous lyric lines that you want to merge (or drag in the time ruler to make a time 
selection), then right-click a selected lyric line and select Merge.

Moving a lyric line

To move a lyric line, drag the lyric line to the desired location. 

Resizing a lyric line

To resize a lyric line, drag its left or right edge.

Abutting lyric lines will move over if extending the lyric line duration.

To overwrite abutting lyric lines, hold down the ALT (Windows) / CTRL (Mac) key while resizing a lyric line.

To move downstream lyric lines, hold down the SHIFT key while resizing a lyric line.

Adding a blank space between lyric lines

For improved legibility in the Lyrics Prompter, you may want to add a blank line to separate different song sections (verse, chorus, 
etc.). There are two ways to separate lyric lines with a blank line:

Make sure there is empty space/gap between two adjacent lyric lines in the Lyric track timeline. Simply resize one or more 
adjacent lyric lines to create a gap.

Create a multi-line lyric line, and add a blank line at the top or bottom. To create multiple lines, press SHIFT+ENTER (Windows) / 
SHIFT+RETURN (Mac) while editing the text.

Swapping two lyric lines

To swap two lyric line, drag a lyric line onto the middle of another lyric line.

Moving a lyric line after another lyric line

To move a lyric line after another lyric line, drag the lyric line onto the end of another lyric line.

To copy instead of move, hold down the CTRL (Windows) / OPTION (Mac) key.

Moving a lyric line before another lyric line

To move a lyric line before another lyric line, drag the lyric line onto the beginning of another lyric line.

To copy instead of move, hold down the CTRL (Windows) / OPTION (Mac) key.

Overwriting an existing lyric line

To overwrite an existing lyric line, hold down the ALT (Windows) / CTRL (Mac) key and drag a lyric line onto another lyric line.

Note: You can use standard CTRL and SHIFT modifiers to select multiple lyric lines.

Note: Empty space between lyric lines results in a paragraph break in the Lyrics Prompter.

Tip: Use the vocal track audio waveform as a guide when dragging the start and end of lyric lines to the proper positions.
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Replacing an existing lyric line

To replace an existing lyric line, hold down ALT+SHIFT (Windows) / CTRL+SHIFT (Mac) and drag a lyric line onto another lyric line.

Moving a lyric line to the middle of another lyric line (and split target lyric line)

To move a lyric line to the middle of another lyric line (and split target lyric line), hold down the SHIFT key and drag a lyric line onto 
the middle of another lyric line.

To copy instead of move, hold down CTRL+SHIFT (Windows) / OPTION+SHIFT (Mac).

See also:

“Time-syncing lyrics” on page 234

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Adding lyrics” on page 230

“Lyrics” on page 221
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Time-syncing lyrics

Time-syncing lyrics means that the lyrics occur at the same time as the corresponding vocal is heard during playback. There are 
different ways to synchronize lyrics with the music. The two most common workflows are:

Automatically populate lyrics with text from the Lyrics Scratch Pad. You can create new lyric lines or replace existing 
selected lyric lines with selected text from the Lyrics Scratch Pad. This is the fastest method. For details, see “Syncing existing 
text” on page 234.

Manually type and align each lyric line, one line at a time. Manually type the lyric text, one line at a time, and move to the 
correct position. This is the slowest method, but provides the most control. For details, see “Line-by-line authoring” on page 238.

Recommended workflow

1. Type or paste all the lyric text into the Lyrics Scratch Pad

2. Add empty placeholder lyric lines during playback

3. Apply the Lyrics Scratch Pad text to the selected lyric lines

You can mix and match workflows as needed. The following describes each workflow in greater detail.

Syncing existing text

You can quickly bulk add text from the Lyrics Scratch Pad to existing lyric lines:

1. Open the Lyrics Inspector.

2. Type or paste all the lyrics into the Lyrics Scratch Pad. Format the text so each line only contains the text that you want to appear 
in each unique lyric line (each line in the teleprompter). One line should typically contain a single sentence/phrase.
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3. Start playback from the beginning of the song. While listening to the vocal track, click the Add a New Lyric Line button  
whenever you want a new lyric line to occur, such as the start of each sung vocal phrase. Please note that the The Snap to Grid 
setting is obeyed. There should be exactly one lyric line for each line in the Lyrics Scratch Pad.

You can also perform this step manually by dragging in the Lyrics track timeline.

4. After the last empty lyric line has been added, stop playback. The Lyrics track now contains empty (“interlude”) placeholder lyric 
lines, ready to be populated with text from the Lyrics Scratch Pad.

5. Select all the empty lyrics lyric lines (Tip: press CTRL+A (Windows) / CMD+A (mac) to select all).
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6. Select the Lyrics Scratch Pad text that you want to apply.

Important: The number of selected lyric lines must equal or be less than the number of selected Lyrics Scratch Pad lines. For 
details, see “Add Selection as Lyric Lines button” on page 228.

7. Click the Add Selection as Lyric Lines button .

The selected Lyrics Scratch Pad text is applied to the selected lyric lines. The lyrics are now synchronized with the music.
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If you need to fine-tune the duration or start time of any lyric lines, simply drag or resize the lyric lines in the Lyric track timeline. For 
details, see “Moving a lyric line” on page 232 and “Resizing a lyric line” on page 232.

Note:

Lines with no text become “interlude” events, spanning the range between lyric lines.

Empty space between lyric lines results in a paragraph break in the Lyrics Prompter.
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Line-by-line authoring

You can manually add one lyric line at a time.

Line-by-line authoring in the Lyrics Inspector
1. Open the Lyrics Inspector.

2. Click the Add a New Lyric Line button  to insert a new lyric line. The new lyric line immediately presents a text editor.

If the editor is closed, select the lyric line and press CTRL+ENTER (Windows) / CMD+RETURN (Mac) to show the text editor.

3. Type the lyric text. Note that multiple lines of text can be added to a single lyric line by pressing SHIFT+ENTER (Windows / 
SHIFT+RETURN (Mac).

4. Press ENTER (Windows) / RETURN (Mac) to save the lyric line and close its text editor.

5. Press ENTER (Windows) / RETURN (Mac) again to add another lyric line immediately following the previous lyric line.

Continue in this fashion to enter multiple lines.

‘

See also:

“Lyrics Editor keyboard shortcuts” on page 227.

Note: The default duration for new lyric lines is inherited from the last selected lyric line.
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Line-by-line authoring in the Lyric track timeline

You can manually add, move and resize lyric lines in the Lyric track timeline.

1. Show the Lyrics track.

2. Double-click or drag in the Lyric track timeline to add a new lyric line.

3. To change the lyric text, right-click the lyric line and select Change Lyric Text.

4. Type the lyric text, then press ENTER (Windows) / RETURN (Mac) to save the lyric line and close its text editor.

Continue in this fashion to enter multiple lines.

See:

“Lyrics track” on page 223

“Lyrics Inspector” on page 225

“Lyrics Editor” on page 226

“Lyrics Scratch Pad” on page 228

“Lyrics Prompter” on page 229

“Adding lyrics” on page 230

“Editing lyrics” on page 231

“Lyrics” on page 221

Tip: Use the vocal track audio waveform as a guide when adding, moving, and resizing lyric lines.
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Exporting
You can export a project in a variety of audio file formats in order to publish and share your music.

See:

“Exporting audio” on page 242

“Publishing to BandLab” on page 79

“Exporting MIDI” on page 244

“Transferring projects between Cakewalk Sonar and Next” on page 245

See also:

“Exporting arrangements” on page 124

“BandLab library import/export” on page 77

“Creating a project preview file” on page 24
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Exporting audio

To export audio, do one of the following:

Select File > Export Audio

Click the Share button  and select Export Audio

Press CTRL+E (Windows) / CMD+E (Mac) to open the Export Audio dialog box

The Export Audio dialog box contains the following options.

Source

The Source menu lets you specify what to export:

Master. Export the project as a single audio file.

All Tracks. Export all tracks as separate files. The track name is appended to the file name.

All Selected Tracks. Export only the selected tracks as separate files.

<list of buses>. Select a bus to export.

<List of tracks>. Select a track to export.
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Range

The Range section lets you specify the time range to export:

Entire project. Export the full duration of the project.

Time selection. Export only the selected time range.

Loop region. Export only the active loop region.

Format

The Format section lets you specify the file type, sample rate, and bit depth:

File type. Select from one of the following export formats:

WAV. The standard digital audio format used under Windows for burning CDs, with a file extension of .wav.

AIFF. Audio Interchange File Format, co-developed by Apple Inc., is most commonly used on Apple Macintosh computer 
systems. The file extension is .aif.

FLAC. FLAC stands for Free Lossless Audio Codec, which is somewhat similar to MP3, but lossless. Audio in a FLAC file is 
compressed without any loss in quality. The file extension is .flac.

Ogg-Vorbis. The Ogg Vorbis Audio format is a increasingly popular royalty-free format for compressed audio files. The file 
extension is .oga.

MP3. Highly compressed digital audio designed for quick downloads via the internet, with the file extension .mp3.

Sample Rate. Select the sample rate that you want your exported audio to use (22,050 Hz – 192,000 Hz).

Bit Depth. Select the bit depth that you want your exported audio to use (8 – 32).

Dithering. Whenever an audio signal is converted from a higher-bit resolution to a lower resolution, it is necessary to apply 
dither to avoid introducing undesirable quantization noise or harmonic distortion into the signal. Select one of the following 
dithering options:

None. No dithering is applied.

Rectangular. Essentially white noise, no noise shaping. Advantages: least CPU-intensive, lowest signal-to-noise ratio, 
preferable to shaped dither when successive dithering can occur (e.g. bouncing, freezing). Disadvantages: suffers from 
intermodulation distortion.

Triangular. Higher level than rectangular, no noise shaping. Advantages: low CPU-intensive dither, superior to Rectangular 
as it does not suffer from modulation noise effects. Preferable to shaped (Pow-r) dither when successive dithering can occur 
(e.g. bouncing, freezing).

 Include Project Preview. Save a project preview file that allows you to preview the project in the Quick Start screen without 
having to open the project. For details, see “Creating a project preview file” on page 24.

Normalize

Raise or lower the overall volume in order to reach a target perceived amplitude or volume level. For details, see “Normalizing audio” 
on page 207.

None. Do not normalize.

Peak. Normalize to the highest peak.

RMS. Normalize to the average loudness level.

Target Level. Specify the normalization target level. It is generally not a good idea to normalize to 0 dBFS peak in a multi-track 
recording. It’s good practice to reserve at least 3–6 dB of headroom to allow for further audio processing that may increase the 
level.

Note: Normalize raises the noise floor. That is, while it increases the volume of the signal, it also boosts the noise it contains.

If the project contains any loud signals, Normalize may not seem to have any effect. This is because the volume increase is 
determined by the loudest audio in the project.
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Additional Options

Click the Export button drop-down menu  to access the following options:

Bypass affects and mixer settings (stems only). Exclude effects, volume, pan, and automation from the export.

 Include effects tails. Add extra time to account to effect “tails”. Effect tails are the reverberations or signal delay that continue 
after the source has stopped. If your project uses track or clip plugin effects (reverb, delay, etc.) that result in effect tails, you will 
need to extend the duration of the exported clips in order to properly accommodate the effect tails. Otherwise, the exported clips 
will end prematurely, before the effect tail is finished.

Make mono. Convert the stereo signal to mono.

Export button

Click the Export button to export audio based on the selected settings.

See also:

“Publishing to BandLab” on page 79

Exporting MIDI

To export a MIDI clip, right-click the MIDI clip header and select Export to File.

Tip: Export tips when mastering:

• When sending your mix to a mastering engineer, export your mix at the sample rate you recorded at, without dither applied, 
at a bit depth of 32.

• When mastering a song yourself, reduce the sample rate based on the destination formatting requirements. If you plan to 
upload your music to streaming services, export your song at a bit depth of 24 and apply dither.
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Transferring projects between Cakewalk Sonar and Next

You can exchange projects between Cakewalk Next and Cakewalk Sonar by exporting projects as Cakewalk Interchange Format 
(CXF).

Cakewalk Interchange Format

The Cakewalk Interchange Format (CXF) is a Cakewalk cross platform inter-app project file format, used to exchange projects 
between Sonar and Next. CXF files exported from either application can be opened or imported in both apps.

What is stored in a CXF file?

CXF supports a subset of project data used by Sonar and Next, so app-specific feature settings and view-specific states will not be 
restored. 

The following data will be exported and imported:

Tracks

Audio

MIDI

 Instrument tracks

• Simple Instrument tracks (Sonar)

• Multi Instrument tracks (each track will represent a unique instance of the synth when opened)

• Split instrument tracks (not supported) 

Bus tracks (Next)

Patchpoints (Sonar; converted to buses)

Aux tracks (Sonar; limited support - treated like patch points and converted to buses) The aux track itself will not route to the 
patchpoint.

Track data:

Audio/MIDI clips.

Overlapping clips or take lanes are flattened prior to export.

Clip effects are rendered into the clips prior to export.

Automation envelopes

Track/Bus parameters

Volume

Pan

Mute

Solo

 Input Gain (Sonar only)

 Input Pan (Sonar only)

Track/Bus routing

Outputs

Hardware outputs are not preserved since they are not cross platform. Any hardware outs are automatically assigned to the 
first hardware output.

Sends to buses and patch points.

Important: CXF is a transitory format only used for exchange. It is not intended for archival storage or backing up since the 
format can change at any time.
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Plugins in track and bus effects racks. On opening a CXF file, any missing plugins will be listed. Note: when moving a project 
between Windows and Mac any plugins used must be installed on both platforms in the same format to successfully load them. 

VST2

VST3

DX

AU plugins (only available in Next Mac) 

DX plugins (only available in Sonar)

ProChannel (not supported)

FX Chains (not supported)

Plugin settings are stored within the CXF and will be restored if the plugin is available.

 Instruments and instrument settings are stored within the CXF.

Exporting a project in CXF format

To export a project to Cakewalk Interchange Format, do one of the following:

Go to File > Export to CXF.

Click the Share button  in the main toolbar and select Export Cakewalk Interchange Format.

CXF files have a .cxf file extension.

When the export is complete, a notification appears with a link to open the export folder.

Opening a project in CXF format

To open a project in Cakewalk Interchange Format:

1. Use the File > Open Project command to open the Quick Start screen’s Recent page.

2. Click the Browse button  to open the Open Project dialog box.

3. Navigate to the .cxf project file you want to open, then click Open.

Opening a CXF file creates a new project, which must then be saved in Next’s native project file format (.cnp).

Importing a project in CXF format

To import a project in Cakewalk Interchange Format into an existing Next project, drag a .cxf file to the track area.

An imported CXF file merges its data into the existing project file.
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Preferences
You can specify various options and preferences in the Preferences dialog box. Some options are global while others are per 
project.

To open the Preferences dialog box, go to Edit > Preferences or press P or CTRL+, (Windows) / CMD+, (Mac).

Settings and options are organized into the following sections:

“Audio settings” on page 248

“MIDI settings” on page 250

“Plugins settings” on page 251

“Project settings” on page 253

“Display settings” on page 254

“Shortcuts settings” on page 256

“Diagnostics settings” on page 257
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Audio settings

The Audio page lets you configure your audio hardware device and latency setting.

The Audio section lets you configure audio device settings.

The Audio section contains the following settings:

Audio Device

Audio Driver. Specify the desired audio driver mode. The following options are available:

CoreAudio (Mac only)

Windows Audio (Windows only)

Windows Audio (Exclusive Mode) (Windows only)

Windows Audio (Low Latency Mode) (Windows only)

DirectSound

ASIO

Audio Input Device. Specify the desired audio recording device. Click Setup to select input channels.

Audio Output Device. Specify the desired audio playback device. Click Setup to select output channels.

Sample Rate. Specify the sampling rate for the audio device. Consult your audio hardware documentation for supported 
sampling rates. For details, see “Specifying the recording format” on page 50. 
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Latency

Audio Buffer Size. Set the mixing latency.

Output Latency. Shows the output latency at the current buffer size.

 Input Latency. Shows the input latency at the current buffer size.

Total Latency. Shows the total latency at the current buffer size.

Driver Latency Offset. Specify the latency compensation while recording.

Recording

File Format. Specify the recording file format:

WAV. The standard digital audio format used under Windows for burning CDs, with a file extension of .wav.

AIFF. Audio Interchange File Format, co-developed by Apple Inc., is most commonly used on Apple Macintosh computer 
systems. The file extension is .aif.

FLAC. FLAC stands for Free Lossless Audio Codec, which is somewhat similar to MP3, but lossless. Audio in a FLAC file is 
compressed without any loss in quality. The file extension is .flac.

File Bit Depth. Specify the recording bit depth (16, 24, or 32). For details, see “Specifying the recording format” on page 50.

Auto-Arm Tracks. Automatically arm the selected track for recording. For details, see “Auto arm track for recording” on page 
54.

Loop and Stretch

Default Loop Stretch Behavior. Specify if loop enabled clips should follow tempo changes by default. By default, looped audio 
clips follow tempo changes in the project.

Stretch audio to follow tempo changes. A clip’s absolute position stays constant, and its M:B:T position shifts. This is the 
default for non-looped audio clips.

Do not stretch to follow tempo changes. A clip’s M:B:T position stays constant, and its absolute position shifts.

Audio Engine

Use Multiple Cores. If you have a multiprocessor computer, select this option if you want Next to distribute audio processing 
across multiple cores.

Stop playback if audio drops out. Stop playback if audio drops out.

Suspend audio engine when app loses focus. Allow other apps to access audio device drivers when Next does not have 
focus. The audio engine will only suspend if nothing is playing, and will not suspend when recording.

Important: Any manual latency tweaks will potentially be different for different buffer sizes or sample rates because it depends 
on the driver. You should only use manual latency if you see that recorded audio through a loopback test not lining up with the 
original source.
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MIDI settings

The MIDI page lets you select your MIDI input device.

The MIDI section contains the following settings:

MIDI Devices

Default MIDI Input for new tracks. Specify the desired MIDI input device. The default settings is All Inputs, which allows you 
to use any available MIDI device.
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Plugins settings

The Plugins page lets you configure VST plugin settings and scan for VST plugins.

The Plugins section contains the following settings:

Scanned Plugin Formats

VST. Enable VST2 plugins.

VST3. Enable VST3 plugins.

AudioUnit (Mac only). Enable AudioUnit plugins.

Plugin Scan

Scan for Plugins on Startup. Automatically scan for new plugins when Next starts. Scanning occurs in the background.

Scan for Plugins. Click Scan Now to scan for new plugins. For details, see “VST plugin scanner” on page 203.

Custom VST Plugin Locations. Add a new VST plugin folder to be scanned.

Reset Plugin Catalog. Remove all scanning records and settings from all your plugins. Use only if you want to completely start 
over.
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Plugins Display

Open Editor on Insert. After inserting a VST plugin, immediately open its UI editor.

Hide Editor when Track Focus Changes. When changing track focus, automatically close any VST plugin editor that doesn’t 
belong to the focused track.

Plugin Management

Open Plugin Manager. Open the Plugin manager, which lets you manage audio effects, instrument, and templates (toggle 
plugin favorite status, visibility in Browser, DPI awareness, and assign tags). For details, see “Plugin Management” on page 209.

Open Plugin Quarantine Manager. Open the Plugin Quarantine Manager, which lets you rescan quarantined plugins. For 
details, see “Plugin Quarantine Manager” on page 210.
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Project settings

The Project page lets you specify if a project should load on app startup, and specify default folder locations.

The Project section contains the following settings:

Startup

Open Most Recent Project at Launch. Open the last opened project when Next starts. 

Show Quick Start Screen at Launch. Show the Quick Start screen when Next starts.

Folders Management

Project Files. The default path for saving Next projects.

Loop Cache. The default path for downloading loops from the Loop Browser.

Backup

Enable Project Backups. Save a backup copy of the project whenever you save the project. Up to ten backups are saved to a 
\Backups subfolder inside the project folder.

Note: If Next crashes due to an unexpected issue, it will automatically skip loading the last project to prevent potential crashes 
or hangs on load.
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Display settings

The Display page lets you configure various display settings.

The View section contains the following settings:

Tracks View

Track Number Display. Show/hide track numbers.

Track Numbering Mode. Track folders affect how track numbers are shown. Track numbers can be either indexed or 
sequential. For details, see “Track numbers” on page 19.

Off (Indexed). Tracks are numbered relative to their parent track folder.

On (Sequential). Each track folder and track increases the counter.

Notifications

 Ignore Device Change Notifications. Don’ show notifications when input and output devices are added.

Restore Notifications. Restore all notifications that have been suppressed.
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Graphics

Auto-Hide Scrollbars When Not scrolling. Automatically hide scrollbars when not scrolling.

Use Standard Title Bar (Windows only). Enable the standard Windows title bar.

UI Rendering Engine. Specify the default graphics rendering engine that should be used to draw text and images on the 
screen:

Software Renderer. CPU rendering.

OpenGL Renderer. Hardware-accelerated GPU rendering of 2D and 3D vector graphics.

CoreGraphics Renderer (Mac only). Apple’s vector-drawing framework.

Selection

Clip Selection After Split. Specify what is selected after a clip is split into two parts:

None. Neither clip is selected.

Left Clip (default). Only the left clip is selected.

Right Clip. Only the right clip is selected.

Both Clips. Both the left and right clips are selected.
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Shortcuts settings

The Shortcuts page lets you assign custom keyboard shortcuts.

The Shortcuts section shows current keyboard shortcut assignments and lets you assign custom shortcuts.

Adding a shortcut

To add a new shortcut, click a command’s corresponding  button, press the new shortcut, then click OK.

Changing a shortcut

To change an existing shortcut, click the shortcut and select Change this key-mapping.

Removing a shortcut

To remove an existing shortcut, click the shortcut and select Remove this key-mapping.

Resetting shortcuts

To reset all shortcuts to their default assignments, click Reset to defaults.

See:

“Keyboard shortcuts” on page 265.

Tip: To quickly open the list of shortcuts, select Help > Keyboard Shortcuts.
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Diagnostics settings

The Diagnostics page lets enable tools that can assist in detecting potential issues.

The Diagnostics section shows various error diagnostic settings.

Error Handling

App Exception Handling. Show a prompt and save a crash diagnostic dump file if an app crash occurs. If disabled, crashes 
are handled by the operating system.

 

257Preferences



258 Preferences



Menu commands
The main app menu contains the following commands.

See:

“File menu” on page 259

“Edit menu” on page 260

“Insert menu” on page 260

“View menu” on page 262

“Transport menu” on page 263

“Help menu” on page 264

File menu

Command Description

New Project Create a new project.

Open Project Open an existing project.

Open Recent Project > Open a recently loaded project.

Save Project Save the current project.

Save Project As Save the current project with a new name.

Save As Project Template Save the current project as a template.

Export Audio Export the current project as a WAV file.

Publish to BandLab Publish the project to your BandLab library. Export is not possible if the project exceeds 12 tracks. For 
details, see “Publishing to BandLab” on page 79.

Export to CXF Export the current project to a Cakewalk Interchange Format (CXF) file, which can be opened in 
Cakewalk Sonar. For details, see “Transferring projects between Cakewalk Sonar and Next” on page 
245.

Exit Close Next.

Table 5. File menu commands 
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Edit menu

Insert menu

Command Description

Undo Reverse the last action.

Redo Reverse the most recent Undo command.

Cut Remove the selected objects and put them on the Clipboard.

Split Split all clips at the playback position.

Copy Copy the selected objects to the Clipboard.

Paste Place the contents of the Clipboard into the current project location.

Delete Delete the selected clip or track/bus/track folder.

Duplicate Duplicate the selected event(s).

Select All Select all tracks, clips, events, or plugins, depending on which view has focus.

Clear Selection Clear the selection.

Move to Track Folder Move the selected tracks/buses into a new track folder. 

Remove Folder Remove the selected track folder and move the contained tracks up one level.

Move Tracks out of All 
Folders

Move the selected tracks to the root level.

Bounce to New Tracks Bounce/consolidate multiple selected tracks to new tracks.

Bounce Tracks in Place Bounce the selected track(s) in place, in their entirety. For details, see “Bouncing audio” on page 206.

Process>

Normalize Audio Tracks Normalize all audio clips on the selected tracks. For details, see “Normalizing audio” on page 207.

Trim Silence Trim silence from both the beginning and end of the selected clip(s). For details, see “Trimming silence from a clip” 
on page 135.

Enable Ripple Edit Enable/disable ripple editing. For details, see “Ripple editing” on page 139.

Preferences Configure various app settings. For details, see “Preferences” on page 247.

Table 6. Edit menu commands 

Command Description

Insert Audio Track Insert a new audio track. For details, see “Inserting tracks” on page 28.

Insert Instrument Track Insert a new instrument track. For details, see “Inserting instrument tracks” on page 29.

Insert Sampler Track Insert a new sampler track. For details, see “Pad Controller” on page 171.

Insert Pad Controller Tracks Insert a new Pad Controller track. For details, see “XSampler” on page 156.

Insert Instrument Rack Track Insert a new Instrument Rack track. For details, see “Instrument Rack” on page 177.

Insert Track Folder Insert a new track folder. For details, see “Grouping tracks with track folders” on page 35.

Insert Bus Inset a new bus. For details, see “Inserting buses” on page 33.

Insert Track Template Insert a new track from a track template. For details, see “Inserting a track from a template” on page 33.

Table 7. Insert menu commands 
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Insert Audio/MIDI File Insert an audio or MIDI file.

Insert Empty MIDI Clip Insert an empty MIDI clip in the selected Instrument track.

Command Description

Table 7. Insert menu commands  (Continued)
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View menu

Command Description

Show Track Inspector Show/hide the Track Inspector.

Show Clip Inspector Show/hide the Clip Inspector.

Show Loop Browser Show/hide the Loop Browser.

Show Arranger Inspector Show/hide the Arranger Inspector.

Sow Lyrics Inspectors Show/hide the Lyrics Inspector.

Show Lyrics Prompter Toggle between showing the Lyrics Prompter and Lyrics Editor.

Show Arranger Track Show/hide the Arranger track.

Show Lyrics Track Show/hide the Lyrics track.

Show Tempo Track Show/hide the Tempo track.

Track Heights Restore last user defined height / Fit tracks to view / Collapse track heights.

Expand Track Folders Expand all track folders.

Collapse Track Folders Collapse all track folders.

Show Project Info Editor Show the Project Information editor.

Show Virtual MIDI Controller Open the Virtual MIDI Controller.

Toggle QWERTY to MIDI Input Enable/disable QWERTY MIDI input without opening the Virtual MIDI Controller.

Show Aim Assist Show/hide the Aim Assist line, which is a vertical line that shows the mouse pointer’s horizontal position in 
the Clips pane, and vertical and horizontal position in the Piano Roll editor.

Time Ruler Format>

Musical Time Display Measure:Beat:Tick time in the transport toolbar and time ruler.

Absolute Time Display absolute time in the transport toolbar and time ruler.

Samples Display sample time in the transport toolbar and time ruler.

Playback Options>

Smooth Scroll During playback, keep the playhead stationary and scroll the Clips pane and Piano Roll editor.

Follow Playhead - Tracks View Scroll the Clips pane when the playhead reaches the right edge.

Follow Playhead - Piano Roll View Scroll the Piano Roll view when the playhead reaches the right edge.

Table 8. View menu commands 
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Transport menu

Command Description

Play/Pause Start/pause playback.

Play/Pause (no rewind) Start/pause playback from current position (never rewind to the last start position, and don’t move the start position 
marker).

Jump Back Rewind the playback position and seek to loop positions and the playback marker en route to the project start.

Go to Start Go to the beginning of the project.

Jump Forward Jump forward and seek to loop positions en route to the project end.

Go to End Go to the end of the project.

Record Start/stop recording on any armed tracks.

Toggle Loop Playback Enable/disable playback looping.

Loop Selection Set the current time range selection as the loop range, and enable looping.

Loop Recording Creates 
Takes in Track Folder

When loop recording, place all takes in a track folder.

Mute Previous Takes During 
Loop Recording

When loop recording, mute previous loop passes.

Enable Punch Recording Enable/disable punch recording.

MIDI Recording Overdub When recording MIDI on instrument tracks, merge new material with existing material. Existing clips on the track are 
left unchanged and all newly recorded material is stored in new clips. While recording, you will be able to hear 
material from existing clips.

Toggle Metronome Enable/disable the metronome.

Resume Playback at Last 
Start Position

When playback starts, jump to the previous playback start location. The start location is indicated by a small green 
play icon above the time ruler. The start location updates when you click in the Clips pane.

Stop Playback on Engine 
Dropout

Stop playback if there is an audio engine dropout.

Table 9. Transport menu commands 
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Help menu

Command Description

Help Open the online documentation.

Report a Problem Report bugs via an online form in your default web browser.

Keyboard Shortcuts Show a list of keyboard shortcuts.

Check for Updates Check for software updates.

View Release Notes Show the release notes.

Activation>

Export Activation Request Export a file that can be used to activate Next from a different online computer.

Import Activation Response Import an activation file that was created on a different online computer.

Sign In / Sign Out Cakewalk Next® needs to be re-activated every 6 months in order to unlock all available features, such as saving 
and exporting. This normally happens automatically if you are signed in to your BandLab account and connected to 
the internet.
Cakewalk Next® supports SSO (Single Sign-On) for activation, which allows you to log in via any service supported 
by BandLab as your sign-in authority. Google, Facebook, Apple ID, mobile phone and BandLab user/password 
credentials are currently supported.
SSO is only used for Cakewalk Next® activation, and under normal circumstances you will only need to sign in once. 
Cakewalk Next® will attempt to refresh your activation status silently and automatically on occasion during start up. 
Use the SSO login as you have done with your BandLab account in the past.

About Cakewalk Next Open the About Cakewalk Next dialog box.

Table 10. Help menu commands 
264 Menu commands



Keyboard shortcuts
Figure 57. US keyboard layout.

To customize keyboard shortcut assignments, go to Help > Keyboard Shortcuts., or go to Edit > Preferences > Commands. For 
details, see “Shortcuts settings” on page 256.

See:

“File / Project” on page 266

“Track Creation” on page 266

“General Editing” on page 266

“Bounce Operations” on page 267

“Clip Property” on page 267

“Track Property” on page 267

“Transport” on page 267

“Zooming” on page 268

“Piano Roll” on page 268

“Modifiers” on page 269

“Keyboard navigation” on page 269

See also:

“Lyrics Editor keyboard shortcuts” on page 227

Note: A plus sign (+) indicates that both keys must be held down at the same time. For example, CTRL+A.

Note: Keyboard shortcuts are based on the US keyboard layout. Other languages may use different layouts. Shortcuts are 
denoted by the key, not by the character they produce. Many keys produce different characters on non-US keyboards.
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File / Project

Track Creation

General Editing

Command Windows Mac

Create New Project CTRL+N CMD+N

Open Project CTRL+O CMD+O

Open BandLab Project CTRL+ALT+O CMD+OPTION+O

Open or Import BandLab Project CTRL+ALT+0 CMD+OPTION+0

Save Project CTRL+S CMD+S

Save Project As CTRL+SHIFT+S CMD+SHIFT+S

Publish to BandLab CTRL+B CMD+B

Export Audio CTRL+E CMD+E

Preferences CTRL+, (COMMA) CMD+, (COMMA)

Exit CTRL+Q CMD+Q

Show Project Information CTRL+SHIFT+I CMD+SHIFT+I

Table 11. File / Project shortcuts 

Command Windows Mac

Insert Audio Track CTRL+T CMD+T

Insert Instrument Track CTRL+SHIFT+T CMD+SHIFT+T

Insert Sampler Track CTRL+SHIFT+X CMD+SHIFT+X

Insert Pad Controller Track CTRL+SHIFT+P CMD+SHIFT+P

Insert Track Folder CTRL+SHIFT+G CMD+SHIFT+G

Insert Bus CTRL+ALT+T CMD+OPTION+T

Move to Track Folder CTRL+G CMD+G

Remove From Folder CTRL+U CMD+U

Table 12. Track creation shortcuts 

Command Windows Mac

Undo CTRL+Z CMD+Z

Redo CTRL+SHIFT+Z CMD+SHIFT+Z

Cut CTRL+X CMD+X

Split S S

Copy CTRL+C CMD+C

Paste CTRL+V CMD+V

Delete DELETE DELETE

Duplicate CTRL+D CMD+D

Select All CTRL+A CMD+A

Enable/disable ripple editing CTRL+R CMD+R

Table 13. General editing shortcuts 



Bounce Operations

Clip Property

Track Property

Transport

Command Windows Mac

Bounce Tracks in Place CTRL+ALT+B CMD+OPTION+B

Bounce Selected Clip(s) CTRL+B CMD+B

Normalize Audio Tracks CTRL+ALT+N CMD+OPTION+N

Normalize Selected Audio 
Clips

CTRL+SHIFT+N CMD+SHIFT+N

Bounce to New Tracks CTRL+SHIFT+B CMD+SHIFT+B

Table 14. Bounce operation shortcuts 

Command Windows Mac

Toggle Loop CTRL+L CMD+L

Table 15. Clip property shortcuts 

Command Windows Mac

Solo ALT+S OPTION+S

Mute ALT+M OPTION+M

Arm ALT+A OPTION+A

Table 16. Track property shortcuts 

Command Shortcut

Play/Pause SPACEBAR

Jump Back W

Go to Start SHIFT+W

Jump Forward E

Go to End SHIFT+E

Record R

Toggle Metronome K

Toggle Loop Playback L

Set loop range to selected time range or clips SHIFT+L

Move Playhead Forward on Grid RIGHT

Move Playhead Backward on Grid LEFT

Table 17. Transport shortcuts 
267Keyboard shortcuts



Zooming

Piano Roll

Misc

Command Windows Mac

Zoom In Horizontally CTRL+RIGHT CMD+RIGHT

Zoom Out Horizontally CTRL+LEFT CMD+LEFT

Zoom In Vertically CTRL+UP CMD+UP

Zoom Out Vertically CTRL+DOWN CMD+DOWN

Zoom to Selection F F

Expand/Collapse Tracks ALT+H OPTION+H

Fit Tracks Vertically SHIFT+F SHIFT+F

Table 18. Zooming shortcuts 

Command Windows Mac

Draw Tool D D

Toggle Midi Velocity Display ALT+V OPTION+V

Split Selected Note(s) SHIFT+S SHIFT+S

Merge Selected Notes SHIFT+ALT+M SHIFT+OPTION+M

Table 19. Piano Roll shortcuts 

Command Windows Mac

Show/hide Track Inspector F3 F3

Show/Hide Clip Inspector F4 F4

Show/Hide Loop Browser B or F5 B or F5

Dock/float Loop Browser CTRL+ALT+B CMD+OPTION+B

Show/Hide Arranger Inspector F6 F6

Show/Hide Lyrics Inspector F7 F7

Show Lyrics Prompter ALT+F7 OPTION+F7

Show/Hide Arranger Track A A

Show/Hide Lyrics Track ALT+L OPTION+L

Show/Hide Tempo Track T T

Show/hide Virtual MIDI Controller CTRL+M CMD+M

Toggle QWERTY to MIDI Input CTRL+ALT+M CMD+OPTION+M

Aim Assist X X

Table 20. General editing shortcuts 
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Modifiers

Keyboard navigation

You can use a keyboard to navigate between tracks and adjust track parameters, without using a mouse.

When a track strip has focus, use the TAB key to navigate to the next control, or SHIFT+TAB to navigate to the previous control. 
Press the ENTER (Windows) / RETURN (Mac) key to toggle any focused button, and use the UP/DOWN Arrow keys to adjust any 
focused slider.

Command Windows Mac

Snap override ALT CTRL

Drag copy CTRL OPTION

Constrain clip drag vertically or horizontally SHIFT SHIFT

Stretch clip CTRL+drag clip edge CMD+drag clip edge

Split a single clip at the mouse position ALT+left click clip header CMD+left click clip header

Split all selected clips at the mouse position ALT+SHIFT+left click clip 
header

CMD+SHIFT+left click clip 
header

Show crossfades for audio clips ALT+SHIFT OPTION+SHIFT

Edit the slope of an automation curve CTRL+drag up/down CMD+drag up/down

Adjust automation node with finer control SHIFT+drag up/down SHIFT+drag up/down

Drag move loop range CTRL+drag selection 
range left/right

CMD+drag selection 
range left/right

Parameter Quick Grouping (relative) CTRL CMD

Parameter Quick Grouping (absolute) CTRL+ALT CMD+OPTION

Allow mouse events to fall through the Piano Roll clip handle and act on the time ruler 
below

CTRL CMD

Table 21. Modifier keys 
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Quick Tutorials
If you want to get up and running quickly, please use the following short tutorials that are tailored to learning specific tasks in Next.

See:

“Configuring your audio and MIDI device(s)” on page 271

“Creating a project” on page 271

“Adding a track” on page 272

“Inserting and playing a software instrument / Playing the on-screen virtual keyboard” on page 273

“Recording” on page 274

“Adding automation” on page 275

“Adding effects” on page 276

“Exporting a project” on page 277

“Creating track folders” on page 277

Configuring your audio and MIDI device(s)

To configure your audio and MIDI hardware devices, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open 
the Settings dialog box.

Configuring the audio driver mode

To select an audio driver mode, select the Audio page, then click the Audio Driver drop-down menu.

Enabling audio devices

To configure your audio hardware device, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the 
Settings dialog box, then select the Audio page.

Enabling MIDI input device

To select your MIDI input device, go to Edit > Preferences or press CTRL+, (Windows) / CMD+, (Mac) to open the Settings dialog 
box, then select the MIDI page.

For details, see “Enabling input and output devices” on page 24.

Creating a project

To create a new project, do one of the following:

Select File > New Project.

Press CTRL+N (Windows) / CMD+N (Mac).

You can also open or import a project from your BandLab library. For details, see “Importing from BandLab” on page 82.

For details, see “Creating and saving projects” on page 24.
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Adding a track

To insert a new track, click the Insert Track button  and select the desired track type:

Mic/Line In . Record your voice or any sound using a microphone. Click the icon to create a blank track. Use the submenu 
to select any available track template.

 Instrument . Play and record a virtual instrument using a MIDI device or your computer keyboard.

Sampler . Use MIDI to play back loops, one-shots, audio clips or local audio files.

Pad Controller . Use MIDI to trigger up to 16 sampler or instrument pads.

 Instrument Rack . Use MIDI to trigger up to 16 layered instruments simultaneously within a single track.

Bus . Create a bus that can be used to process many tracks.

Track Folder . A track folder may contain other tracks, buses, and folders. Useful for project organization and mixing.

For details, see “Inserting tracks” on page 28.
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Inserting and playing a software instrument / Playing the on-screen 
virtual keyboard

To enable virtual MIDI input and show the Virtual MIDI Controller, do one of the following:

Click an instrument track’s track type icon  in the track inspector

Select View > Show Virtual MIDI Controller

Press CTRL+M (Windows) / CMD+M (Mac)

To enable QWERTY to MIDI input without showing the virtual keyboard, do one of the following:

Select View > Toggle QWERTY to MIDI Input

Press CTRL+ALT+M (Windows) / CTRL+CMD+OPTION+M (Mac)

To insert an instrument track:

1. Do one of the following:

Click the Insert Track button , then select Instrument .

Select Insert > Insert Instrument Track.

Press CTRL+SHIFT+T (Windows) / CMD+SHIFT+T (Mac).

2. In the Instrument Browser dialog box, select the desired instrument

3. Click Add.

1. Click Insert Track button and select Instrument 2. Select instrument 3. Click Add

 

1 2

3
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Playing the Virtual MIDI Controller with a computer keyboard

To play the polyphonic keyboard, click the on-screen keys or press the corresponding keys on your computer keyboard.

For details, see “Virtual MIDI Controller” on page 69.

Recording

To arm a track for recording, click its Record Arm button . A track’s Record Arm button turns red  to indicate that the track is 
armed for recording.

To start recording, do one of the following:

Click the Record button . The button is red when enabled .

Press R.

If the metronome count-in is enabled, it will play the count-in.

Play or perform the material you want to record. 

During recording, the recorded signal is shown in red in the Clips pane:

To stop recording, do one of the following:

Click the Play/Pause button .

Select Transport > Play/Pause.

Press SPACEBAR.

Click the Record button . Recording stops, but playback continues.

Select Transport > Record. Recording stops, but playback continues.

Press R. Recording stops, but playback continues.

Listen to the new material. If you’re not happy with the recording, select Edit > Undo to erase the new material. Select Edit > Redo 
command to restore the recording and toggle between Undo and Redo as many times as you like.

For details, see “Recording” on page 49.
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Adding automation

To show/hide automation on all tracks, click the Show/Hide Automation button .

To create a new automation envelope, click a track’s Automation menu and select the desired parameter.

Recording automation
To record automation:

1. Do one of the following:

To arm a single control for recording, double-click the control. The controls show a small red circle when armed.

To arm all controls for recording, click the Show/Hide Automation Lanes button  drop-down menu  and select 

Capture automation changes during playback/record. A red circle  indicates that automation recording is enabled, 
and all automatable controls show a small red circle.

2. Do one of the following:

 If you want to record automation in real-time, start playback.

 If you want to adjust automation at only a specific location on the timeline, position the playhead at the desired location.

3. Adjust the desired automatable fader/knob/button.

4. When you are finished with recording automation, stop playback, then click the Show/Hide Automation button  drop-down 

menu  again and disable Capture automation changes during playback/record.

For details, see “Automation” on page 211.

 

 

Automation recording disabled: Automation recording enabled:
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Adding effects

To add an effect at the end of the effect chain:

1. Select the target track/bus/track folder.

2. Open the Track Inspector and click the Add Effect button .

3. Make sure Effects is selected.

4. Select the desired effect and click Add.

For details, see “Effects” on page 193.
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Exporting a project

To export audio, select File > Export Audio or press CTRL+E (Windows) / CMD+E (Mac) to open the Export Audio dialog box.

For details, see “Exporting” on page 241.

Creating track folders

Inserting a new track folder

To insert a new track folder, do one of the following:

Click the Insert Track button , then select Track Folder .

Select Insert > Insert Track Folder.

Press CTRL+SHIFT+G (Windows) / CMD+SHIFT+G (Mac).

Placing tracks into a new track folder
To place tracks into a new track folder, select the tracks you want to group, then select Edit > Move to Track Folder or press 
CTRL+G (Windows) / CMD+G (Mac).

For details, see “Track folders” on page 17 and “Grouping tracks with track folders” on page 35.

See:

“Configuring your audio and MIDI device(s)” on page 271

“Creating a project” on page 271

“Adding a track” on page 272

“Inserting and playing a software instrument / Playing the on-screen virtual keyboard” on page 273

“Recording” on page 274

“Adding automation” on page 275

“Adding effects” on page 276

“Exporting a project” on page 277

“Creating track folders” on page 277

“Quick Tutorials” on page 271
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